MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Cinema 4D Hypernurbs problem

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Fabrice GueurCinema 4D Hypernurbs problem
by on Jan 27, 2012 at 6:21:07 pm

Hello all !

I am discovering Cinema 4D, and I started my first model... I'm coming from Maya, and in Maya there is an option to smooth an object. During the modeling phase it is very useful as I can watch my object with more polys than I use. Then I can deactivate it, and keep modeling.

I know that smoothing doesn't exist in C4D. Instead, I've understood you could play with an Hypernurbs, and place the model inside it to be "smoothed". It is not destructive, and it suit me very well...

Unfortunately, I'm having some weird artifacts using it. It is way more easier to see it, so I took two screens.

First one : the model not using hypernurbs. It is the very start of the modeling and the process is totally incomplete. But I wanted to see what it would look like all smoothed.
Here is the pure poly screen :

Second one : I don't change anything, and place the object inside an hypernurbs. Here is the result... Explanation comes after.

As you can see, there is some kind of a problem near the wheels. What is strange in here, is that all the extruded part is correctly rendered. The very same happens to the vertices I manually attached. I started with the front wheel (on the left). The basic object is a tube, which I've flatten out, and started to extrude itself. I gave him its shape afterwards in the 3D space. The whole left part of the wheel is not extruded. It is the same object. The extrusion process starts after the gray part you can see on the left.

So, I'm wondering what is happening to my model, or what did I did wrong... Or even better : how could I solve this ?

Many thanks for your help


Return to posts index

Darby EdelenRe: Cinema 4D Hypernurbs problem
by on Jan 27, 2012 at 7:13:36 pm

The only possible problems that come to my mind would be either HyperNURBs Weighting gone awry or that some of your vertices are not connected. I have a suspicion it may be the latter based on the funky Phong shading around the problematic vertices even pre-smoothing.

Easy way to check for the first if you've applied any HyperNURBs weighting is to select the tag on the object.

Easiest way to fix the latter would be to:

1) Select the object and run Functions > Optimize with the last check box selected and a Tolerance of 0. This will weld any vertices that occupy the same space together.

2) Put a Connect object in the hierarchy as a child of the HyperNURBs and a parent of your model. Make sure that Weld is enabled on the Connect object and set your Tolerance low (0 should work).

When you use Extrude NURBs (as well as many of the primitives) the individual faces are not connected to one another, the vertices along the edges just occupy the same space.

Darby Edelen

Return to posts index

Fabrice GueurRe: Cinema 4D Hypernurbs problem
by on Jan 28, 2012 at 3:01:30 am

Thank you for this very fast answer. I tried the function optimize, but it didn't change a thing. As well as for the connector stuff, it does not change either.

I tried in hypernurbs mode to select the problematic edges. When I select one, the other one comes automatically selected. And when I do a weld on it, it is actually welding together, but totally messes up the vertices near it. So there is something definitely on those...

I have different ideas (I have a curving right there, maybe the curving is to steep... I will try to add some resolution there to have intermediate deviation in the angle, and see if it does it. I will also try to start the model again, since I might have gone wrong in some extrusion... I'll have a look at those both later after my day at work :-)

I keep you posted and many thanks for your answers

Return to posts index

Fabrice GueurRe: Cinema 4D Hypernurbs problem
by on Jan 28, 2012 at 2:14:44 pm

I finally found out the problem. Because I don't like when I don't understand, I've analyzed the model to the pixel... And found out a weird stuff. I found a border on the back of the wheel, which should not be there. After having deleted those, I finally understood what was happening.

It seems that for a reason I don't know, I wrongly attached the wrong vertices. Or did a wrong extrusion at the very start of the modeling process. Nevertheless, the vertices were wrongly attached, and the shape was curving in an angle of nearly 190°, which can't be smoothed by the hypernurbs (as long as I know, hypernurbs can handle up to angles of 180°). I totally deleted those faces, and restarted the extrusion. The welded the point together, and it is now working as it should...

It was a mistake of mine, and I'm glad having it found.

The only thing left now is that I notices some vertices still there, no face being attached (I deleted the faces, not the vertices). Is there any method to clean those "lost" vertices ?

Thanks a lot


Return to posts index

Brian JonesRe: Cinema 4D Hypernurbs problem
by on Jan 28, 2012 at 5:24:47 pm

Sure, Optimize or just select them by hand and delete them

Return to posts index

Fabrice GueurRe: Cinema 4D Hypernurbs problem
by on Jan 28, 2012 at 7:08:53 pm

Thanks ! Working perfectly fine now ! Many thanks for the help ! :-D

Return to posts index

Brian JonesRe: Cinema 4D Hypernurbs problem
by on Jan 28, 2012 at 2:59:50 pm

you have an un-optimized mesh or a different number of points in one part of the mesh compared to the unattached part (though it sure does not look like it in your screen shots). Or it's more than one object (we assume it's not). Try Point mode - select all the points in the object, then run an Optimize with the default value of 0.1 (or even increase that). If that doesn't do it there is something I can't see in the screen shots and can you post the scene file?

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved