MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

How do I prevent clones from intersecting

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Frank RuggieroHow do I prevent clones from intersecting
by on Dec 27, 2011 at 9:38:26 pm

How Cinema People.

Am I missing a step? I want a whole bunch of cylinders to lie on the floor in a stack (think haystack).
I put my cylinders in a mograph cloner, then I put a random effector on it. When I make my haystack, some of the cylinders go through each other.

I then put a mograph rigid body tag on the cloner and set the force to FOLLOW ANIMATION and the strength to 0. But the clones still intersect.

Can anyone guide me in the right direction?

Thanks in advance.

FRank


Return to posts index

Brian JonesRe: How do I prevent clones from intersecting
by on Dec 28, 2011 at 5:36:58 am

it depends a lot on the kind of haystack you mean (and a bit on the version of C4D), can you post the scene?


Return to posts index

Frank RuggieroRe: How do I prevent clones from intersecting
by on Dec 28, 2011 at 2:09:02 pm

Hi Brian.

Thank you for responding. I did post the project file here:

http://db.tt/7pr1Ubwx

If you look at frame 0, you will see that all of the clones still intersect even with the rigid body tag applied to the cloner object.

I guess what I am trying to do, is to have them not intersect, and upon playing it down, not have them explode outward. I just want them to sit there so I can do a camera move around the stack.

Thanks for your help.

Frank



Return to posts index


Brian JonesRe: How do I prevent clones from intersecting
by on Dec 28, 2011 at 5:34:28 pm

Dynamics only work with the passing of time (if they were able to work in the frame all the dynamics objects would fall to the floor with gravity - and you might actually want a bunch of objects to explode outwards once you start the timeline) so at frame zero the dynamic tags haven't had a chance to work at all and you already have intersecting cylinders from the setup of the cloner. The way to make piles of things is to group your clones (without intersecting) and let them drop - they'll get pretty random on their own - or to emit them from a particle emitter over time. You're also going to have to change the bounce and friction settings - make bounce almost zero and friction very high - or all those cylinders are going to mostly slide/roll off each other and end up as pretty much one layer on the floor.


Return to posts index

Tillman StaffenRe: How do I prevent clones from intersecting
by on Jan 26, 2012 at 9:53:11 am

Haven't seen the Cinema Scene, but I think you can solve this problem, by turning down the overall gravity "Strg + D" under the dynamics tab to 0. Increase follow position (under Forces in the dynamic tag), so that it is above 0. Than hit play and wait until non of the cloners are intersecting any more. Hit stop and go to the Dynamics tab in the dynamic tag of your cloners and press the Define initial state (or something like that) button. Turn back on gravity and it should work...


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]