MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Random movements that I haven't set between Keyframes?

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Danny LuksaRandom movements that I haven't set between Keyframes?
by on Dec 8, 2011 at 3:44:27 am

I'm animating a sphere right now that jumps around on screen a bit. I'm new to Cinema 4D.
I've run into an issue; between keyframes, some grid parameters will change when I haven't set them to do so, then change back.

Here's what I mean:
If there is a keyframe at frame #1 and at frame #10 that causes a change in the Y axis value, and then there is a keyframe at frame #10 and one at frame #15 and the keyframe on frame 15 has the same values as the one on frame 10, in the frames between frames 10 and 15, or between the set keyframes, there will be a change in the values, causing the object to move out of place. About halfway through the middle, they will change back.

How can I fix this?


Return to posts index

Adam TrachtenbergRe: Random movements that I haven't set between Keyframes?
by on Dec 8, 2011 at 5:03:22 am

It's probably an issue with keyframe interpolation. By default Cinema uses a spline interpolation that gives everything an ease-in/out. Try selecting the keyframes in the timeline and setting the interpolation in the attributes manager to linear.


Return to posts index

Danny LuksaRe: Random movements that I haven't set between Keyframes?
by on Dec 9, 2011 at 7:10:28 am

So... how does one go about doing that? :) I'm brand new.


Return to posts index


Brian JonesRe: Random movements that I haven't set between Keyframes?
by on Dec 9, 2011 at 4:57:36 pm

you need to open up the timeline window and select the keyframes there. There are controls in the timeline itself and in the Attribute Manager with slight differences depending on the version of C4D you are running. The Help will have something (just search Timeline in the Help)


Return to posts index

Simon MullinsRe: Random movements that I haven't set between Keyframes?
by on Dec 13, 2011 at 3:32:24 am

I'm new to Cinema 4D as well so I'm proably not the best person to help you but you could try adding a keyframe inbetween the 10 and the 15 and setting it to the correct y-axis value ?


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]