MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Boole modeling not working with dynamics tags, probably an easy fix

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Todd Weisse
Boole modeling not working with dynamics tags, probably an easy fix
on Aug 3, 2011 at 1:42:50 am

Hey everyone, I'm new to C4D and need a little help. Im trying to make part of a wall fall out from the rest, like it got hit with something heavy. I did this by modeling a chunk of the wall i wanted to fall out. It has a flat face (the wall) and a jagged, rough back, the inside of the wall. I lined up the chunk with the wall so the jagged side was inside the wall, and made a copy of the chunk. I then used the boole commands to subtract the chunk from the wall, leaving a wall with a hole. then I fractured the copied chunk with thrausi (fracturing plugin). I thought I could just add a floor, and dynamics tags to everything and just simulate the pieces falling out, but they explode out super fast, even though there is a perfect hole in the wall for them. I think that when i add the collider tag to the wall (now a boole object) , It is taking the collision from the original wall, and not the final boole geometry. Is there a way to fix this? Thanks for any help!


Return to posts index

Greg Burrus
Re: Boole modeling not working with dynamics tags, probably an easy fix
on Aug 3, 2011 at 11:23:52 am

do you have the tag setup to trigger on collision. That may be the issue if it's exploding before it's hit. You also might want to ad a slight margin of spacing between the shape that will explode and the main wall. Something really small that won't be noticed but will a lot not to intersect with any other geometry.


I would suggest making the boole object editable after duplicating it since if you have it still as a boole it's kind of memory intensive when using dynamic depending on the complexity of it.

Hope that helps.

Greg

http://mogra.g2bproductions.com/ - Blog
http://g2bproductions.com/ - Portfolio


Return to posts index

Brian Jones
Re: Boole modeling not working with dynamics tags, probably an easy fix
on Aug 3, 2011 at 2:43:10 pm

what are the Shape settings in the Dynamics Body/Collision tab. It should be Static Mesh for the Boole


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]