MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Transparency issues...

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
dean chapmanTransparency issues...
by on Jul 18, 2011 at 7:19:16 am

I'm a little confused as to how transparent objects work with reflective objects...

I have a plane with a reflective material, serving as the floor.

i have another plane which has a texture with an alpha applied to it. This plane is perpendicular to the "floor" plane, and the texture is simply a photo of a person with an alpha channel.

Behind the "person" plane is yet another plane, serving as a wall.

My problem is that the image of the wall plane is being reflected onto the floor by the "person" reflection.

This sounds confusing, so i've attached a picture...

You can see the checkered wall (behind the man) is being reflected on the floor......and the reflection occupies the same area in which the transparency of the person occupies.

Any ideas how to remedy this?



Thanks!

-Dean


Return to posts index

Sebastian HageneuerRe: Transparency issues...
by on Jul 18, 2011 at 7:34:25 am

Hi there,
I have not tried this, it is only an idea, but I would try with a compositing tag. Apply a compositing tag to the person-plane and uncheck "seen by reflection". Maybe this should do it? But... it will probably remove the person as well... hmmm. How is your Reflexion depth and ray depth in the render options/options? Maybe turning that up will help?

Cheers
Sebastian

artefacts - visualising the ancient world
artefacts-berlin.de


Return to posts index

Adam TrachtenbergRe: Transparency issues...
by on Jul 18, 2011 at 1:36:21 pm

The compositing>exclusion function is a bit confusing. I'm guessing that in this case you have compositing tags on the wall planes that are excluding the floor plane? That's correct as far as it goes, but what it's not doing is exluding the rear wall plane that's being refracted through the tranparency of the alpha-mapped plane.

To correct that you need to add the alpha-mapped plane to your exclusion lists.


Return to posts index


dean chapmanRe: Transparency issues...
by on Jul 19, 2011 at 4:40:35 am

Hi Adam,

Thanks for the response...

I have simply unchecked the "seen by reflections" box in the compositing tags for the walls.

I tried your suggestion of excluding the alpha "man" plane..........this works, but i lose his reflection as well.

I'd like to keep his reflection on the ground, and get rid of only the wall refraction...

Any ideas?

Thanks man


Return to posts index

Adam TrachtenbergRe: Transparency issues...
by on Jul 19, 2011 at 4:51:33 am

The method I described works -- maybe I didn't describe it very well. Here's an example scene: 2630_exclusiontags.zip


Return to posts index

dean chapmanRe: Transparency issues...
by on Jul 19, 2011 at 6:38:55 pm

Hey Adam,

Thanks so much for taking the time to put the scene together....very kind.

I guess it must be an issue with my render settings, because when i load your scene and render...i get this (see attached photo).

What do you think?

-Dean



Return to posts index


Brian JonesRe: Transparency issues...
by on Jul 19, 2011 at 9:23:13 pm

do you have your Ray Depth set to 0?


Return to posts index

dean chapmanRe: Transparency issues...
by on Jul 19, 2011 at 9:36:31 pm

No....Ray Depth is set to the default, 15.


Return to posts index

Adam TrachtenbergRe: Transparency issues...
by on Jul 20, 2011 at 2:53:16 am

That is very odd. I can't think what the problem might be. Might be time to contact Maxon tech support.


Return to posts index


dean chapmanRe: Transparency issues...
by on Jul 19, 2011 at 4:46:50 am

Hey Sebastian,

Thanks for the advice.

I think you're right about screwing around with the ray depth....

This works if i take it down from the default 15, to 2.

My problem now is that when i add other objects which have alphas......the renderer does not render their alphas...it instead renders the alpha as black.

If i bump up the ray depth to 3, then the alphas of my new objects work....but i end up with my orignal problem of having that back wall image appearing on my floor once again.

Any suggestions?

Thanks!


Return to posts index

Bill KellyRe: Transparency issues...
by on Jul 18, 2011 at 8:06:49 pm

Try going to the Objects window and clicking on the material tag that you have applied to the plane with the man. Change the projection (down in the Attributes tab) from UVW to Frontal.



Return to posts index

dean chapmanRe: Transparency issues...
by on Jul 19, 2011 at 4:47:51 am

Thanks Bill,

I tried that, but it doesn't seem to make a difference....for me.


Return to posts index


Mark OertigRe: Transparency issues...
by on Jul 20, 2011 at 7:52:25 pm

can you maybe upload a small version of the scene?


Return to posts index

dean chapmanRe: Transparency issues...
by on Aug 4, 2011 at 7:29:56 pm

Hey Mark,

I know this is kinda late....but i still can't figure this thing out.


I am super confused as to how the refraction, ray depth, and reflection is working with one another.


Attached is my scene file...

2737_refractiontest.zip

Thanks!


Return to posts index

Brian JonesRe: Transparency issues...
by on Aug 4, 2011 at 7:41:47 pm

in the three Compositing tags on the walls uncheck Seen By Refraction


Return to posts index


dean chapmanRe: Transparency issues...
by on Aug 4, 2011 at 8:50:25 pm

Hmm, i try that and this is what i get (ive attached a pic)

On a side note, i accidently uploaded my scene file with "seen by refraction" unchecked for all the planes with the images. So, I made sure to recheck that.



Return to posts index

Mark OertigRe: Transparency issues...
by on Aug 13, 2011 at 9:08:33 pm

Hi Dean
Like Brian said i switched off the seen by refraction from the 3 wall tags. (seen by transparency on, seen by reflection off) I throwed out all the other Compositing Tags and it looks fine for me. I attatched the file. (R12)
Or should the Walls also be reflected on the floor?
Cheers
Mark


Return to posts index

Mark OertigRe: Transparency issues...
by on Aug 14, 2011 at 10:59:16 am

heres the file:
http://f1.creativecow.net/2801/alpha


Return to posts index

dean chapmanRe: Transparency issues...
by on Aug 17, 2011 at 1:45:35 am

Thanks Mark,

Argh.....when i open your file and simply hit the render button, this is what i get (see attached photos).

I also took a snapshot of my render settings.

Thanks again,

Dean







Return to posts index

Mark OertigRe: Transparency issues...
by on Aug 17, 2011 at 7:50:07 am

Hi Dean
hmmm...thats wierd. When i render it, it looks like that (see link).
Rendersettings are the same. (does it eventually work, if you copy all the objects into a new scene?)
Is there maybe a problem with the versionnumber or the system? I'm running R12.048 (Build RC42839) on Windows7 Ultimate 64bit.
Seems to be a Bug. Can someone else confirm that?
Maybe ask Maxon.

Gruss
Mark



render.jpg


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]