3DS MAX: 3ds Max Forum 3ds Max Tutorials

I need AVI, Alpha + footage on plane in Max???

COW Forums : Autodesk 3ds Max

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
adeeb oberoi
I need AVI, Alpha + footage on plane in Max???
on Oct 19, 2011 at 9:46:19 pm

I need keyed out footage in a max project.

I have the avi with alpha+, I just cant get bit to work.

I have autodesk 3d max 2010 and windows 7.

Any adcive will be very welcome.

Adeep Oberoi


Return to posts index

Joseph W. Bourke
Re: I need AVI, Alpha + footage on plane in Max???
on Oct 21, 2011 at 1:45:58 pm

My guess is that you need to add a second copy of the alpha channel to the opacity layer in Maps in the Material Editor. That should do the trick - I think. If not, maybe you need to split off the alpha channel to be a separate greyscale track and then put it in the opacity map.

Joe Bourke
Owner/Creative Director
Bourke Media
http://www.bourkemedia.com


Return to posts index

adeeb oberoi
Re: I need AVI, Alpha + footage on plane in Max???
on Oct 21, 2011 at 2:38:01 pm

I did try that, but when I render the whole plane is gone including the footage.

yea a separate greyscale does work but I will have to render each and every avi footage double out of AE.

Other 3d applications just recognize the alpha channel.

There must be a way to make this work in 3d max.

Adeep Oberoi


Return to posts index


Joseph W. Bourke
Re: I need AVI, Alpha + footage on plane in Max???
on Oct 21, 2011 at 3:44:53 pm

An easier way to go might be to batch convert the files to Quicktime movies with alpha (Animation code, millions of colors+). You could do the batch process in Adobe Media Encoder. It would be much easier than outputting all of the alphas as separate tracks from multiple files.

You might want to check the Autodesk site to see if that particular .avi format is supported with alpha. One other thing to check is that the .avi file actually has its' alpha channel. I have read that sometimes the .avi files looks as if it has an alpha (uncompressed, 32-bit), but when you bring it into After Effects to see, the alpha is white.

Joe Bourke
Owner/Creative Director
Bourke Media
http://www.bourkemedia.com


Return to posts index

adeeb oberoi
Re: I need AVI, Alpha + footage on plane in Max???
on Oct 21, 2011 at 10:24:32 pm

But I thought max doesnt except quicktime, I will try that, it would
be super solution.


Return to posts index

Joseph W. Bourke
Re: I need AVI, Alpha + footage on plane in Max???
on Oct 23, 2011 at 1:50:56 am

Adeeb -

It depends partly on what version of Max you're using. If you're using the 64-bit version, QT is out, but you can run the 32-bit version of Max on a 64-bit machine. I don't have Max open right now, but one of your other options is to render your files to stills with an alpha channel (I know...time consuming), such as .png or .tga files. This will definitely work. But I would swear that I've brought QT files with alpha into max for mapping onto planes.

Joe Bourke
Owner/Creative Director
Bourke Media
http://www.bourkemedia.com


Return to posts index


adeeb oberoi
Re: I need AVI, Alpha + footage on plane in Max???
on Oct 23, 2011 at 1:58:51 am

Whow, thx, yes I have windows 7, 64 bits.

I actually dont care about avi. but choose that because QT didnt work. I absolutely do not have a preference for AVI at all.

Its great if a TGA or PNG with alpha+ will work thats great, I just need to get footage into max mapped onto a plane and only show the footage, so as if the person in the footage is walking around in a 3d max scene.

Would you please advice me on how to exactly get this PNG sequence to work on a plane?

Would appreciate that for sure. I am in the middle of this TV spot.

Kind regards,

Adeep Oberoi


Return to posts index

Joseph W. Bourke
Re: I need AVI, Alpha + footage on plane in Max???
on Oct 23, 2011 at 2:14:58 am

Good News!

I just opened the 32-bit version of Max 2010, and imported a QT file with alpha channel. After importing it to the Diffuse color channel, I then copied it to the opacity channel (all in the Material Editor), set Alpha Source to Image Alpha, checked the Premultiplied Alpha box, set RGB Channel Output to Alpha as Gray, and Mono Channel Output as Alpha, and it worked just fine.

So problem is solved. Just create your plane, set your material map to Bitmap, import the .mov file, and do the above. You will have your alpha channel.

Joe Bourke
Owner/Creative Director
Bourke Media
http://www.bourkemedia.com


Return to posts index

adeeb oberoi
Re: I need AVI, Alpha + footage on plane in Max???
on Oct 23, 2011 at 2:20:08 am

COOL, that is good news, I will go try that tomorrow when I get to the studio.

I am not sure but I believe we have the 64 bit version, I know its max 2010 for sure.

OK, now if we do have the 32 bit version, will that mean all will render way slower???

Weird that the 64 bit doesnt do QT.

Still may wanne go the image sequence way in 64 bits if it speeds up rendering, this is a super render intensive project.

But its great to know we have a solution for the QT 32 bit max.

Thanks again, much appreciated.

Adeeb Oberoi


Return to posts index


adeeb oberoi
Re: I need AVI, Alpha + footage on plane in Max???
on Oct 23, 2011 at 3:50:17 pm

Thanks Joseph, I just tried it, it is really weird that 32 bits does do QT but 64 bits doesnt.

The qt imported fine, did everything you said (i believe) how ever the material is black and white, like the transparent part is black and the keyed out person is totally white.

What am I doing wrong ??????

Thanks again, and sorry to keep bothering.

Best regards,

Adeeb Oberoi


Return to posts index

Joseph W. Bourke
Re: I need AVI, Alpha + footage on plane in Max???
on Oct 23, 2011 at 11:00:40 pm

Sorry to be getting back to you so late. I've been out all day. It sounds to me as if you might have the alpha channel inverted somehow. I don't have Max open - is there a switch in the material editor which says "invert" alpha?

Joe Bourke
Owner/Creative Director
Bourke Media
http://www.bourkemedia.com


Return to posts index

adeeb oberoi
Re: I need AVI, Alpha + footage on plane in Max???
on Oct 24, 2011 at 12:33:02 am

Well, I tried that too.

I could send you the max file to have a look at it?

I used the exact same settings for diffuse in the opacity as you mentioned.

What would be the best image sequence as far as image quality is concerned to use for max 64 bits? and would the settings need to be the same?

Regards,

Adeep Oberoi


Return to posts index


adeeb oberoi
Re: I need AVI, Alpha + footage on plane in Max???
on Oct 24, 2011 at 4:48:46 pm

I finaly got things working, the png sequence worked but looked very bad.

I just continued with the AVI and rendered an extra black an white avi for the opacity slot. Little more work but hey it looks great.

No for my next problem, The footage of people on the transparent plane does not cast shadows. I have my people in the 3d scene now which is great, I want to make it look real, so if they can cast shadows it would be great.

In an other 3d program all I needed to do is turn on transparency and light through transparency in the render settings... I cant get this to work yet though.

Anny advice?

Thx,

Adeep Oberoi


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]