APPLE MOTION: Motion Forum Motion Tutorials FCP Legacy FCP Tutorials

Motion 5.1.2 Oscillate behavior bug?

COW Forums : Apple Motion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Petter StahreMotion 5.1.2 Oscillate behavior bug?
by on Sep 27, 2014 at 4:09:23 pm

I've experienced this problem through multiple versions of Motion. I first thought it was me doing something wrong but it seems this is a bug ... or?

I've also searched threads like this one https://f1.creativecow.net/2978/apple-motion-4-5-oscillate-behaviour-bug which implies that this bug has been around since at least 2011.

If you can repeat this on your machine, please let Apple know that this bug still isn't fixed using "Provide Motion feedback" in the Motion-menue.

If you can't repeat the problem, please tell me what I'm doing wrong. My work around has been trying to emulate the oscillate effect using keyframes only. Not funny!

Problem/bug description:
When applying the Oscillate behavior to a parameter of an object (in my case Rotation) I can't keyframe it's Amplitude and Speed settings to gradually stop IF the object doesn't appear from frame 1.

Look at this movie:
http://www.studiostahre.se/temp/140927motionbug.mp4

What I show is a rectangle that has the Oscillate behavior and is keyframed (Amplitude+Speed) to stop after 2 seconds. I play it and it works fine. But then I move the rectangle almost 4 seconds away and while I drag it you can see that the oscillate-effect (sinus curve in the bottom window) changes, but the keyframes are intact. The Oscillate behavior now expands past my last keyframe. And when I play the animation again the oscillation doesn't stop where it should (at approx 6 sec). It is still oscillating at the project end (10 sec).

I have also tried to stop the Osciallate behavior using the Ramp behavior instead of keyframes, but I run into the same problem.

Bug?


Best,
Petter


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]