APPLE MOTION: Motion Forum Motion Tutorials FCP Legacy FCP Tutorials

Incomplete Generator

COW Forums : Apple Motion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Don SmithIncomplete Generator
by on Oct 3, 2011 at 9:25:00 pm

Boy, I sure like Motion 5 and FCPX. I'm preparing generators that I'll use often.

I've prepared a simple circle that draws on the screen and published a few controls.

Saved it as a generator. When brought into the timeline, the circle starts out completed. No drawing on.

I've set a timeline marker just pass the drawing completion and made it a mandatory built-in marker. No help.

Stumped here because I've created lower-third animations without a problem.


Return to posts index

Mark SpencerRe: Incomplete Generator
by on Oct 4, 2011 at 1:46:41 pm

Don, I just tested this and it worked fine for me. Did you install the FCP X 10.0.1 and Motion 5.0.1 updates?

--
Mark Spencer
Freelance Producer/Editor/Motion Graphics Artist
Apple-certified Master Trainer
Author, Motion 4 from Peachpit Press
http://www.applemotion.net


Return to posts index

Don SmithRe: Incomplete Generator
by on Oct 4, 2011 at 2:09:55 pm

Thank you for your trouble Mark. It was because I re-built my startup volume from scratch that I was rescuing templates from Motion 4 by opening them in Motion 5 and saving them as templates.

My thinking was 'what could be wrong with a simple circle?' Well, as simple as it is, it was problematic saving that Motion 4 template through Motion 5. No Drop Zones to publish first per one of your tutorials. Yet, it wouldn't work right. I mean, there's just one Group, and one Circle in the group. Nothing else.

When you reported that it worked for you, I deleted the circle and re-created it. Now it works fine. Thank you. But, what's the difference? I'm still at a loss as to why a simple circle drawing on would not translate. Chalk it up to the mysteries of graphic creation I guess. I've taken templates like a digital vu meter, an analog vu meter, and lower-third animations from M4 into M5 and thus into FCPX without a problem.

NewsVideo.com


Return to posts index


Don SmithRe: Incomplete Generator
by on Oct 4, 2011 at 3:31:01 pm

Well, Mark, I wasn't so crazy after all.

Now, I buit a simple arrow in Motion 5 and it animates in its length. I set a Mandatory Build-Out marker just after the animation completes.

Exported as a generator, it works fine. Publish a few parameters and save again and it no longer animates on. Unpublish all published parameters and it works again. Start adding back a published parameter at a time and it stopped animating at one point. I'm not naming that parameter because it's not consistently at fault. It appears to be some magic combination of publishing parameters in some magic order because now I'm back with a working arrow but the published parameters are the same, just enabled in a different order.

NewsVideo.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]