APPLE MOTION: Motion Forum Motion Tutorials FCP Legacy FCP Tutorials

Motion 5 / FCPX Woes

COW Forums : Apple Motion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Don SmithMotion 5 / FCPX Woes
by on Jun 28, 2011 at 7:13:08 pm

I've been trying to give FCPX and Motion 5 the benefit of the doubt. I realize that before I speak, I need to explore the possibility that the trouble is a short between the headphones. After much research, I don't think it is.

I've got both programs on a brand-new MacBook Pro, 17" Thunderbolt laptop it 8GB of RAM. It SEEMED to develop these problems after the Thunderbolt update this morning but I have no way of verifying that.

I'm working on a project in M5 that uses keyed video. The person who did one of the keys didn't do it well. I fired up FCPX where I had experimented with keying video before and it did an amazing job.

I put my green-screen video in, and to check it, I put a white background clip under it. I put the key filter on the green-screen shot and made a small adjustment to make it a perfect key. Then I disabled the visibility of the background clip and Share>Send to Compressor (since Share>Movie crashes M5 and FCPX every time).

That's the First problem, neither M5 or FCPX will Share (Export) to a Movie without crashing. I get around that by sending to the new Compressor. That's worked every time.

Second problem, I pull the new key into my project in M5 and the keyed part shows up black! OK, I double-check. I load the keyed video into FCP7 and it keys perfectly. Also perfect sound.

Third problem, no sound in M5. Settings are identical to other clips. The clip plays with sound when first selected in that little window at the top left. I load the same key video into Motion 4 and I get NO black background and I get a perfect key. In M5, no key, no audio. I did a workaround on the black BG of the key video but you don't need to know those details. I'm still dead in the water because there's no way I can find to make M5 play the sound of the keyed clip. Yes, it's on and linked in the Audio tab and in the Audio editor. Same settings as other clips.

It may be my paranoia, but the problems seem to have started today. I installed the Thunderbolt firmware update that became available. I was told that when the computer restarts I would see a progress bar and to not disturb it. I restarted but if it installed then it went by in a heartbeat.

Clues anyone?

Return to posts index

Mark SpencerRe: Motion 5 / FCPX Woes
by on Jun 28, 2011 at 7:18:01 pm

My first though would be, why not just do the key in Motion 5, instead of doing it in FCP X, exporting a movie, and bringing the movie into Motion? The keyer in Motion is the same - it's actually better because it has more options.

But to your problem - did you export the keyed footage to a codec that supports an alpha channel, and did you include the alpha channel? If so, check the alpha channel interpretation in Motion.

For the audio, make sure you have audio enabled in the transport controls - and verify that it's there in the Audio list (in the Project Pane).

Mark Spencer
Freelance Producer/Editor/Motion Graphics Artist
Apple-certified Master Trainer
Author, Motion 4 from Peachpit Press

Return to posts index

Robert AnsleyRe: Motion 5 / FCPX Woes
by on Aug 5, 2011 at 12:28:50 am

I really like Motion 5. Just the interface alone was worth the price. I did not buy FCPX, I just export videos like you said, and use them in FCP7. It seems to do things better - Match Move tracks better and keying seems more robust. Multiple audio files work fine for me. But I have been having video problems that have me perplexed. All is fine in my project, until I accidentally double click in the canvas on some area, I think where no objects are, which makes the screen go black. No matter what I've tried, i can't see my work anymore. The only solution is to save, and restart. Have you seen that one?

Return to posts index

Robert AnsleyRe: Motion 5 / FCPX Woes
by on Aug 5, 2011 at 2:04:28 am

Never mind. Stupid me. I was changing the canvas from camera view.

Return to posts index

Stephen SmithRe: Motion 5 / FCPX Woes
by on Jun 28, 2011 at 7:19:16 pm

Second problem, I pull the new key into my project in M5 and the keyed part shows up black!

Do you export the keyed clip to the Animation or Proress 4444 codec and was it set to Millions +?

Stephen Smith
Utah Video Productions

Check out my Motion Training DVD

Check out my Motion Tutorials

Return to posts index

Andy NeilRe: Motion 5 / FCPX Woes
by on Jun 28, 2011 at 7:44:24 pm

If the export shows up with alpha intact in FCP 7, then it sounds as if Motion is misinterpreting the alpha. Select the clip in Motion. Hit SHIFT+F to select the media in the media tab. Check the inspector and make sure that the alpha is set to Straight.


Return to posts index

Don SmithRe: Motion 5 / FCPX Woes
by on Jun 29, 2011 at 4:08:14 pm

I export to ProRes 4444. The video in Motion shows it to be Millions+ and Straight Alpha.

I'm unsure about Mark means about enabling sound in the transport controls. The sound for that video clip is listed under the Audio tab as being on with the same settings as the other media, and likewise when I look at the Audio in the timeline below. Sound from existing clips before and after this new clip from FCPX is playing sound normally and have the same settings.

But, I do have a clue now; I've just loaded Motion 5 onto a MacPro. I haven't checked sound yet, but moving the clip that caused the key to show up black onto the project shows just fine on the MacPro. I'm now thinking something is interfering with Motion 5 on my new MacBook Pro Thunderbolt laptop. Also, Motion 5 on the Mac Pro will export to a movie just fine (although much slower than if I send it to the new Compressor) whereas both Motion 5 and FCPX would crash on my laptop if I tried to export to a movie.

Amazing in that I tried to keep the new MBP as 'clean' as possible whereas the Mac Pro has all sorts of crap loaded onto it! On my new MBP I have CS5.5 (the everything bundle), Final Cut Studio 3, FCPX, Motion 5 and the new Compressor. The only other thing loaded onto it is a driver for the Matrox MX01 LE I use in the field.

It still makes me wonder about that Thunderbold firmware update that I applied yesterday morning. When the machine restarted there was no progress bar to indicate that the firmware update was being applied, or may be it got started and bailed. I can't say for sure but it paranoid side of me things the troubles began after that firmware update attempt.

Thanks to everyone who replied.


Return to posts index

Don SmithRe: Motion 5 / FCPX Woes
by on Aug 5, 2011 at 11:42:28 am


I know I said I had a 'clean' install on my new Thunderbolt 17" MacBook Pro with 8GB of RAM but I decided to 'clean' again.

This time (and it was a scary process to go through the first time), I restarted the laptop and held down the Option key so that I could boot from the Recovery partition. Since I had installed Lion before on the laptop, I knew that the Recovery partition would be there.

Once booted on the recovery partition I was given access to Disk Utility. I took a deep breath and chose to Erase my boot drive (Macintosh HD.. I had yet to rename it). I then clicked on the option to re-install Lion.

Confusingly I was give a couple of login boxes, none of which would work no matter what I put as my login. So, I started canceling out, sweating bullets that I had just bricked my laptop and there would be no way out. However, after canceling the login windows I was presented with a Lion installer window.


I installed Lion on my now blank internal drive.

After downloading the laptop rebooted and Lion was configuring and starting up. I was asked to establish a wireless connection to send in my registration but the wireless wouldn't see my local Wi-Fi signal so I skipped that part. Once Lion was fully installed, Airport could see that Wi-Fi signal and I was able to join it.

I then re-installed FCPX, Motion 5 and the new Compressor. Nothing else.

Suddenly, Motion 5 had no problem handling and exporting the movie of a big project that had been problematic before. I had faulty audio on those export options that would work. Some export options, such as 'Export Movie', did not work at all previously. Now, 'Export Movie' worked just fine and, unlike, the export options that worked previously, the audio was was fine as well. Previously, the export options that worked only gave me good video but the audio was full of artifacts such as random bits of audio or spots with no audio at all. Funny, but the same thing happens (using that same project) on my work MacPro station still operating under Snow Leopard but using Motion 5.

Previously, my 'clean' laptop was bought with Snow Leopard on it and Lion was installed over Snow Leopard. I then installed FCP Studio 3. Later, I installed Adobe CS 5.5 Master Collection, Motion 5, FCPX (over the FCP Studio 3 installation so I would still have access to FCP 7), and the new Compressor. I then put in the drivers for my Matrox MX02 LE box.

Nothing else. Since i only placed software needed for work, I considered it a 'clean' install.

So, something among those software installations is what drove Motion 5 crazy. But Motion 5 on my work MacPro under Snow Leopard has much of the same craziness. I even embarrassed myself posting what I thought was my discovery of a bug in M5 here only to discover it was just an artifact of my installation. My task now is to try to find what those two installations have in common. My work machine still has CS3 on it and not 5.5. My work machine has both FCP Studio 3 and the new FCPX on it and that's the only thing the two computers had in common that I've found so far.

So, I post all this in the hope that others who have the same experience will compare notes with me.

Don Smith

Return to posts index

Nils A. UtsiRe: Motion 5 / FCPX Woes
by on Nov 22, 2011 at 1:59:02 am

Hi there,

I am having similar audio export issues with Motion 5, on a pretty clean install though.

Got no Adobe software on this install, so maybe we can exclude that.

Plenty of Autodesk stuff, Maya 2012, Mudbox 2012, Smoke. SketchBookExpress.

Pixologic ZBrush.

wacom tablet, do you have one of those? I know there is a issue with wacom tablets for dragging songs into an iPad from iTunes, of all things.. This is a new thing in Lion for me.

It is weird though, seeing as you say it works on a completely clean install.

I'll check back for any progress,

Nils A. Utsi
Filbmagoahti AS

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 All Rights Reserved