APPLE MOTION: Motion Forum Motion Tutorials FCP Legacy FCP Tutorials

Jaggy Motion Text in FCP. Solution?

COW Forums : Apple Motion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Kevin Jones
Jaggy Motion Text in FCP. Solution?
on Mar 15, 2011 at 10:00:53 pm

I'm using Final Cut Studio 2 with the Motion 3 upgrade on a Mac OS X version 10.4.11.
These days I'm shooting HD video with a Sony XDCAM PMW EX-1, 1080p, 30fps.

When I create Motion text to import into FCP, I always set motion to match my video format.
Text looks great within Motion. Nice and smooth. But when it's over-laid on video in the FCP timeline it looks jaggy.

Ironically, if I create the same text with the built-in Boris Title 3D, the text is very smooth.

If someone could point me in the right direction I would appreciate the help.
Thanks!

Kevin Jones

2.5GHz Quad-core PowerPC G5
Final Cut Studio 2


Return to posts index

Mark Spencer
Re: Jaggy Motion Text in FCP. Solution?
on Mar 15, 2011 at 10:03:08 pm

http://www.kenstone.net/fcp_homepage/motion_text_in_fcp_spencer.html

--
Mark Spencer
Freelance Producer/Editor/Motion Graphics Artist
Apple-certified Master Trainer
Author, Motion 4 from Peachpit Press
http://www.applemotion.net


Return to posts index

Kevin Jones
Re: Jaggy Motion Text in FCP. Solution?
on Mar 15, 2011 at 10:15:52 pm

Thanks.
I've been researching this for a couple of days now.
I've read that article. Made no difference.
Also, it's a DV format example. I don't know if that makes a difference or not.

I'm hoping to tap into someone who experienced the same problem, same set-up and discovered a solution.

Thanks!

Kevin Jones

2.5GHz Quad-core PowerPC G5
Final Cut Studio 2


Return to posts index


Mark Spencer
Re: Jaggy Motion Text in FCP. Solution?
on Mar 15, 2011 at 10:17:23 pm

DV or HD, doesn't matter - you still need to check your sequence settings and make sure everything is set up correctly.

--
Mark Spencer
Freelance Producer/Editor/Motion Graphics Artist
Apple-certified Master Trainer
Author, Motion 4 from Peachpit Press
http://www.applemotion.net


Return to posts index

Kevin Jones
Re: Jaggy Motion Text in FCP. Solution?
on Mar 15, 2011 at 10:26:09 pm

Mark,
Thanks for the fast response!
I believe I have everything set-up correctly. I went through your excellent article and followed the set-up recommendations.
Still looks jaggy.

SD (DV) text viewed on an interlaced SD monitor looks fine.
HD Motion text looks mighty poor.

Why does text generated in Text 3D look perfect?

Thanks again!

Kevin Jones

2.5GHz Quad-core PowerPC G5
Final Cut Studio 2


Return to posts index

Andrew Wilson
Re: Jaggy Motion Text in FCP. Solution?
on Mar 16, 2011 at 1:45:09 am

I've had several occasions where I'll set the field dominance in motion as none and when I bring the clip into fcp, the field dominance changes to even. Control-click your clip in the timeline and make sure the properties there match the field dominance of the sequence.

Andrew Wilson
WestView Digital Video & Design
http://www.westviewdigital.com


Return to posts index


Kevin Jones
Re: Jaggy Motion Text in FCP. Solution?
on Mar 16, 2011 at 3:43:22 am

Andrew,
I'll give that a try in the morning and let you know how it works.
Thanks.

Kevin Jones

2.5GHz Quad-core PowerPC G5
Final Cut Studio 2


Return to posts index

Dave Davin
Re: Jaggy Motion Text in FCP. Solution?
on Mar 16, 2011 at 8:49:35 am

Hi Kevin

You've probably looked at this but make sure your fps' are matched? Common mistake and will make text stutter.

Dave

Dave Davin
Creative Director

RAIC Productions
http://www.raicproductions.com


Return to posts index

Kevin Jones
Re: Jaggy Motion Text in FCP. Solution?
on Mar 16, 2011 at 4:57:54 pm

Dave,
Both Motion and FCP are set at 30fps.
Playback does not stutter or falter in any way.
All effects and filters work fine.
It just the text, when imported into FCP looks jaggy.

Thanks for the input.

Kevin Jones

2.5GHz Quad-core PowerPC G5
Final Cut Studio 2


Return to posts index


Kevin Jones
Re: Jaggy Motion Text in FCP. Solution?
on Mar 16, 2011 at 4:54:06 pm

Thanks Andrew,
Good call, but alas... not the solution in this case.
I checked Motion and FCP. Both are set for "Even".
I'll keep on looking for a solution.

Thanks again.

Kevin Jones

2.5GHz Quad-core PowerPC G5
Final Cut Studio 2


Return to posts index

Andrew Wilson
Re: Jaggy Motion Text in FCP. Solution?
on Mar 17, 2011 at 12:22:18 am

You're actually checking the properties of the clip right? Control-Click on the clip both in the timeline and the bin and check its properties to make sure field dominance is set to the same thing as your sequence settings.


Is your clip set evenly on a pixel? If I reposition a clip, I always make sure the position values are set to even numbers. Sometimes dragging a clip to slightly reposition it will jag up the edges.

One final question... are you rendering inside Motion and importing a self-contained movie file or are you dropping the motion project file into the timeline?

Andrew Wilson
WestView Digital Video & Design
http://www.westviewdigital.com


Return to posts index

Kevin Jones
Re: Jaggy Motion Text in FCP. Solution?
on Mar 17, 2011 at 3:05:59 am

Good Questions!

Yes I am have been checking the clips to be sure they match Motion.
Both are set to Sony XDCAM EX 1080p 30fps. This is the only HD format I use.

Yes I always enter numerically even numbers both horizontally and vertically in FCP to position my text clips. (This is a great tip by the way).

Typically, I create a Motion text file. Then import the project file into FCP. Then I place the motion project file onto the timeline where I need it. I find this method is easier to make tweaks. I don't usually create a self-contained movie.

Thanks for the input!

Kevin Jones

2.5GHz Quad-core PowerPC G5
Final Cut Studio 2


Return to posts index


Andrew Wilson
Re: Jaggy Motion Text in FCP. Solution?
on Mar 17, 2011 at 3:25:28 am

Sounds like you're covering your bases pretty well. One small inconsistency though...

You said you checked the frame dominance of both clips and they were set to even, yet you said in the previous post that you use 1080 30p. Which is progressive which would mean that your field dominance should be set to none. And the setting you confirmed in that last post as 1080 30p isn't the setting I'm talking about, it's the compressor - not the field dominance.

Just to be sure, I'm uploading screen grabs of the setting I'm talking about. One is from SEQUENCE/SETTINGS, one is the field dominance column in the bin and the last is from CTRL-CLICKING a clip the timeline and selecting ITEM PROPERTIES / FORMAT

ITEM PROPERTIES:



SEQUENCE / SETTINGS:



CLIP SETTINGS IN BIN:





And finally... did you try a different font? Could be a bogus font - not that I want to add more things to try! Jaggy text has been a huge issue for me in the past - but more with LiveType which never seemed to be able to import with the right field dominance so I've learned to get pretty observant about all the settings.

Andrew Wilson
WestView Digital Video & Design
http://www.westviewdigital.com


Return to posts index

Kevin Jones
Re: Jaggy Motion Text in FCP. Solution?
on Mar 17, 2011 at 3:35:45 am

Sorry Andrew.. I meant "None". I'm getting a little foggy.
Looks like it's the Motion file that is my problem.
I must have something set up wrong.
Never had this problem with SD Motion text files.

I'm currently using "Arial".
I find it to be pretty smooth for this experiment in Motion text fontdom.

Thanks.

Kevin Jones

2.5GHz Quad-core PowerPC G5
Final Cut Studio 2


Return to posts index

Kevin Jones
Re: Jaggy Motion Text in FCP. Solution?
on Mar 17, 2011 at 3:26:34 am

Andrew,
I re-read your comments and re-checked the properties of my Motion text clip as it was in my FCP timeline. Son-of-a-gun if the field dominance didn't say "Upper(Odd)".

I checked the properties of the same text file in Motion and it said under Field Order "None"
All my video clips, and my FCP timeline are set for "None".
This is starting to make sense now.
Motion Project Properties said the project was "None"
I assumed the file would remain that way.
Apparently somewhere between Motion and FCP the Motion file is changed to "Upper(odd)"

I think you are on to something here. I must not have something in Motion set properly.
What do I need to do to make sure my Motion project file are being saved and imported correctly?

We're getting close!
Thanks!

Kevin Jones

2.5GHz Quad-core PowerPC G5
Final Cut Studio 2


Return to posts index

Andrew Wilson
Re: Jaggy Motion Text in FCP. Solution?
on Mar 17, 2011 at 12:36:11 pm

Let me know if you figure it out. ;


okay, so the way to fix it is to CONTROL-CLICK on the clip in the timeline, get properties-->Format and where it says Upper - then control click on that property and select NONE.


I've had this problem for a long time. I set field dominance to none in Motion and import into FCP, edit it into the timeline and *Most* of the time, the FD switches in upper and I have to change it manually.

One more thing to add from my experience, if your timeline has been rendered already, sometimes switching the FD won't "unrender" that segment of the timeline and you won't see any change. Drop a SLUG clip (or any clip) onto the timeline above your motion clip, then delete the SLUG. Now FCP will see the chance you made for the re-render.

Andrew Wilson
WestView Digital Video & Design
http://www.westviewdigital.com


Return to posts index

Kevin Jones
Re: Jaggy Motion Text in FCP. Solution?
on Mar 17, 2011 at 3:07:09 pm

Thanks Andrew!
That did it alright. Nice smooth text again!
This is an excellent work-around for the problem.
I tend to use a lot of Motion text in my projects and this will certainly help.

Now if I could just figure out why the Motion text file changes field dominance after I save and import it.

Thanks again Andrew.

Kevin Jones

2.5GHz Quad-core PowerPC G5
Final Cut Studio 2


Return to posts index

Andrew Wilson
Re: Jaggy Motion Text in FCP. Solution?
on Mar 17, 2011 at 3:32:11 pm

(fist pump... big smile... high five...)

Glad I could help.


BTW - I'm on FCS 3 and it's been a problem there too. I was so hoping it would go away when I upgraded. No such luck.

Andrew Wilson
WestView Digital Video & Design
http://www.westviewdigital.com


Return to posts index

Mark Spencer
Re: Jaggy Motion Text in FCP. Solution?
on Mar 18, 2011 at 2:15:45 am

Great job, Andrew - yes, FCP frequently loses the flag for field dominance, as well as aspect ratio...

--
Mark Spencer
Freelance Producer/Editor/Motion Graphics Artist
Apple-certified Master Trainer
Author, Motion 4 from Peachpit Press
http://www.applemotion.net


Return to posts index

Sergio Lorente
Re: Jaggy Motion Text in FCP. Solution?
on Nov 10, 2012 at 9:22:55 am

From Final Cut Pro 7, if you import a Motion proyect (progresive) it´s possible with de-interlaced to progresive. It´s simple and it´s very nice trick.

- Select item (motion proyect) from Browser in FCP7.
- Right clik, Item Properties / Format
- Just to the right of Field Dominance and over Upper (Odd)...

Press CTROL-clik and you´ll see 4 options (None, Upper, Lower and Not Set).

If you press None, jaggy dissapear.

Bye!!

Sergio Lorente
Consultant Network Europe
sergio@integravideo.com
Valencia - Spain


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]