APPLE MOTION: Motion Forum Motion Tutorials FCP Legacy FCP Tutorials

Gak! Image well in Emitter locked?

COW Forums : Apple Motion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Jiggy Gaton
Gak! Image well in Emitter locked?
on Jul 26, 2010 at 3:36:39 pm

Hi, I creating particle systems in Motion 4 but the first stumbling block is getting the particles contained in a shape. Here is the apple doc text:

>>drag the image to the Image Source well in the Emitter Inspector
(http://documentation.apple.com/en/motion/usermanual/index.html#chapter=11%26section=6%26tasks=true)

Well, the Image Source well is locked and says None. How do I drag an image onto that?!? Arg...
thx in advance!!!
jigs


Phoenix Studios Nepal: A small A/V Production House in Kathmandu.


Return to posts index

Andy Neil
Re: Gak! Image well in Emitter locked?
on Jul 26, 2010 at 6:27:58 pm

When you say it's locked, what do you mean?

The typical way to create a particle system is to select the layer you want to create particles from, and then click the Make Particles button on the toolbar, or hit E on the keyboard.

Andy

http://www.timesavertutorials.com


Return to posts index

Jiggy Gaton
Re: Gak! Image well in Emitter locked?
on Jul 27, 2010 at 4:59:08 am

Thx for that, but no problem creating the particle system. I am trying to customize them so they play out within a certain shape or geometry as advertised that they can do. Only I can't get anything into the image well as the manual says u have to. It's not accepting any drags from anywhere! Frustrating to say the least. Not sure if my Motion is broke, but have used the image well for other things before.

Maybe there is another way. I am generating an explosion of cell phones. Fine, got that. But now I want that explosion to only appear in the country of Nepal (I have a black and white alpha png of that, where I want the phones to NOT explode past the inner white map bit). There is an option referred to in the book to do this, but it dunna work. If I could only get something into that well, I bet it would:(

Thx again!

Phoenix Studios Nepal: A small A/V Production House in Kathmandu.


Return to posts index



Andy Neil
Re: Gak! Image well in Emitter locked?
on Jul 27, 2010 at 7:39:49 am

Can you explain how you're trying to get it to work? If the shape you're using to constrain the emitter is an image, then the emitter shape needs to be set to Image. If you have it set to Geometry, then the image won't be allowed in the well. Geometry is for shapes only (like those made with the bezier tool). If you DO have it set to Image, could you take me through a step by step to see if there's anything you're missing (though that's unlikely).

Andy

http://www.timesavertutorials.com


Return to posts index

Jiggy Gaton
Re: Gak! Image well in Emitter locked?
on Jul 27, 2010 at 9:16:36 am

yes andy, I set up an emitter and it's just scattered across an area (any default setting: circle burst rectangle etc.). So I change the Shape to "Image" expecting I can use that to restrict the area of the scattering, see image below. But I can't get anything into the Image Source Well. What's the trick? thx!



Phoenix Studios Nepal: A small A/V Production House in Kathmandu.


Return to posts index

Jason Diebler
Re: Gak! Image well in Emitter locked?
on Jul 27, 2010 at 2:53:09 pm

What type of image?

"The deepest blues are black" - Foo Fighters
(this doesn't help me when I'm chroma keying!)


Return to posts index


Jiggy Gaton
Re: Gak! Image well in Emitter locked?
on Jul 27, 2010 at 3:05:43 pm

Any type! I've tried them all I think. What are u supposed to use? It's just a black and white mask of Nepal in png alpha format. But I can do anything that works:)
thx!

Phoenix Studios Nepal: A small A/V Production House in Kathmandu.


Return to posts index

Jason Diebler
Re: Gak! Image well in Emitter locked?
on Jul 27, 2010 at 4:26:42 pm

My only thought was maybe its a bit depth conflict. Open in Photoshop go to Image>Mode and see if another setting works better. RGB 8 or 16... just something to double-check and try.

"The deepest blues are black" - Foo Fighters
(this doesn't help me when I'm chroma keying!)


Return to posts index

Andy Neil
Re: Gak! Image well in Emitter locked?
on Jul 27, 2010 at 4:47:20 pm

Can you post the image you're trying to use? I can see nothing overtly wrong that you're doing. Although I find it strange that your 3rd particle says none in the source as if you added it as a particle and then deleted it from the Media tab.

The only thing I can think of is that the image is of a mode that is incompatible with Motion like Grayscale, or Index or something like that. All images need to be RGB, but if that's the case, I'm not sure why it's not accepting the image source in the well.

Andy

http://www.timesavertutorials.com


Return to posts index


Jiggy Gaton
Re: Gak! Image well in Emitter locked?
on Jul 27, 2010 at 5:50:03 pm

Ha! the third particle is the image that I am trying fill...I was just trying everything, but that obviously was a mistake. Attached is the file, just a normal PNG as far as I can tell...thx all for your help! I have several of these that need to be done before morning (just a few hours from now:)

Here is the file:
936_nepalmapbandwjustmap.png.zip

Phoenix Studios Nepal: A small A/V Production House in Kathmandu.


Return to posts index


Andy Neil
Re: Gak! Image well in Emitter locked?
on Jul 27, 2010 at 5:59:51 pm

Your image is Indexed Color. That's not compatible with Motion. You're liable to get all kinds of issues and errors. Here's an RGB version. See if this works for you.


937_rgbmap.png.zip

http://www.timesavertutorials.com


Return to posts index

Jason Diebler
Re: Gak! Image well in Emitter locked?
on Jul 27, 2010 at 6:03:15 pm

Aha!

"The deepest blues are black" - Foo Fighters
(this doesn't help me when I'm chroma keying!)


Return to posts index


Jiggy Gaton
Re: Gak! Image well in Emitter locked?
on Jul 27, 2010 at 7:00:35 pm

thx Andy, I don't understand how I slipped up on that one! That image is in hundreds of slides all working fine in other ways. Preview says it's RGB...so how did you figure out otherwise? Anyway, saved my butt for the morning...thx so so much!!!!
jigs

Phoenix Studios Nepal: A small A/V Production House in Kathmandu.


Return to posts index

Andy Neil
Re: Gak! Image well in Emitter locked?
on Jul 27, 2010 at 7:06:39 pm

I have Photoshop so the first thing I did was open it there. If you also have photoshop, you can always check images before using them. I deal a lot with print gfx artists who tend to always work in CMYK, so I'm used to adjusting the images I use.

Glad it's working for you.

Andy

http://www.timesavertutorials.com


Return to posts index

Jason Diebler
Re: Gak! Image well in Emitter locked?
on Jul 27, 2010 at 6:02:15 pm

Andy solved it!


Return to posts index


Rajesh Barnabas
Re: Gak! Image well in Emitter locked?
on May 31, 2011 at 6:50:31 pm

It still didn't drop for me even in rgb mode.

What worked for me is if you

1) Add whatever emitter you want to the canvas.
2) Right click on that layer (after making sure to check Windows>Timeline )
3) "Add Image Mask"
4) At that point as long as under the Emitter tab Shape>Image is set.
5) A big drop zone is added to your canvas for you do then drop the image you want to use there, rather than under the Inspector tab.

That should work for customizing all the built in Motion Effects with your own images.
(oh and yes PNG files worked for me). Didn't try other stuff.)


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]