FORUMS: list search recent posts

Text shadow not working in Internet Explorer?

COW Forums : Web Design

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Simon MatthewsText shadow not working in Internet Explorer?
by on Feb 10, 2014 at 1:14:35 pm


I have a WordPress blog and I'm currently using the Piano Black theme. I added a text shadow to some of the text via the custom css file, which works fine in Chrome and Firefox but for some reason it doesn't work in Internet Explorer. The strange thing is, I have looked at another blog page which has the exact same line of css that I'm using and it works in Internet Explorer for that page, which is why I don't understand how it isn't working for my page. I've checked the code using 'Inspect Element' and for some reason the text-shadow line is disabled in Internet Explorer. Not sure why this is. Any help would be appreciated.

Here's the css: text-shadow: 1px 1px 1px #000;

Here's a link to my blog page:



Return to posts index

Herbert van der wegenRe: Text shadow not working in Internet Explorer?
by on Feb 15, 2014 at 7:05:16 am

This one had me stumped a bit at first, until I saw this on line 4

added in your head tag. Because of this Internet Explorer 9,10 and 11 are emulating the features of IE7, which does not support text-shadow. You can check in IE, and press F12 - then inspect the h2, and notice how IE is convinced text-shadow is not available (wriggly red underline). That is caused by the IE7 emulation.

Turn it off by removing that line in the head, and it will work fine. I wonder why the developer left that in? Probably for testing purposes to check what the theme would look like in IE7, and he/she forgot to remove it afterwards.

System: Win7 64bit - i7 920@3.6Ghz, p6t Deluxe v1, 48gb (6x8gb RipjawsX), ATI 7970 3gb, EVGA 590 3GB, Revodrive X2 240gb, e-mu 1820. Screens: 2 x Samsung s27a850ds 2560x1440, HP 1920x1200 in portrait mode

Return to posts index

Simon MatthewsRe: Text shadow not working in Internet Explorer?
by on Feb 15, 2014 at 10:45:49 am

Hi Herbert,

Thank you very much for replying. It had me stumped as well! I noticed the wriggly red underline myself and was wondering why that line was being disabled. Removing the line in the head that you pointed me to solved the issue and the text shadow is now working fine. Brilliant!

I'm not sure why the developer would have left that line in. As you say, it might have been for testing purposes.

Anyway, thanks very much for your help!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved