FORUMS: list search recent posts

Trouble getting JW player to work correctly

COW Forums : Web Design

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Jeremy Chopra
Trouble getting JW player to work correctly
on Oct 8, 2012 at 2:07:18 pm

Hi all I am not sure what I am doing wrong here but I have 2 pages reacting differently to the JW player on my site..

The first page I set up a while ago and the video plays fine with the a control bar etc..

Today I have tried to add a video to another page using the same JW player but all I get is a box in chrome and a DIVX symbol which when clicked inside plays the video but on all other browsers shows nothing but a big space on the page?

There are differences in the code that JW player provided but have played around to get it to be similar to the working page and nothing works.. any ideas? the pages in question are:

http://www.cascadepictures.co.uk/reel (WORKING CORRECTLY - the JW video is the first one at the top)

http://cascadepictures.co.uk/about-showreels.html (PROBLEM PAGE - The video is at the bottom of the page)

thanks for any help you can give

http://www.cascadepictures.co.uk


Return to posts index

Matt Geier
Re: Trouble getting JW player to work correctly
on Oct 8, 2012 at 3:11:15 pm

Hi Jeremy,

I'm not entirely sure 100% this is the is actual cause of the problem, but line 363 seems suspect as to the placement of the tag....

Might want to check into that and see if you can remove it (since glancing at the source doesn't seem apparent where the start tag is....)

Could be I've missed it too.... just a thought.

Let us know.

Matt Geier
(Video Networking Solutions Expert)
(Creative Design Workflow Consultant)
(Social Media Networks Consultant)
(Technical Video Industry Sales Consultant)


Return to posts index

Jeremy Chopra
Re: Trouble getting JW player to work correctly
on Oct 8, 2012 at 3:36:18 pm

Hi Matt

thank you for responding, I had a look at the code and line you mentioned, i think that was a tag for a twitter script I had put in a new place and left that "script" tag behind.. deleted it now but that is not the cause... :(

for note the JW player begins at line 340 ending at 359.

thanks again

http://www.cascadepictures.co.uk


Return to posts index


Curtis Thompson
Re: Trouble getting JW player to work correctly
on Oct 8, 2012 at 7:54:40 pm

hello...

both revert to flash for me in firefox and play ok - are you intending to leverage html5 video when possible?

sitruc


Return to posts index


Jeremy Chopra
Re: Trouble getting JW player to work correctly
on Oct 8, 2012 at 9:31:29 pm

Hi Curtis

Thanks for the response, Sorry I forgot to update this topic after I fixed the issue which was probably just before you had a chance to look at the pages in question.. it was a case of me not defining and referencing the jwplayer. Once I did that everything was ok :)

How would I go about leveraging html5 video? It's not something I have looked at but would want to do so yes.

jeremy

http://www.cascadepictures.co.uk


Return to posts index

Curtis Thompson
Re: Trouble getting JW player to work correctly
on Oct 8, 2012 at 9:46:54 pm

hello...

[Jeremy Chopra] "How would I go about leveraging html5 video?"

well - you can use the same player you are now. they have a lot of docs on it, but the basic concept is that you create copies of your movie in a few alternate formats (.mp4, .webm, and .ogg), each of which is supported by ie, chrome and firefox/safari...then the player code you have will play the right version for whichever browser the user visits you with, or it will default to the flash copy.

the downside is that you have to create 3 extra copies of your movie, but the upside is better mobile support and overall forward-looking video technology...

sitruc


Return to posts index


Jeremy Chopra
Re: Trouble getting JW player to work correctly
on Oct 8, 2012 at 9:57:55 pm

ahh ok, would I be right in thinking that would mostly come down to the script used by the player? and not any additional code by me?

definitely want to do that but not sure the best place to start. any suggestions outside of the JWplayer site itself?

jeremy

http://www.cascadepictures.co.uk


Return to posts index

Curtis Thompson
Re: Trouble getting JW player to work correctly
on Oct 8, 2012 at 10:10:45 pm

hello...

ya the point of that player is to generate the embed tags, etc., that are needed, but they are pretty simple to begin with...

[Jeremy Chopra] " definitely want to do that but not sure the best place to start. any suggestions outside of the JWplayer site itself?"

you mean to just learn about it? if so, this is a nice post on it with some sample code so that you can see what's going on:

http://camendesign.com/code/video_for_everybody

sitruc


Return to posts index

Jeremy Chopra
Re: Trouble getting JW player to work correctly
on Oct 8, 2012 at 11:03:26 pm

wow that is a lot of info, just scrubbing through quickly I can see its even covered the history of webM. Great page. thanks..

Will probably try HTML5 at some point but will have to wait for now. the jwplayer wizard didn't really work in my page right so will take a bit more work than have the time to do right now but certainly looks like will not have much of an option soon but to do so to get the tablets on side and all ;)

thanks again

Jeremy

http://www.cascadepictures.co.uk


Return to posts index


Jonas Marsh
Re: Trouble getting JW player to work correctly
on Oct 12, 2012 at 6:06:18 am

You might want to fully check every single detail. I'm not really sure about what is wrong with your video.


Return to posts index

Jeremy Chopra
Re: Trouble getting JW player to work correctly
on Oct 18, 2012 at 11:50:56 pm

Hi Jonas

sorry I have already solved the issue so its playing ok now albeit via flash. It was my mistake forgetting to add the code for the player. Bad mistake, but at least is fixed and working now :)

Jeremy

http://www.cascadepictures.co.uk


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]