BORIS FX: Boris FX Forum Boris FX Tutorials After Effects Motion Graphics

Boris RED not showing in FCP 7

COW Forums : Boris FX

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Adolfo TertulianoBoris RED not showing in FCP 7
by on Aug 28, 2012 at 6:01:46 pm


I just updated Boris RED from version 5.0 to version 5.1.5. I did so because when I tried to launch Boris transitions from FCP 7 it would not load the Boris interface (this, btw, was a recent problem, and I thought it would get solved by simply updating Boris).

The first weird thing I noticed is that during the installation, it didn't list FCP as a host. Here:

I proceeded with the install. Then I noticed I had two different folders in my Applications folder, one for Boris RED 5.0 and another one for Boris RED 5.1.5. Thinking that having both would cause problems, I decided to uninstall 5.0. I then launched FCP 7, only to find out that none of the Boris filters or transitions show up. And so I started this thread.

Any ideas of what could be wrong here? Thanks in advance.

Return to posts index

peter mcauleyRe: Boris RED not showing in FCP 7
by on Aug 29, 2012 at 12:11:57 am

Hi Adolfo,

I'm glad that you provided a screenshot as this made the problem that you are experiencing an easy one for me to diagnose. The issue at hand, based on the screenshot that you have provided, is that you have installed Boris RED 64 into FCP7 which is a 32 bit host. That won't work. You need to download the RED 5 32 bit installer from the website. So go ahead and do that, then install the update and the transitions should be working as expected.

I hope this helps.


Return to posts index

Adolfo TertulianoRe: Boris RED not showing in FCP 7
by on Aug 30, 2012 at 10:30:27 pm

So sorry for the late reply; been busy finishing a project. You were absolutely right. I installed a 32bit version, and now Boris RED is now back in FCP 7. Thank you very much for your help.


Return to posts index

Stephanie innissRe: Boris RED not showing in FCP 7
by on Jun 24, 2015 at 2:47:03 am

Update: I reinstalled Boris 5.1.1 and this time it showed FCP as an install option. I opened up my fcp7 and I can now see Boris Red transitions, however only 2 effects shows up. When I click on the "option" nothing loads, nothing happens. Any ideas.

Return to posts index

Stephanie innissRe: Boris RED not showing in FCP 7
by on Jun 23, 2015 at 11:10:31 pm

I just recently purchased Boris red 5.1 for my fcp7, however Boris did not load in my fcp7 effects bin. Not sure what to do. I have uninstalled Boris and reinstalled it twice and still it does not show up in FCP7. Would love your feedback and direction to resolve the issue.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved