BORIS FX: Boris FX Forum Boris FX Tutorials After Effects Motion Graphics

Alpha in Sony?

COW Forums : Boris FX

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Daniel Stepnik
Alpha in Sony?
on Jan 12, 2011 at 11:49:37 am

I made a logo with extruded spline and text. I want to be able to use it in other movies and have it over a background. I can't seem to get the black backgound to go away. I've set the alpha properties (in Vegas), that doesn't work. I've tried chroma key-kinda works. I've tried to find something in rendering but I don't see anything that would work.
What am I doing wrong?


Return to posts index

John Rofrano
Re: Alpha in Sony?
on Jan 12, 2011 at 5:33:43 pm

[Daniel Stepnik] "I want to be able to use it in other movies and have it over a background. I can't seem to get the black backgound to go away. "
How are you trying to use it in other movies? Did you render it? Are you nesting the project in your movie project? Did you create it in the movie project?

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Daniel Stepnik
Re: Alpha in Sony?
on Jan 12, 2011 at 9:50:43 pm

I've tried rendering it as .mp4 and .mts. I import it into vegas.Put it into the timeline above my background and the logo covers the screen with a black background. Right click on properties, set the alpha to black and the background still remains.

I'm on Win7, Vegas 64 bit, vers 10c, BCC is about 4 days old


Return to posts index


John Rofrano
Re: Alpha in Sony?
on Jan 12, 2011 at 10:42:04 pm

[Daniel Stepnik] "I've tried rendering it as .mp4 and .mts. I import it into vegas.Put it into the timeline above my background and the logo covers the screen with a black background. Right click on properties, set the alpha to black and the background still remains. "
That's because you need to render to a codec that supports an alpha channel. MP4 and MTS are 24-bit codecs. You can't represent an alpha channel in 24-bit. It takes 32-bits to represent the alpha (Red Channel=8bits, Green Channel=8bits, Blue Channel=8bits, Alpha Channel=8bits, 8*8*8*8 = 32bits)

Render with Quicktime 7 and use the Animation codec. This was designed specifically for computer animations like BCC7 produces and will contain the alpha channel information.

You'll need to make this template yourself as Vegas doesn't come with one. Start with the Default Template and press the Custom... button like this:



Then change it to look like this and save it:



~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Daniel Stepnik
Re: Alpha in Sony?
on Jan 13, 2011 at 10:44:35 am

Works perfect! Thanks for the help!


Return to posts index

John Rofrano
Re: Alpha in Sony?
on Jan 14, 2011 at 2:16:01 am

You're welcome. Anytime.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index


Stu Barton
Re: Alpha in Sony?
on Jan 16, 2011 at 1:15:20 pm

Hi John,
I just purchased "Boris Continuum 3D Objects" for Sony Vegas Pro. I am attempting to render to the Quick Time 7 (custom) template as you have described above to create my Alpha channel. I note however that I don't have all the drop down options or the ability to create a custom template in Quick Time 7. This obviously seems to be a problem in not having the correct Quick Time codec's loaded so Vegas can piggy-back off those codec's. In the past I have had some issues with importing certain mov's into Vegas but not others. I was under the impression that with the release of Vegas Pro 10 that this Quick Time/mov issue was going to be resolved. I am currently running the latest Quick Time 7.6.9 and I Tunes 10.1.1.4 programmes. Do I need to roll back to Quick Time 7.6.2 as some forumns suggest ? I'm currently running Windows 7 (64 bit) and Vegas Pro 10.0(c) on an I7 920 chip with 12 GB of RAM. Thanking you in advance John for your assistance.



Return to posts index

John Rofrano
Re: Alpha in Sony?
on Jan 16, 2011 at 4:09:01 pm

Quick Time 7.6.9 works fine on my workstation and I'm running Windows 7 64-bit with Vegas Pro 10c. I noticed that the template in the dropdown on your image is for audio only. That's really strange. Do you have any video tracks in your project?

Do you have any codec-paks installed (like K-Lite, etc.) or Quicktime Alternative? Those might be messing up Vegas Pro. It is definitely something unique to your PC. The custom button should not be grayed out.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Stu Barton
Re: Alpha in Sony?
on Jan 17, 2011 at 1:55:14 am

Hi John and thanks very much for your response. Yes I do have a video track in my project. Apart from the single audio template I get 6 drop down video template options ranging up to 3 Mbps render option. I cannot render any option out due to the compatability issue with Quick Time (see screen grab below) I can play videos in my Quick Time player as long as I set my permissions to "Administator" I cannot import mov's into Vegas accept for mov's off my Canon camera (different codec) I have uninstalled and then reinstalled the latest Quick Time 7.6.9 with no joy however. I have never installed any codec packs or Quick Time alternatives. Supporting applications that I use are mainly based around the latest in VLC, Neo Scene, Handbrake and SUPER. Thanks very much for your time John.

Stu.............



Return to posts index


John Rofrano
Re: Alpha in Sony?
on Jan 17, 2011 at 4:20:41 am

Well... Vegas is definitely telling you that it doesn't think Quicktime is installed properly. You should not have to be an administrator just to playback mov files so something is definitely wrong with your Quicktime installation. You need to figure out what's wrong with Quicktime on your system.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]