BORIS FX: Boris FX Forum Boris FX Tutorials Motion Graphics After Effects

Boris RED 4 will not load if Wacom table not plugged in

COW Forums : Boris FX

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
John Rofrano
Boris RED 4 will not load if Wacom table not plugged in
on Mar 26, 2010 at 1:52:48 pm

I just submitted this to Boris but I thought I would post here to see if anyone can confirm this behavior. I've been having a problem with Boris RED hanging when loading. It would get as far as creating the preview window and then stop. None of the menus would work and you had to kill it from the Task Manager. This has been plaguing me for months.

Boris support was no help. I would get an email with something to try, I would try it and never hear back from them. Then I'd open a ticket again and they'd give me something else to try and after one or two emails I'd never hear back from them. I even posted here but got no results. Boris BLUE worked fine but Boris RED would hang. I finally gave up on Boris RED and bought Adobe After Effects instead.

Well... I was building a new Windows 7 PC and so I loaded BLUE and then RED and RED worked! After loading more software it stopped working. Retracing my steps and thinking about what was different between BLUE and RED I realized that it stopped working after I installed my Wacom tablet drivers. (BLUE doesn't support tablets which is why it worked) Apparently, if the Wacom drivers are loaded and the tablet is not plugged in, Boris RED hangs when loading. If the tablet is plugged in it works fine. It looks like there is a bug in either RED or the Wacom drivers because RED should ignore the fact that the tablet is not plugged in (I don't keep it plugged in all the time because I move it between PC's)

Can anyone else who has a Wacom tablet and uses Boris RED confirm this behavior?

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Matthew Mullen
Re: Boris RED 4 will not load if Wacom table not plugged in
on Mar 26, 2010 at 2:00:11 pm

John,

It sounds like a conflict between the driver and Red.

You can usually stop the process in task manager if you know the name of the driver process.

You can also try disabling the service by going into Device manager> Services and Applications> Services and locating the driver and disabling it.

This could be a temporary fix. If we can get a model number for the Wacom Tablet and a the driver name/version we can have someone look into it.

-Matt


Return to posts index

John Rofrano
Re: Boris RED 4 will not load if Wacom table not plugged in
on Mar 26, 2010 at 7:10:56 pm

Hi Matt, I'll get you that info when I return home tonight. Also got your email. Thanks,

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index


John Rofrano
Re: Boris RED 4 will not load if Wacom table not plugged in
on Mar 27, 2010 at 1:38:18 pm

Hi Matt,

Here is the information you requested:

Wacom Tablet: Intous 3 Model: PTZ-630
Driver: 6.1.5-3a for USB Tablets on Windows 7, Vista or XP (32 & 64 bit)
OS: Windows 7 64-bit

These are the latest drivers from Wacom.

I have a new piece of information. The tablet does not have to be plugged in continuously. It just needs to be plugged in once after reboot. After that, you can unplug it and RED will still work fine until the next reboot.

So it looks like Wacom's driver is not fully initialized until it finds a tablet and perhaps RED just needs to add a timeout on the call to the driver (as a workaround) to not wait for it to come back.

Here is what I did:

I uninstalled the drivers, rebooted my workstation and then RED ran fine. Installed the drivers but did not plug in the tablet. RED hangs on load. Plug in the tablet. RED loads fine. Unplug the tablet, RED still loads fine!!! So... it seems the tablet must be plugged in at least once to get RED to load properly after that until the next reboot (or at least that's the behavior I'm observing) I rebooted twice and saw the same behavior.

Let me know what you find.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

Matthew Mullen
Re: Boris RED 4 will not load if Wacom table not plugged in
on Mar 29, 2010 at 2:00:14 pm

Thanks John! I'll keep you posted.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]