BORIS FX: Boris FX Forum Boris FX Tutorials After Effects Motion Graphics

BCC 5.0.3/Avid MC 3.1 upgrade?

COW Forums : Boris FX

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Bill Nelson
BCC 5.0.3/Avid MC 3.1 upgrade?
on Dec 9, 2008 at 6:46:54 pm

I note with interest that Avid 3.1 requires BCC 5.0.3. That's great, but I'm having a hard time justifying another $600 upgrade w/o confidence that these things work as advertised. After problems with my Boris 4.2.2, (specifically that cool Lens Flare effect that introduces field jitter/interlace artifacts every time I use it) it's difficult to justify another $600 upgrade w/o confidence that these things work as advertised. I posted this problem months ago, and have only heard 'regrets' from Boris. Not like my old Boris Red experience, where a man w/a French accent called me personally with an issue on my venerable ABVB Avid system.



Return to posts index

B.j. Ahlen
Re: BCC 5.0.3/Avid MC 3.1 upgrade?
on Dec 28, 2008 at 11:03:49 am

Why $600?

The most common MC software upgrade is less than $500 direct from Avid, and can be had for quite a bit less from some of their online resellers.

That's for a box upgrade with not just MC3 (which is great), but also all the 3rd party apps that have been quite significantly enhanced, not just BCC5 but also Sonic DVDit Pro HD for example.




Return to posts index

Bill Nelson
Re: BCC 5.0.3/Avid MC 3.1 upgrade?
on Dec 29, 2008 at 10:49:14 pm

The Avid upgrade combined with the BCC upgrade is steep... unless demonstrable additional capability can be utilized. Perhaps I'm not paying attention to the PR, but what does my money buy, exactly? As I mentioned, plugins of mine of the 4.2.2 BCC still have issues that are not rectified.





Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]