BORIS FX: Boris FX Forum Boris FX Tutorials After Effects Motion Graphics

Crashes Everytime... Any help appreciated?

COW Forums : Boris FX

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
mtlongCrashes Everytime... Any help appreciated?
by on Jan 31, 2006 at 8:26:10 pm


We're running Boris Red 3.0.1 on Avid Newscutter Adrenaline 6.1.6. Windows 2002 Pro, Service Pack 2.

We're trying to create a cube turn transition where we start on the left face and the cub turns to the right and down to reveal the top face.

On the Avid timeline, we have three tracks:
V1: Outgoing video with a Boris Red 1 Input Effect (to add some moving text)
V2: A piece of video (Our logo on a moving background)
V3: Incoming video with Boris Red 4 Input Effect to create cube.

V2 and V3 were created in After Effects 6.5 and imported into Avid.

Once in Boris, we'll change Track 1 into a cube and delete Track 2. We change the faces as follows:
Front Face: V2 (Avid's V2)
Left Face: V3 (Avid's V1)
Top Face: V1 (Avid's V3) Flipped BOTH H & V
We don't need the other faces.

At this point, we'll click on the first keyframe to animate the cube... AND CRASH!!! We get an ACCESS VIOLATION from Avid, click ok and the both Boris and Newscutter Adrenaline shut down.

Now, I've tested things out and have successfully created the effect by first animating the cube, then changing the faces. In fact, it seems the crash occurs anytime after we chance the face or possibly flip H & V. Also, this was a transition I've done before without it crashing. Suddently, after teaching the other editors how to create this effect (we're using it as a transition to our endpage for News Promos), it's now doing this.

Any help you can give would be appreciated. I'm glad to have found a work around, but we can't have this crashing like this.


Michael Long

Return to posts index

stephenlnoeRe: Crashes Everytime... Any help appreciated?
by on Feb 4, 2006 at 9:57:15 am

If you do the same effect in the Red stand alone engine, does it shut down red with the same circumstances?

Return to posts index

mtlongRe: Crashes Everytime... Any help appreciated?
by on Feb 16, 2006 at 9:42:55 pm

Sorry it took so long to get back with you... but yes, the same circumstances in the Red Engine and it crashes. Specifically, after I flip the top face both H&V.

Contacted tech support and they still haven't figured it out...

Return to posts index

mtlongRe: Crashes Everytime... Any help appreciated?
by on Feb 19, 2006 at 6:42:44 pm

Tech support got back with me... Seems it's a bug... Here's what they told me:

From some original descriptions we've tried to reproduce the issue but weren't able to. In the original test, however, we didn't note that it was the top face had been flipped around specifically. We went back and found that if the cube effect is done by adding a cube and moving media into it, or by converting the video track into a cube, and switching the H & V of the top face, even in the Red Engine stand-alone, touching a Keyframe will cause an immediate crash, like you saw. Because you're working in Avid, it brought up an Avid alert window, which made us look into Red working within Avid, but really it's a problem within the Red interface.
We've noticed that not only will that happen in Red but it's also cross platform (Windows and Mac), and we've noted it as a bug. However, via odd coincidence, there is a very simple workaround.
If you first create the cube with the video tracks, and then adjust the Front Face to switch H & V, and then switch the Top Face to H & V, the problem will not occur. Then, simply go back and switch the Front Face from H & V to Never (no flip), so that only the Top Face has the H & V flip, the crash will not occur.

Try it this way and let me know if that doesn't work. Sorry for taking a little while to find the error, but we've since been able to produce the crash, as well as prevent a crash with this workaround, 100% of the time.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved