FORUMS: list search recent posts

Blackmagic Intensity Shuttle USB 3.0 on Asus MOBO

COW Forums : Blackmagic Design

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Mike WehnerBlackmagic Intensity Shuttle USB 3.0 on Asus MOBO
by on Jun 9, 2012 at 8:48:41 pm

Ok, where to begin?

I'm attempting to get the BMI USB shuttle to work with a Asus P8Z68-V LX motherboard.

I know that the built-in 3.0 ports will not work because of the proprietary management system, so I bought a USB 3.0 PCIe card and installed it. It is using Renesas driver version and FW version, both of which are higher than the required drivers for the BMI to work.

When I plug the Shuttle into the port a small alert pops up that says "This device could be faster" and "BMI Shuttle would work faster when plugged in to a Super Speed USB 3.0 port", but it's already plugged in to one, so I'm not sure why that error pops up.

I have installed all the latest drivers for the BMI, the USB card, and my MOBO but nothing works. When I go into Media Express it doesn't even recognize that the shuttle is plugged in. In my computer's device list the Shuttle shows up fine and the computer thinks its working correctly. When I open the BMD control panel, it says "No Settings Required" because I'm guess it doesn't see the device as being plugged in.

Is there absolutely anything I can do to get this to work? My computer KNOWS it's there, and this is the most frustrating thing in the world.


Return to posts index

Tom BassfordRe: Blackmagic Intensity Shuttle USB 3.0 on Asus MOBO
by on Jun 9, 2012 at 11:17:58 pm

First try the onboard USB3 ports, they might well work on that MB.

If they don't then proceed to getting the USB plug in card to work properly.
Take it out and put it back in, ensuring you use a 4x minimum PCIe slot (one of the long slots, either the black one or the grey one - it wil not work at USB3 speed in any of the short PCIe slots)

After replugging the card reinstall the driver.

If it still doesn't work then try to upgrade the MB bios and then install the latest chipset drivers.

Return to posts index

Mike WehnerRe: Blackmagic Intensity Shuttle USB 3.0 on Asus MOBO
by on Jun 10, 2012 at 3:18:50 am

Hey Tom, thanks for the input.

My results:

The USB 3.0 ports on the motherboard don't support the NEC chipset so the BlackMagic doesn't even recognize them as being USB 3.0.

My motherboard has both of its PCIe x16 slots taken up by dual video cards, so there's no room to put it besides the x1 slots. But I'm confused by your statement that I won't get USB 3.0 speeds out of the x1 slots. Why would that be? Why would they sell PCIe x1 USB 3.0 cards if they don't work with USB 3.0 accessories?

If need be, I'll remove one of my video cards and give it a try, but I can't believe this would have to be the case. I have two PCIe x1 slots open and I can't use either of them for the USB 3.0 card?


Return to posts index

Tom BassfordRe: Blackmagic Intensity Shuttle USB 3.0 on Asus MOBO
by on Jun 12, 2012 at 10:23:38 am

Have you actually TRIED your onboard USB?

Don't believe the really out of date info on the BMD website - the NEC only remarks were to do with internal system architecture on early USB3 motherboards. People have the intensity working on quite a lot of systems including laptops so i would not believe what the blackmagic website says on the topic.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 All Rights Reserved