CREATIVE COW: Feedback Forum About Us Contact Us Support Articles

"Quote" system is acting strange?

COW Forums : Letters to the COW Team

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Jeremy Garchow"Quote" system is acting strange?
by on Jun 27, 2012 at 3:09:48 pm

It seems the quote system is getting weirder.

I love it, don't get me wrong, I use it all the time, but the past few weeks "Shift-q" seems to be erratic (sometimes it works, sometimes it doesn't) and the Quote button on iOS doesn't work like it used to. You have to press and hold the "Quote" button until a javascript window comes up, and even then it is erratic. It might be the horrible Apple ecosystem to blame (sorry, inside joke), but I thought I'd through it out there that it's not as smooth of an operator as it once was.

Am I holding it wrong?

Thanks, all.

Jeremy


Return to posts index

Abraham ChaffinRe: "Quote" system is acting strange?
by on Jun 27, 2012 at 3:50:55 pm

Hello Jeremy,

Thank you for letting us know about this.

[Jeremy Garchow] ""Shift-q" seems to be erratic"
The hotkey for doing a quote should just be "q". The shift shouldn't be needed.

[Jeremy Garchow] "the Quote button on iOS doesn't work like it used to"
[Jeremy Garchow] "You have to press and hold the "Quote" button until a javascript window comes up, and even then it is erratic."
Yes, I see that on my iPad. Sometimes the first time you tap the Quote button it doesn't fire the onclick event. I've been testing it now and it is working more frequently as I continue to test it. (Maybe it knows its being tested or something =p)

There hasn't been a change to the quote system on this end for a few months but I'll run a few more tests and see if I can figure out what may be causing the issue for you. If there are other behavior patterns that you can help isolate that would help. Erratic behavior of a seemingly static system is hard to debug. Often its easier to fix something that is totally broken than something that just has a few quirks.

Thanks again!

Abraham


Return to posts index

Jeremy GarchowRe: "Quote" system is acting strange?
by on Jun 27, 2012 at 3:57:16 pm

[Abraham Chaffin] "The hotkey for doing a quote should just be "q". The shift shouldn't be needed."

All these years, I've been hitting shift-q! I'll see if 'q' is any better.

Maybe in the description in the response box that reads: "To include any portion of the post in your response, highlight the desired text and hit the "Q" key." Change "Q" to "q"?

It's why I have been hitting shift-q all this time, or maybe I'm a fool. Wouldn't be the first time.

[Abraham Chaffin] "There hasn't been a change to the quote system on this end for a few months but I'll run a few more tests and see if I can figure out what may be causing the issue for you. If there are other behavior patterns that you can help isolate that would help. Erratic behavior of a seemingly static system is hard to debug. Often its easier to fix something that is totally broken than something that just has a few quirks."

I hear you.

The erratic behavior really comes when you press and hold the "quote" button on iOS and get the java pop-up, but then it still doesn't fire, and I have to reselect the quote again, and hit Quote again.

I'll see if I can find a pattern to it and thanks for taking a look.

Jeremy


Return to posts index


Jeremy GarchowRe: "Quote" system is acting strange?
by on Jun 29, 2012 at 3:53:21 pm

OK.

Responding in this thread:

http://forums.creativecow.net/readpost/344/12147

I cannot hit 'q' or 'Q', but the "Quote" button does work. I do notice that my browser (Mac Safari) looks like it's still loading the page (spinning wheel on the top of the tab).

I open the "Activity" window inside Safari and I notice that there's four things trying to load and they are all stuck and they all have to do with Facebook.

Here's a screen grab of the window (I canceled them all):



notloading_2.png

Once cancelled, the 'q' method works.

Hope this helps somehow.

Jeremy


Return to posts index

Abraham ChaffinRe: "Quote" system is acting strange?
by on Jun 29, 2012 at 4:16:50 pm

Hello Jeremy,

Thank you for following up with this. It is possible that the culprit is the Facebook elements or the social like buttons being loaded when trying to use the quote system. Sometimes JavaScript being loaded from these elements can interfere with other JavaScript that has already been loaded on a page. The pages are setup to load the Facebook and other social elements last after all the other elements have finished loading but its possible they are still making the browser not respond properly if they hang for whatever reason (usually a network issue or load on their system). It's unfortunate that these social elements can't be coded more efficiently by these companies and that they have become necessary evils.

How often do you experience the Facebook elements hanging?

Abraham


Return to posts index

Jeremy GarchowRe: "Quote" system is acting strange?
by on Jun 29, 2012 at 4:31:56 pm

[Abraham Chaffin] "How often do you experience the Facebook elements hanging?"

Since the quote system seems to has been not working as usual for me, it must be happening quite a bit lately.

I now see the cause of it, when it happens again, I'll check the activity to see if it's consistently Facebook.

Jeremy


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 CreativeCOW.net All Rights Reserved
[TOP]