CREATIVE COW: Feedback Forum About Us Contact Us Support Articles

The Expressions Box is broken

COW Forums : Letters to the COW Team

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Filip VanduerenThe Expressions Box is broken
by on Aug 16, 2009 at 3:52:20 am

When I put some code in the special "expressions box" textarea in the After Effects Expressions forum, it's not rendered in the final html.

BTW: the way it used to be was that this expression code was placed before the body of the post, but it would make more sense after the body.

kindest regards,
Filip



Return to posts index

Abraham ChaffinRe: The Expressions Box is broken
by on Aug 17, 2009 at 4:03:45 pm

Apologies - should be working again and also moved to show up below the post. The box has also been added to the add post system.

Abraham


Return to posts index

Filip VanduerenRe: The Expressions Box is broken
by on Aug 22, 2009 at 2:32:48 pm

Hi Abraham,

I thought the whole point of the expressions box was that we could copy in expressions using < and > without having to worry how it shows up in the browser and the e-mails.
But now, they just get added to the actual body of the node, wrapped in < code > tags.

The problem is that it's always broken somewhere, either I put in an HTML-entity, but then people can't copy paste the code from their email, or I put in an actual < symbol, with the chance that the browser will think it's the start of a tag, and omit the rest of the line of code.

I think the best way would be to allow HTML-tags in the message-body, but not in the code-box.
Store the code-box as a separate raw text-field, and HTML-encode it on displaying in the browser, but send it as raw data to the emails, since they're not HTML-mails.

Not sure if this is feasible in your databsestructure though.



Return to posts index


Abraham ChaffinRe: The Expressions Box is broken
by on Aug 24, 2009 at 3:47:15 pm

Okay - I've made a few adjustments to it. You should be able to add the code in there without any worries. It will modify the code to display properly in the HTML behind the scenes and will put itself in the email and should be visible properly in our non-html emails.

Let me know if you see any other modifications that need to be made to this.

Abraham


Return to posts index

Filip VanduerenRe: The Expressions Box is broken
by on Sep 1, 2009 at 10:27:13 pm

Hi Abraham,

last niggle about the expressions Box,

all is well , except that single and double quotes are slash-escaped in the e-mails



Return to posts index

Abraham ChaffinRe: The Expressions Box is broken
by on Sep 1, 2009 at 10:57:28 pm

Okay, made the adjustment. Should be good to go now.

Abraham


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 CreativeCOW.net All Rights Reserved
[TOP]