APPLE FINAL CUT PRO: Apple Final Cut Pro X FCPX Debates FCP Legacy FCP Tutorials

Re: FCP7 not recognizing video after replacing audio with ffmpeg

COW Forums : Apple Final Cut Pro Legacy

FAQ   •   VIEW ALL   •   ADD A NEW POST   •   PRINT
Respond to this post   •   Return to posts index   •   Read entire thread


Matt Lyon
Re: FCP7 not recognizing video after replacing audio with ffmpeg
on Nov 15, 2014 at 12:40:47 pm

Before you address the ffmpeg issue, I think you need to figure out why FCP is drawing the waveforms wrong. That shouldn't happen. It probably means the audio is being imported incorrectly (assuming their isn't an issue with the files themselves). Incorrectly drawn waveforms might point to a frame rate mismatch issue, which I discuss in my tutorial: https://library.creativecow.net/lyon_matt/fixing-fcp-assets/1

But for syncing, I wouldn't mess with ffmpeg. Since it sounds like you are simply syncing the clips to the first frame of each media file, the workflow in FCP is pretty quick: Import the processed audio tracks in to FCP. Then you can strip the "bad" audio tracks off the video clips by throwing the files on to a timeline, deleting the audio tracks, then throw the "clean" clips into a new bin, then use the "merge clips" command to sync the video-only-clips with the new audio files. It doesn't take that much longer then typing out a terminal command.

Matt Lyon
Editor
Toronto


Posts IndexRead Thread 


Current Message Thread:





© 2019 CreativeCOW.net All Rights Reserved
[TOP]