Creative COWSIGN IN :: SPONSORS :: ADVERTISING :: ABOUT US :: CONTACT US :: FAQ
Creative COW's LinkedIn GroupCreative COW's Facebook PageCreative COW on TwitterCreative COW's Google+ PageCreative COW on YouTube
AVID:Avid Editing ForumAvid Editing TutorialsAvid Editing Basics ForumAvid Liquid ForumAvid Liquid TutorialsAvid VideoRAID Forum

Re: Does Avid Media Composer 3 work on Mac 10.7.3 software update?

COW Forums : Avid Media Composer / Symphony

VIEW ALL   •   ADD A NEW POST   •   PRINT
Share on Facebook
Respond to this post   •   Return to posts index   •   Read entire thread


Job ter BurgRe: Does Avid Media Composer 3 work on Mac 10.7.3 software update?
by on May 1, 2012 at 11:59:18 am

MC3.5.1 / 3.5.4 are not supported beyond MacOS 10.5.7 and QT 7.5.5/7.6.
MC3.1.x is not supported beyond MacOS 10.5.5 and QT 7.5.5.

If you need to use Avid under 10.7.3, you would need v6. An upgrade to MC6 would set you back 599USD.

There's also a current promo (until June 15th) that lets you crossgrade to Symphony software voor 999USD, which includes BCC8 (a value of at least 495).


Posts IndexRead Thread
Reply   Like  
Share on Facebook


Current Message Thread:




LOGIN TO REPLY



FORUMSTUTORIALSFEATURESPODCASTSEVENTSSERVICESJOBSNEWSLETTERNEWSBLOGS

Creative COW LinkedIn GroupCreative COW Facebook PageCreative COW on Twitter
Share on Facebook
© 2016 CreativeCOW.net All rights are reserved. - Privacy Policy

[Top]