APPLE FINAL CUT PRO: Apple Final Cut Pro X FCPX Debates FCP Legacy FCP Tutorials

Issues with FCPX, mac dustbin and anecdotal resolution

COW Forums : Apple Final Cut Pro X Debates

VIEW ALL   •   ADD A NEW POST   •   PRINT
Respond to this post   •   Return to posts index   •   Read entire thread


Julian Bowman
Issues with FCPX, mac dustbin and anecdotal resolution
on Apr 16, 2014 at 4:40:56 pm

So, I had really bad performance issues with FCPX on my new mac dustbin. I have posted here about it. I took the machine into the Apple store and they did a base level scan and said it seemed fine. I also had a chat with a lad who made some suggestions etc. with regards to trouble shooting and seeing if it is a plugin conflict.

I haven't had any time to test it so have been soldiering on.

yesterday I went to export an edit and everytime I tried FCPX crashed. Then I tried rendering, same thing. I then deleted the text plugin I had used, one I owned but had never used before, and everything was fine.

It was made by Pixel Film Studios, a company I am not overly enamoured with after the ripping off of motionvfx event and mainly because they seem to release a lot of rather poor plugins (look good in the trailer, reality is they aren't). So I deleted every plugin I had installed by them, and although I haven't had the time to test old projects I really struggled with, simply using FCPX seems much quicker and slicker already.

So, currently it is only anecdotal and I will do a fuller test, but deleting their plugins definitely makes everything feel a lot better inside the app.

Just thought I'd share in case others are having issues with FCPX and have Pixel plugins installed.


Posts IndexRead Thread 


Current Message Thread:





© 2019 CreativeCOW.net All Rights Reserved
[TOP]