APPLE FINAL CUT PRO: Apple Final Cut Pro X FCPX Debates FCP Legacy FCP Tutorials

Re: I have an OLD MAC Pro first Generation with FC Pro 7.02 can I run FCX

COW Forums : Apple Final Cut Pro X Debates

VIEW ALL   •   ADD A NEW POST   •   PRINT
Respond to this post   •   Return to posts index   •   Read entire thread


David Mathis
Re: I have an OLD MAC Pro first Generation with FC Pro 7.02 can I run FCX
on Dec 22, 2013 at 11:01:01 pm

[Matt Trubac] " I am pretty sure 10.1 requires Mavericks."

The new version of X does require Mavericks.


Posts IndexRead Thread 


Current Message Thread:





© 2019 CreativeCOW.net All Rights Reserved
[TOP]