FORUMS: list search recent posts

Re: BRU PE Tape Import Tool won't authenticate - "BRU PE Not Installed" - FALSE

COW Forums : Archiving and Back-Up

VIEW ALL   •   ADD A NEW POST   •   PRINT
Respond to this post   •   Return to posts index   •   Read entire thread


Jim Curtis
Re: BRU PE Tape Import Tool won't authenticate - "BRU PE Not Installed" - FALSE
on Jan 10, 2018 at 3:46:17 pm

Adobe has a forum monitored by Adobe employees offering support. So does Avid. Avid tried the ransom model, and last I checked (when I abandoned them around 2010) it was ongoing (and probably necessary for complicated large installations), but they must have realized that in the age of the internet and public forums, it's not a great idea to allow disgruntled customers to trash the company without stepping in to do some damage control - and if that requires free support, then so be it.

It's a coincidence that I happen to be working on a project now for a big and getting bigger health care company who has come to realize this. They have two people on staff whose full time jobs are to scour social media for complaints, and to respond quickly to them. Their reply usually starts along the lines of "We're sorry that we have not met your expectations. Let's see what we can do to address your concerns." They don't point fingers and accuse and belittle customers, even when they're wrong or uninformed, as the worst examples of "customer service" advocates are wont to do.

Tolis seems to have done away with their BRU PE user to user support mail list that didn't have much traffic. They have a woefully out of date "knowledge base" (consisting of a whole 22 articles going back five or six years for BRU PE). I joined the Cow years ago, but it fell into disuse as I've learned to solve most of my own problems. I googled to find this forum for archiving, and is the only one I found geared toward the production industry. That makes this the more or less de facto user forum for thrifty BRU PE users. Slings and arrows.

Companies are going to have to get used to customers characterizing their model of support as ransom. We are creatives, after all. It's a metaphor!

I'll only be dragged kicking and screaming to any new Apple OS, and never again until 10.x.5 at minimum. Fool me twice.... I have a test partition with Sierra 10.12.6 and BRU PE only on it, and I plan to eventually do a fresh install of all my software and plug-ins, which will take days likely, as several of my plugs and apps will require a web authorization reset, meaning I have to contact some vendors and explain what I'm doing (I've had to do this before when upgrading MacPros or after a crashed boot drive.). Using Migration Assistant in the past seems to have migrated my problems and leftover trash in my Library and App Support folders.

Sorry, I seem to have rambled horribly off-topic.


Posts IndexRead Thread 


Current Message Thread:





© 2019 CreativeCOW.net All Rights Reserved
[TOP]