ADOBE PREMIERE PRO: Tutorials Forum Articles Creative Cloud Debate

Mac Pro Acceleration related crashes on Export

COW Forums : Adobe Premiere Pro

FAQ   •   VIEW ALL   •   ADD A NEW POST   •   PRINT
Respond to this post   •   Return to posts index   •   Read entire thread


Andrew Thomson
Mac Pro Acceleration related crashes on Export
on Jul 29, 2019 at 5:00:52 am

I've not ever posted here before that I can recall now, though I've been a long time member... Creative Cow has always been an excellent resource for ideas, tips and troubleshooting for me so thanks to all for many years of this valued resource!

Here's the machine:
Mac Pro6,1 late 2013
6 core Xeon E5
32Gb ram
2x AMD D500 3Gb vram total
Mojave 10.14.6
Premiere Pro 13.1.4

I have consistently used this machine for the last year with next to no issue until v13 of Premiere Pro, whereupon Premiere or Media Encoder consistently hangs, crashes to desktop, or reboots upon an Export operation when running with Metal or Open CL acceleration. It also tends to hang or crash at other times as well, such as during attempts to send a project from Premiere to Media Encoder when hitting 'Queue', or when using Shift+Option launch on Premiere to flush caches and prefs.

This computer sits well within specification sitting halfwayish between minimum and recommended, and the D500 is supported for Mac Metal: https://helpx.adobe.com/au/premiere-pro/system-requirements.html

I do not encounter any issues when working in Premiere Pro during the editing process with Metal acceleration on. I edit mostly H264 4K movs from a GH4 or 4K MXFs from an FS7. I render H264 MP4 files or ProRes Mov files usually at 1080p. Playback during editing is not smooth for much of the time, and I need to let it catch up sometimes but I expect that with these kinds of files, and for what I'm doing it is smooth enough. What's important to me is that it behaves, and the machine did all the editing things I could throw at it without falling over including exporting, right up until recently. Now it does all the editing things I can throw at it without falling over right up until I hit that Export button.

I have tried to troubleshoot as far as I am able with this:
Tried previous versions of the software through Adobe Cloud options,
Checked and revised various folder permissions based on other crash related reported issues scoured from the internet,
Various Premiere project level tricks such as flushing and rebuilding media caches, trashing and rebuilding preferences,
A system reimage by my institutions IT bods and subsequent reinstall of Adobe CC applications,
OSX built in ram test initiated when holding D on boot,
A boot level ram test using memtest that came back with no errors

The crash on Export is consistent and the same no matter what I try. The file object is created at zero kb size, the progress bar window appears but there's no activity, and a minute or two later the machine freezes and reboots on its own.

Nothing in what I can find and read with related changes to hardware acceleration in the latest versions suggests that I shouldn't be able to use acceleration for this sort of work. Using software mode may be a recourse but doesn't really seem like a 'fix' for something that wasn't broken before, and faster performance is important. I'm wondering if this sounds like a hardware issue with the machine, or whether other people have encountered anything similar changing to v13. It's just so strange to me since it worked so consistently well up until then.

Is there anything else I can try?


Posts IndexRead Thread 


Current Message Thread:





© 2019 CreativeCOW.net All Rights Reserved
[TOP]