Apple OS X Forum
external hard drives ejecting after lion install
external hard drives ejecting after lion install
by Maryann Kovacs on Jul 10, 2013 at 7:54:33 pm

My hard drives have been ejecting during data copying from one hard drive to another since updating to Lion.

Here is what I have tried:
• Apple tech support updated drivers on my computer and that didn't help
• Apple tech support repaired permissions on my computer's internal drive
• I have repaired my external hard drives multiple times with disk utility and never seem to get an error. in fact, I do this before each attempt to copy just to be sure.
• I have tried unchecking "put hard drive to sleep" option and made sure the computer never sleeps in the energy saver to see if that makes a difference and it doesn't.
• I have tried reformatting the drives to a different format and that doesn't make a difference.
• I should mention that the drives are larger drives (8 TB) and have their own dedicated firewire port and power supply as well.
• I have tried different hard drive types: caldigit and graid hard drives to see if it is a problem that follows the drive manufacturer and it still ejects the drives regardless.
• I have tried to copy data from different data sets to see if it is an issue with a file in particular that it doesn't like and it never ejects the drive when it reaches a certain file.
• I have checked hard drive eject times to see if there is a set time that the problem occurs and can not see any pattern. Sometimes it will eject after 4 hours of transferring, sometimes 2 hours, sometimes 1.5 hrs. It also doesn't eject after a certain amount of data is being transferred. There is no pattern to that either.
• I have attempted the copy of data between drives with finder and shot put pro (which doesn't use finder) and the drives still eject so it doesn't seem to be copy finder issue.
• I have tried 5 different computers:2 are lion and 2 are mountain lion and one is snow leopard and it ejects the drives on all EXCEPT snow leopard which tells me it is most definitely a problem with lion and mountain lion.
• I have checked the console log during the transfers to see if that could give me any additional information and all it says around the time the disk drives eject is: missing drive etc. There are no errors in the console that jump out at me prior to the missing hard drive error.

I am really stumped about this. One thing I haven't tried yet is to attempt the transfer with esata cables instead of firewire, although I have read that this shouldn't make a difference. Maybe I will try this anyway tonight just to be thorough. I have spend days testing this stuff and I have spoken with at least 4 apple techs about this problem and there are no solutions.
The only thing I can think of is that the system is being put to sleep somehow, which causes a slight power drop with the hard drives which would cause lion to think the drive is being ejected. I have made sure the energy settings are not putting drives or computer to sleep but could something else be doing this? I can't imagine what would be. If I specify those settings, lion should do exactly that and keep my computer awake and drives spinning right? Perhaps there is something else happening.

Any thoughts???