Apple OS X Forum
Managing ports in OSX
Managing ports in OSX
by Steve Long on Jan 16, 2011 at 10:08:15 am

I\'m using Instant Web Publishing in Filemaker to share a database over an intranet. I had everything working smoothly until the hard disk died and I migrated the database over to another computer. I can seem to find any open ports over which to share the database. I\'ve run the Network Utility to scan for open ports and there are none. Is there a manner that I can reset the ports to a default setting (ie: 80 for HTTP, 110 for mail, etc.)? Thanks in advance for any assistance.


Re: Managing ports in OSX
by Steve Modica on Jan 16, 2011 at 12:32:02 pm

The term "port" is probably being overloaded here. (Meaning it has more than one meaning).

There are standard port numbers in /etc/services and I'm sure they are set to the defaults. People don't change those.

I'm guessing he app wants ports to be opened in the firewall so traffic can go back and forth. Do you have a firewall setup on the system?

I imagine some ports need forwarding at the firewall so it can get out.

Steve Modica
CTO, Small Tree Communications


Re: Managing ports in OSX
by Steve Long on Jan 16, 2011 at 1:41:23 pm

Thanks, Steve, for the quick response. I assumed it was at the server side as well, but after being frustrated with the problem on the network cut of my control, I disconnected and scanned the ports on the network behind my own router and encountered the same lack of open ports. Then I performed the same scan from another machine that resides in my network, and found several open ports within seconds. I'll look again, but as far as I know, the problematic computer has the firewall turned off.

Nevertheless, thanks for the input.

Regards,
Steve





© CreativeCOW.net