Apple Final Cut Pro X Forum
FCPX Crashing on Export
FCPX Crashing on Export
by Aloyisius Oxbow on Apr 20, 2020 at 12:07:48 am

Hello! I'm using FCPX 10.3.4 on El Capitan (10.11.6). Suddenly, every video I try to export crashes immediately (I never get to the settings menu). If I try to export as a still image then it either just does nothing or sometimes gives an error saying it failed.

I've tried absolutely everything I can think of and every suggestion I've found in online searches:

- Deleting prefs
- Uninstalling and reinstalling FCP
- Making a new library
- Moving my libraries to a different disk
- Exporting to a different disk
- Deleting render files, turning off background rendering
- Switching to a different OSX user
- Checking all disks (no errors, plenty of room)
- Disabling/deleting QuickTime components
- Deleting a couple new apps I've downloaded since the last time FCPX worked
- Running various repair/maintenance/cleanup tools with Onyx
- Using Digital Rebellion Pro Maintenance Tools (Crash Analyzer, all the cleanup tools, etc.)
- Using Time Machine to revert back to old versions of my FCP libraries
- Rebooting the computer, of course
- Resetting PRAM
- Unplugging everything except necessary drives and peripherals

Many of these I've tried multiple times. Crash Analyzer says it's a "Network Error", though I'm not sure why a network is even needed to export a file? But I've tried checking and clearing all my network prefs anyway.

What am I missing? What haven't I tried? Does anyone have any idea what could be causing this? It's not only on one project but ALL of them, which worked totally fine before.


Re: FCPX Crashing on Export
by Joe Marler on Apr 20, 2020 at 12:19:02 pm

This was apparently caused by /System/Library/PrivateFrameworks/MobileDevice.framework, which had been recently updated. Problem was apparently resolved by restoring a previous version using Time Machine.


Re: FCPX Crashing on Export
by Aloyisius Oxbow on Apr 20, 2020 at 5:35:00 pm

That's correct, I hadn't had a chance to post the update here yet so thank you for doing so!





© CreativeCOW.net