FORUMS: list search recent posts

FCP 7 not working

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Chris Batte
FCP 7 not working
on May 6, 2013 at 8:49:48 am

I just got a new computer: Mac Mini 2.6 Intel Core i7 running OSX 10.8.3 and I can't get FCP 7 to work. Migrated from my old MBP17 running OSX 10.6. I then uninstalled the FCP using FCS remover (selecting all programs) and reinstalled the program from a .dmg located on the new computers HD. I then installed the updater to bring it to FCP 7.0.3

When I try to open FCP I get an error message that reads: "The Waveform Cache Files Folder does not have read/write access. Please select a new folder in the System Settings Dialog or correct the problem on disk."

I've tried the following things to eliminate the problem: erased all Waveform Cache folders (on external drives also) then uninstall/reinstall; I've gone into Disk Utilities and repaired the permissions then uninstalled/reinstall.

Still no luck. Any help would be greatly appreciated.

cb


Return to posts index

Neil Patience
Re: FCP 7 not working
on May 6, 2013 at 5:50:13 pm

There is a couple of other possibilities. Mountain Lion is picky about read write access. It has a thing called Gatekeeper that may be inhibiting the ability to write. Or perhaps more likely you just need to change the read write permissions on the Waveform Cache folder.
Right click the folder - select get info - then at the bottom of the window make sure the user that you are logged in as has read write permission. If you make it read/write for everyone should cover all possibilities.

Hope that helps

best wishes
Neil
http://www.patience.tv

8 Core MacPro, Kona 3, Tangent Wave, Mackie Universal Symphony 6.5 FCP7
i7 2.7 Gig MBP (non retina) 16Gigs Ram Blackmagic Monitor Mini Symphony 6.5 FCP7


Return to posts index

Chris Batte
Re: FCP 7 not working
on May 7, 2013 at 2:01:44 pm

Neil,

Thanks for responding. I should be more clear about what's happening though because I'm more concerned about the crash than the read/write access. Frankly, since the newer installs, there are no waveform cache folders because I've erased them all by now. Even on my backup drive. Every time I open the app I get that error message then I click 'ok' and then the program crashes, not allowing me the opportunity to change anything in the System Setting Dialog.

Here's a list of things I've attempted in trying to resolve this issue. And please note, after every time I did one of these things I've uninstalled and reinstalled the software:

Erased all Waveform Cache folders (on external drives also).
Using Disk Utilities repaired and verified the permissions.
I've done PRAM and SCM restart.

Any other ideas?


Return to posts index


Chris Batte
Re: FCP 7 not working
on May 7, 2013 at 2:04:19 pm

Neil,

Thanks for responding. I should be more clear about what's happening though because I'm more concerned about the crash than the read/write access. Frankly, since the newer installs, there are no waveform cache folders because I've erased them all by now. Even on my backup drive. Every time I open the app I get that error message then I click 'ok' and then the program crashes, not allowing me the opportunity to change anything in the System Setting Dialog.

Here's a list of things I've attempted in trying to resolve this issue. And please note, after every time I did one of these things I've uninstalled and reinstalled the software:

Erased all Waveform Cache folders (on external drives also).
Using Disk Utilities repaired and verified the permissions.
I've done PRAM and SCM restart.

Any other ideas?


Return to posts index

Neil Patience
Re: FCP 7 not working
on May 7, 2013 at 11:36:07 pm

Hi Chris

I see, I think i understand, at least I hope I do. Your post seems clear, perhaps I have the wrong end of the stick.


[Chris Batte] " then I click 'ok' and then the program crashes, not allowing me the opportunity to change anything in the System Setting Dialog."

What I was thinking was that perhaps the crash is caused by the inability to write to the waveform cache folder or perhaps even create the folder - hence the error in your first post which was

[Chris Batte] "I get an error message that reads: "The Waveform Cache Files Folder does not have read/write access. Please select a new folder in the System Settings Dialog or correct the problem on disk."

Obviously you cant get to the FCP settings because by then it has crashed. However as I said the read write settings for that folder are in the OS not FCP. It seems pretty clear from the error message the issue is read write access of some kind.

If FCP has managed to create the folder Waveform Cache but can't write to it then right click on it and use get info to change the read write permissions to all.

If it has not managed to create the folder before the crash then you can do so manually - the default place is usually in "Documents/Final Cut Pro Documents/Waveform Cache Files. This is along with all the other folders that FCP will create by default. (see image)


As I also said it might be that FCP is being refused permission to write by Gatekeeper. Just make sure that in Security and Privacy under the general tab that the correct option is set. You need either "anywhere" or "mac app store and identified developers" if its set to "App Store" that can cause read/write issues for anything not from the App store.

Many people here have installed FCP7 on Mountain Lion without issue. A few have problems but often it turns out that they did not do a clean install of the OS but an upgrade. Obviously ML is not officially supported but then FCP7 isn't supported anymore in any event. I think the last official OS supported was Snow Leopard. I run it on Lion without any problems.

Thats all I can think of in terms of permission error possibilities. You have done everything else. Repair permissions, re-install. etc etc. What about doing a clean OS install ? I know you had a new machine and new installation and its a pain in the a*** but might be worth doing that. I think the "migrated" option you mention may not be the best way and can cause problems.

Hope something there works

best wishes
Neil
http://www.patience.tv

8 Core MacPro, Kona 3, Tangent Wave, Mackie Universal Symphony 6.5 FCP7
i7 2.7 Gig MBP (non retina) 16Gigs Ram Blackmagic Monitor Mini Symphony 6.5 FCP7


Return to posts index

Chris Batte
Re: FCP 7 not working
on May 8, 2013 at 4:35:22 pm

Thanks for responding.

I did get it to work and it was a permissions issue. I removed all the external drives and went into the permission section of my internal drive. I then clicked "apply to enclosed items" which somehow allowed me access to the System Settings in FCP. I then set the Waveform/Tumbnail/AutoSave Vault to a folder I created called FCP on the computer buried in the user structure. Now it works.

3 days of that crap but now I can get back to work.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]