FORUMS: list search recent posts

Using compressor instead of mpeg streamclip, takes 10 times as long. Settings issue?

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Justin Peer
Using compressor instead of mpeg streamclip, takes 10 times as long. Settings issue?
on Mar 8, 2012 at 11:44:47 am

Hi,

new to editing and trying to figure out some of the basics. I'm using a gopro hero2 camera, footage from which needs transcoding to be used in final cut pro from the gopro native mp4 files to quicktime, and it was suggested that I use the apple prores 422 LT option.

I started using mpeg streamclip to do the conversion but found that I was getting a shift in colour balance by doing this. I switched to using compressor v3.5.3 which gives perfect colour rendition but takes forever to transcode. roughly 4 hours of gopro footage is taking 2-3 days to transcode.

I can't believe it should really take this long, otherwise how on earth do professional editors actually get anything done. I'm using a Macbook Pro 2.3Ghz Core i7 with 8Gb ram, bought earlier this year, so the hardware should be up to the job. Any suggestions on whether the speed is reasonable or alternatives to how I might set this up.

Thanks.


Return to posts index

Richard Herd
Re: Using compressor instead of mpeg streamclip, takes 10 times as long. Settings issue?
on Mar 9, 2012 at 6:26:01 pm

You need to post exactly what settings you're using, please.


Return to posts index

Justin Peer
Re: Using compressor instead of mpeg streamclip, takes 10 times as long. Settings issue?
on Mar 9, 2012 at 7:38:40 pm

Hi Richard, I'll explain as best I can. I've not changed any preferences from standard, I open compressor and select the file I want to convert then drag it to the box on the compressor window. I then select the Apple Pro Res 422 LT codec from the settings list and drag it into the selection window. I then select 'source' or other destination and drag that to the blue bar in the selection window, giving me the following:



Sometimes I'll batch run a few files but these are the settings I use. It seems to take 10 times as long as using mpeg streamclip to produce the same output files.

Thanks for your help.


Return to posts index


Andrew Rendell
Re: Using compressor instead of mpeg streamclip, takes 10 times as long. Settings issue?
on Mar 10, 2012 at 10:55:01 am

You need to look at the "Inspector" window for what the settings actually are, rather than the preset.

In general, the things that slow Compressor down are having the "better" or "best" choices in the Resize Filter, Deinterlace and Rate Conversion sections in the Frame Controls and doing a two pass rather than one pass conversion. (Mpeg Streamclip also slows down if you choose multi-pass for your conversion - those things add to the amount of work the computer has to do). I think it's often worth doing a couple of tests with different settings and looking at the resulting files very carefully to decide whether it's worth spending the extra time to get what may be only marginally better quality (sometimes it makes a big difference, sometimes it's hardly noticeable, it depends on the source material and the end use).


Return to posts index

Justin Peer
Re: Using compressor instead of mpeg streamclip, takes 10 times as long. Settings issue?
on Mar 10, 2012 at 2:07:57 pm

Righto, here's what is set, all of which is default settings, several of which are greyed out.

Summary
Name: Apple ProRes 422 (LT)
Description: Apple ProRes 422 for lower bit rate, good quality applications with audio pass-through. Settings based off the source resolution and frame rate
File Extension: mov
Estimated size: 1.79 GB
Audio: multi-track passthrough
Video Encoder
Format: QT
Width: (100% of source)
Height: (100% of source)
Selected: 1280 x 720
Pixel aspect ratio: Square
Crop: None
Padding: None
Frame rate: (100% of source)
Selected: 59.96
Frame Controls: Off
Codec Type: Apple ProRes 422 (LT)
Multi-pass: Off, frame reorder: Off
Automatic gamma correction
Progressive
Pixel depth: 24
Spatial quality: 50
Min. Spatial quality: 0
Temporal quality: 0
Min. temporal quality: 0


Frame controls are off and by default have the following settings.



Encoder settings

File Extension: mov
Estimated size: 1.79 GB
Audio: multi-track passthrough
Video Encoder
Format: QT
Width: (100% of source)
Height: (100% of source)
Selected: 1280 x 720
Pixel aspect ratio: Square
Crop: None
Padding: None
Frame rate: (100% of source)
Selected: 59.96
Frame Controls: Automatically selected: Off
Codec Type: Apple ProRes 422 (LT)
Multi-pass: Off, frame reorder: Off
Automatic gamma correction
Progressive
Pixel depth: 24
Spatial quality: 50
Min. Spatial quality: 0
Temporal quality: 0
Min. temporal quality: 0

In the filters section, no boxes are ticked.

The ultimate aim of this is to be able to import the footage into FCP and edit without sacrificing too much quality, I'm shooting at 720p, 60fps, and then be able to edit and output at 720p. The 60fps is to allow me to slow down footage with twixtor or similar.

Hope this helps, thanks.


Return to posts index

keith mcgregor
Re: Using compressor instead of mpeg streamclip, takes 10 times as long. Settings issue?
on Jul 24, 2012 at 4:16:02 pm

So then when you hit submit do you then choose your cluster? If you don't have Q-master setup properly you should do so as it will take advantage of all your cpu power. The setup is different for every machine (so it seems as I work at a school that has 4 mac labs and not even in 1 lab can I use the same setting for every machine) so you would have to configure it for your system. Here, read this:
http://blogs.creativecow.net/blog/3570/setting-up-apple-qmaster
Should have what you need.
-Keith

Reality? What did you make it?


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]