FORUMS: list search recent posts

Exporting 29.97 Interlaced as 29.97 Progressive

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Josh Aderhold
Exporting 29.97 Interlaced as 29.97 Progressive
on Jan 13, 2010 at 5:43:36 am

I'm working on a project that was shot on HDCAM 59.94 and captured into Apple Pro Res 422. I don't need an answer on the workflow of HD to SD. I've read every freakin post on here about that. They're everywhere.

I simply want to know if I export via compressor and, through frame controls, turn on field dominance to progressive, am I going to get an okay image for DVD playback? Leaving it to "Same as Source" leaves me with a pixelated, jagged image. Turning it off leaves me with a pixelated, jagged image. Comparatively, side by side, nothing I have tried thus far looks as good as the 29.97 progressive DVD. Computer monitors, televisions, plasmas, LCDs. The Progressive just looks better.

Ultimately I just want to know if there is anything fundamentally wrong with exporting 29.97 as progressive without changing my frame rate? Are potential viewers going to run into problems when viewing a 29.97 progressive image?

This question obviously stems from a misunderstanding I have on interlaced vs progressive. I don't expect a lesson on interlaced or progressive. I take full responsibility for educating myself. Just a simple answer that can help me settle this struggle in my head; Am I doing something wrong by setting an interlaced 29.97 image to progressive?

Thanks in advance.

MacBook Pro
Intel Core 2 Duo
2.6GHz
L2 Cache: 6MB
4GB Memory
Bus Speed 800MHz


Return to posts index

Rafael Amador
Re: Exporting 29.97 Interlaced as 29.97 Progressive
on Jan 13, 2010 at 5:55:31 am

Hi Joss,
You shouldn't be getting bad picture on exporting as Interlaced.
Compressor may be miss interpreting the original field order.
So in the "Encoder" tab> Video Format. don't let it in AUTO. Set your self the parameters of the incoming footage.
About de-interlacing your footage, no problem at all. it will look like was shot Progressive and will look better in Progressive monitors.
I've stopped shooting interlaced some time ago.
Cheers,
rafael

http://www.nagavideo.com


Return to posts index

Josh Aderhold
Re: Exporting 29.97 Interlaced as 29.97 Progressive
on Jan 13, 2010 at 5:26:08 pm

Hi Rafael,

Thanks for the response. I've just found that progressive tends to look better than my other tests. Even with the encoder tab set to auto, it shows the correct parameters. NTSC, 29.97, 16:9, Top First. That's what the auto shows. Will simply turning it on instead of auto change anything?

Also I have found that the deinterlacer can't be turned off in frame controls. The manual states you can leave the settings to "same as source" and it will determine what needs to be done. But I've found that even if you do this, it's trying to deinterlace. This is proven (I believe) by the fact that if I change the quality at which it's supposed to deinterlace, my exporting time grows significantly. That says to me it's doing something when set to fast since changing it to better slows down my export.

The only reason I'm using frame controls is because I've found the resizing option leaves me with a far better looking image than with it turned off. I've tried both and consistently I get a better looking image with my resize filter turned to best oppose to frame controls turned off. My problem comes into the fact that I don't seem to be able to turn off deinterlacing, even with "Same as Source" selected. Because of this, and because setting the deinterlace to fast results in a jagged picture, the best work around, I have found, was to turn on progressive.

I've also experimented with exporting a SD clip and bringing that into compressor. My result is actually twice as worse.

If you have anything to add, I would appreciate it. Otherwise, thank you for the answer to my "progressive" question.

MacBook Pro
Intel Core 2 Duo
2.6GHz
L2 Cache: 6MB
4GB Memory
Bus Speed 800MHz


Return to posts index


Rafael Amador
Re: Exporting 29.97 Interlaced as 29.97 Progressive
on Jan 14, 2010 at 2:38:26 am

[Josh Aderhold] "NTSC, 29.97, 16:9, Top First."
Here there is something wrong Josh.
What are you importing to Compressor NTSC or HD?
If is HD, should be Upper-first.
If NTSC, Lower-first.
Rafael



http://www.nagavideo.com


Return to posts index

Josh Aderhold
Re: Exporting 29.97 Interlaced as 29.97 Progressive
on Jan 14, 2010 at 4:49:40 am

Well NTSC is what it is encoding into? Yes?

Here are my settings within Final Cut:

http://img.skitch.com/20100114-bbah1bix9awr9akts36ir2ccj4.jpg

This is HD. Correct? When I was prompted by Final Cut to match the sequence settings to my media clippings, I selected yes. So they should match up exactly.

Here is how the file looks in Compressor:

http://img.skitch.com/20100114-rhx8eqmjcn9sg872u5jf1t1wfx.jpg

Everything seems to be fine. Encoded bounds 1920x1080. Display bounds: 1920x1080.

Then I drop in a setting. I originally dropped in a default settings. DVD Best. Then I made changes and "Save As..." to a new setting type. The Summary:

http://img.skitch.com/20100114-gyj6jcw83qm9tdybdxmwgsb8ai.jpg

Now my Encoder says:

http://img.skitch.com/20100114-erj1stnqniifncqrgdgd225n25.jpg

I switched dominance to Progressive. NTSC is just the format it is encoding into, correct? Even if I turn off auto I can't change it to anything except PAL. Every other option is grayed out.

My Frame Controls:

http://img.skitch.com/20100114-bu7amx2hkypnuxun2x1uu27u3s.jpg

I have set this to Progressive as well.

Like I said before, in every test I have gone over, Progressive just looks better. I have tested it on Tube Televisions, LCD televisions and Plasmas. As well as my computer monitors with VLC. Anything other than progressive is pixelated, has artifacts, jagged edges, light flickering, color trails, etc etc. It's not disgusting (Not all of it. Frame controls auto, encoder auto, that looked the best out of everything I left alone.) But comparatively, progressive has yielded a better look.

Now please tell me if I'm doing something wrong. Or if I should check some setting, something I'm over looking. Anything that sticks out. Because I've looked over almost every post I could find on the forums here and across the web, trying to figure out WHY this might be happening. Maybe I'm just picky and expecting too much from Compressor. But I found that with the settings I've shown you, progressive gives me the cleanest looking image.

Thanks


MacBook Pro
Intel Core 2 Duo
2.6GHz
L2 Cache: 6MB
4GB Memory
Bus Speed 800MHz


Return to posts index

Rafael Amador
Re: Exporting 29.97 Interlaced as 29.97 Progressive
on Jan 14, 2010 at 6:37:16 am

Hi Joss,
Evry thing clear now.
The problem is that the Compressor interface is miss leading.
In the "Encoder> Field order you must check the INCOMING footage field order.
The field order of your MPEG-2 must be set in the "Frame Control" tab, where you can decide to keep the original, de-interlace it or shift fields.



Checking the field order here is the only way Compressor knows the field order of the incoming footage, otherwise it have to guess.
Set "Upper First" in the Compressor and "As Source" in the "Frame Control" should gives you a workable SD MPEG-2 with Upper field order. Should work.
Rafael

http://www.nagavideo.com


Return to posts index


Josh Aderhold
Re: Exporting 29.97 Interlaced as 29.97 Progressive
on Jan 14, 2010 at 7:31:44 am

So you're saying that if I want my outbound field order to be Progressive, the best choice is to select my incoming field dominance to match my HD footage. Being HD and 29.97, my field dominance is upper. So my incoming field should be set to upper and my outbound field should be set to whatever I want it to be.

Like I said before, "same as source" doesn't give me near the quality that progressive does. With the exact setting you suggested and your image shows I get:

Jagged edges.
Visible Interlace lines.
Pixelation on edges.
Color trails.

Time and time again my picture looks better when I set Frame Controls to Progressive. For the most part I've been leaving encoder to auto which shows an upper field dominance. I have switched this to Progressive as well, but you're saying I should leave it to match my incoming footage. Either way, changing my encoder settings or not, I just get a better picture with progressive in my frame controls.

Another aspect which is misleading is whether or not you can turn deinterlacing off in frame controls. It seems I have a choice. Leave frame controls off and suffer from a poor resizing job or turn frame controls on and suffer from a poor deinterlacing job. This has been my experience with it thus far. I would much rather the ability to completely shut off deinterlacing while being able to resize my frame with Frame Controls. It appears this option has been left out. Like I said earlier, if I leave "Same As Source" selected, it still deinterlaces whether I want it to or not. This is proven by the drastic change in exporting time when selecting the quality at which it would do the job. I don't have an option to turn it off. "Same as source" doesn't turn it off.

Thanks for all the help. As long as there is nothing wrong with deinterlacing into progressive, I'll stick with that. It's given me the best quality image so far.

MacBook Pro
Intel Core 2 Duo
2.6GHz
L2 Cache: 6MB
4GB Memory
Bus Speed 800MHz


Return to posts index

Rafael Amador
Re: Exporting 29.97 Interlaced as 29.97 Progressive
on Jan 14, 2010 at 10:11:31 am

Hi Josh,
[Josh Aderhold] "So you're saying that if I want my outbound field order to be Progressive, the best choice is to select my incoming field dominance to match my HD footage. Being HD and 29.97, my field dominance is upper. So my incoming field should be set to upper and my outbound field should be set to whatever I want it to b"
Right.
Your output will be Upper (same as source), Lower or Progressive depending of how you set "Frame Control".

[Josh Aderhold] "Time and time again my picture looks better when I set Frame Controls to Progres"
What kind of monitor are you using?
If you are judging in your computer screen, an interlaced clip will look almost always wrong, even being correct. You need to play your DVD in an interlaced monitor to be sure if there is any interlacing issue.
Rafael



http://www.nagavideo.com


Return to posts index

Josh Aderhold
Re: Exporting 29.97 Interlaced as 29.97 Progressive
on Jan 14, 2010 at 5:08:14 pm

Well I haven't been looking at an interlaced monitor, at least I don't think I have.

This is what I have tested the footage on.

* Multiple computer monitors
* A 46 inch Plasma TV
* A 32 Inch LCD TV
* A 22 Inch Classic GE Tube Television

That's all I have access too. My assumption being if progressive looks better on a 46 inch Plasma and almost flawless on a 32 inch LCD, Progressive should be the way to go.

The image is a little to small to determine on my Tube Television (which is interlaced, yes?) but Progressive looks fine on it as well.

MacBook Pro
Intel Core 2 Duo
2.6GHz
L2 Cache: 6MB
4GB Memory
Bus Speed 800MHz


Return to posts index


Rafael Amador
Re: Exporting 29.97 Interlaced as 29.97 Progressive
on Jan 14, 2010 at 5:29:02 pm

Hi Josh,
Progressive should look well in all the screens.
Your tube TV will tell you if there is something wrong with the interlacing: Or the picture looks OK, or you'll need to turn your face to look somewhere else.
With a progressive monitor you can never be sure if there is an interlaced issue. Progressive monitors can make look bad an interlaced movie or can hide interlacing problems.
Cheers,
Rafael

http://www.nagavideo.com


Return to posts index

Josh Aderhold
Re: Exporting 29.97 Interlaced as 29.97 Progressive
on Jan 14, 2010 at 5:55:57 pm

Great! As long as it looks good, I'm happy.

Thanks for all your help. I truly appreciate it.

MacBook Pro
Intel Core 2 Duo
2.6GHz
L2 Cache: 6MB
4GB Memory
Bus Speed 800MHz


Return to posts index

Josh Aderhold
Re: Exporting 29.97 Interlaced as 29.97 Progressive
on Jan 15, 2010 at 3:21:10 am

New question related to the same thing...

Could my quality be affected in anyway because I have two layers of video that aren't nested together? I have a logo over the top of my video footage as a kind of watermark. But I don't have the layers nested. Would this affect anything when exporting with Compressor?

MacBook Pro
Intel Core 2 Duo
2.6GHz
L2 Cache: 6MB
4GB Memory
Bus Speed 800MHz


Return to posts index

Rafael Amador
Re: Exporting 29.97 Interlaced as 29.97 Progressive
on Jan 15, 2010 at 4:57:01 am

It shouldn't affect the quality.
Nesting must be used only when needed, and to set a Logo there is no need.
rafael

http://www.nagavideo.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]