FORUMS: list search recent posts

Field Kit Deinterlacer not showing as Progressive after render

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Adrian Smith
Field Kit Deinterlacer not showing as Progressive after render
on Jun 15, 2015 at 6:54:05 pm

Hello all. I am working on some old interlaced video that I need to export to After Effects for some Rotobrushing effects work. I have just purchased FK Deinterlacer (Field Kit) as I'm told that is the best tool for deinterlacing the video. I used to use Compressor.

I am just using the default settings and it takes a long time (I was warned this was the case). However after the process has ended and I check the file format info it still shows it as being interlaced and when I export to After Effects it says there is framerate mismatch (59.94 which is the interlaced frame rate).

Can someone tell me if I'm doing something wrong? I have included a screenshot of the FK settings I am using.



Return to posts index

Dave LaRonde
Re: Field Kit Deinterlacer not showing as Progressive after render
on Jun 15, 2015 at 9:58:37 pm

What are the H & V dimensions of the footage being deinterlaced, the FCP edit timeline, and the comp in which you plan to work in AE?

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index

Adrian Smith
Re: Field Kit Deinterlacer not showing as Progressive after render
on Jun 15, 2015 at 11:34:38 pm
Last Edited By Adrian Smith on Jun 16, 2015 at 2:29:04 am

In this instance the video clips I am working with are 1440 x 1080. The video was originally shot in HDV and is now ProRes 422.

The video does not look deinterlaced (no jagged edges, etc.) after running the Field Kit Deinterlacer but the info boxes see it as interlaced in After Effects and in FCP. I rendered it using the above settings.

As a comparison when I deinterlace in Compressor using the frame controls the video is output as progressive and is is seen as such by After Effects an FCP.

Many have told me that Field Kit does a superior job of deinterlacing but I'm confused as to why it doesn't seem to apparently alter the form of the video file - even if the appearance of the video is deinterlaced.

Is there anything I should change in the settings for this to happen. I have searched (and searched) online but found nothing definitive.

I don't often work with deinterlaced video anymore - but clients still send me things from their archives that need the deinterlacing process. I would like to offer the best results.

Not sure if it has to do with the way I'm exporting. My current workflow is to export from crusty old FCP7 as a self-contained Quicktime Movie using the current settings option. Maybe this is where the madness lies - as in Compressor I would change the output setting to Progressive.

Many thanks.


Return to posts index


John Rofrano
Re: Field Kit Deinterlacer not showing as Progressive after render
on Jun 16, 2015 at 11:15:31 am

[Adrian Smith] "Not sure if it has to do with the way I'm exporting. My current workflow is to export from crusty old FCP7 as a self-contained Quicktime Movie using the current settings option. Maybe this is where the madness lies - as in Compressor I would change the output setting to Progressive."
I believe you've successfully identified the problem. The FK Deinterlacer plug-in is removing the interlaced fields from the video stream. If you render to an interlaced format, you will put them back in. You must both use the deinterlace plug-in AND render to a progressive format to totally remove the interlacing.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]