FORUMS: list search recent posts

Final Cut Pro 7 Won't Launch

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Dan O'Sullivan
Final Cut Pro 7 Won't Launch
on Sep 10, 2014 at 3:57:22 pm

I have had this same configuration working for almost 2 years and suddenly, Final Cut Pro 7 won't start.

I have:

Mid 2012 15" Macbook Pro
8GB Ram
512MB Nvida Graphics card
FCP 7.0.3
MacOS 10.8.5

It gets through asking for hardware setup, then hangs.

I've done the following:

Trashed preferences, then used the utility to trash preferences
Repaired Permissions
Zapped PRAM
Uninstalled with the FCS Remover utility
Re-installed FCP 7. Tried to launch without updating, no go.
Uninstalled again
Re-installed and updated before launch, it will go through profiling for RT, then hangs

It was not updated to the latest ProCodec update (1.0.5?) The only thing that I've installed between the last time FCP worked and now was Blackmagic Davinci Lite. Any thoughts


Return to posts index

John Fishback
Re: Final Cut Pro 7 Won't Launch
on Sep 11, 2014 at 5:35:46 pm

The only additional thing I'd do is run Disk Warrior.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]