FORUMS: list search recent posts

FCP 7 on 2013 Macbook Air 11

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Ely Mennin
FCP 7 on 2013 Macbook Air 11
on Mar 5, 2014 at 10:21:04 pm

Recently I installed Final Cut 7 on my 2013 Macbook Air 11". I should say that normally I use a desktop to cut video, but I need a portable solution every once and a while.

So the software install on the MBA went fine, then I noticed a weird issue playing back video out of my timeline. I can only view my sequence playback at Dynamic or Low quality, the high and medium quality options are greyed out.

Is there any way to make FCP 7 work properly on this machine ? I have done some digging and I see that some people are now installing FCP 7 on older G5 machines, not sure if that's the right direction...

Any advice greatly appreciated.

Thanks !


Return to posts index

Roger Poole
Re: FCP 7 on 2013 Macbook Air 11
on Mar 5, 2014 at 11:07:56 pm

FCP7 is intel only so can't be installed on a G5. Unfortunately a Macbook Air really isn't up to the job. You need to have your media on a separate HD for editing. If I'm correct the Air has only USB2 expansion and USB2 drives are no good for video editing. When you launch FCP for the first time it profiles your system for real time playback, if your system isn't up to the job then your RT options will be limited in the way that you describe. That being said, it doesn't mean that your final output will be of low quality, only the display during the edit, but there is still the external storage problem. A Macbook pro with external Firewire or Thunderbolt storage would be a better choice.


Return to posts index

Bret Williams
Re: FCP 7 on 2013 Macbook Air 11
on Mar 6, 2014 at 7:27:05 pm

Wasn't the 11 air the first TB device?


Return to posts index


Roger Poole
Re: FCP 7 on 2013 Macbook Air 11
on Mar 7, 2014 at 2:33:56 am

According to the specs, Thunderbolt "video" expansion. However, as someone else has posted identical problems so it looks like it might be a Mavericks problem. Seems to be a real "dogs breakfast" of an O/S even if you are running, or trying to run, all new everything.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]