FORUMS: list search recent posts

Warning dropped frames! with RAID 0? wtf?!

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Bryan Colvin
Warning dropped frames! with RAID 0? wtf?!
on Aug 21, 2013 at 6:19:55 pm

I am finishing a feature film, and at the final stretch I'm running into problems with dropped frames.

I have a 16TB RAID 0 hard drive array that is filled up to 9.8TB (also backed up on 2nd RAID5 hard drive array for safety)

I have all the red footage on there plus the proxy files.

I have a smaller 1TB that is nothing but the proxies that I have mostly been working from. I started getting frame drops so I decided to go back to the RAID so I wouldn't have performance issues, yet the same error window is popping up with the RAID0 and making this edit take way longer than it should!

I tried Unlimited RT, Safe RT, playback quality dynamic/high/medium/low, scrub high quality on/off.

I don't want to bother trying partial frame rate, that's just unacceptable


i've tried wiping render files and re-rendering on a separate scratch disk

i've pretty tried everything and I still keep on getting that popup window :(


Return to posts index

Bryan Colvin
Re: Warning dropped frames! with RAID 0? wtf?!
on Aug 21, 2013 at 6:36:31 pm

wow, I think I just solved it.

another detail was that I had a 2.35 bars + timecode burn overlay using Apple ProRes 4444 for its transparency.

I moved that to the scratch disk and SOLVED. Now I can put all my settings back to high quality and it works perfectly.

I guess since hard drives can only read at one point at a time, overlaying the timecode burn (which is on a completely different sector on the hard drive), make the needle have to bounce back and forth like crazy to read both at the same time.

By moving it to another drive the scratch disk can focus on reading the timecode burn in file separately, leaving the RAID 0 or even my small 1TB to focus on the footage only.

you learn something new everyday


Return to posts index

Bryan Colvin
Re: Warning dropped frames! with RAID 0? wtf?!
on Aug 21, 2013 at 7:02:35 pm

well, i spoke too soon... its still dropping :( :( :( :( :(


Return to posts index


Alan Okey
Re: Warning dropped frames! with RAID 0? wtf?!
on Aug 21, 2013 at 10:01:45 pm

Please provide these important details:

- What is the throughput of your RAID-0? (Use AJA System test or similar to benchmark)

- What are your sequence settings?


Return to posts index

Bryan Colvin
Re: Warning dropped frames! with RAID 0? wtf?!
on Aug 21, 2013 at 11:57:54 pm

sequence settings:
Frame Size: 1920 x 1080
Aspect Ratio: HDTV 1080i (16:9)
Pixel Aspect Ratio: Square
Editing Timebase: 23.98
Apple ProRes 422 (Proxy)
Audio 48 KHz, 24-bit

all my footage is transcoded as

Frame Rate: 23.98
Codec: Apple ProRes 422(Proxy)
Frame Size: 1920x1080
Pixel Aspect: Square

Data Rate floats around 4 MB/second

Audio media is:
multi-mono files (3-7 tracks)
48 KHz 24-bit
floats around 700/kbs for most (5 tracks)

AJA System Test

The RAID0 drive
Frame Size Sweep
KB MB/sec
Read Write
16.0 27.7 35.0
32.0 58.2 44.8
64.0 69.5 56.0
128.0 76.1 60.4
256.0 78.1 63.4
512.0 81.8 64.6
1024.0 82.3 65.1
2048.0 81.7 64.8
4096.0 81.6 64.8
6144.0 81.6 64.9
8192.0 81.7 64.9

seems to be performing fine

the scratch disk

Frame Size Sweep
KB MB/sec
Read Write
16.0 39.6 31.9
32.0 53.0 39.5
64.0 53.4 47.6
128.0 53.4 49.7
256.0 52.3 50.4
512.0 53.4 51.2
1024.0 52.7 50.1
2048.0 52.7 51.4
4096.0 52.7 50.9
6144.0 53.5 51.6
8192.0 53.1 50.8

I'm at a loss, it seems like I have plenty of power to run this project :(

Computer is
Mac Mini
OS X 10.6.8
2.66 GHz Intel Core 2 Duo
8GB 1067 MHz DDR3 RAM

Both RAID 0 Hard Drive arrray and scratch disk are plugged in to firewire 800 (daisy chained). Raid goes directly into computer, scratch is chained to RAID.

I never used a scratch disk before this problem, i was running entirely on the RAID 0

This project has worked beautifully with NO errors for months. Just the last couple days it started having issues.

I'm wondering if its a problem with the FCP Project file... I have all kinds of backups so I'm trying to open old ones and see if i get rid of hte problem by going to versions before it started acting up

:(


Return to posts index

Bill Dewald
Re: Warning dropped frames! with RAID 0? wtf?!
on Aug 22, 2013 at 1:16:57 am

How large is your project file? I had some weird stuff go on down the stretch on a feature I worked on a few years ago.

Among other things, we broke the project into 20 minute chunks across a number of new projects. It seemed to take some of the stress off.

Even copying your entire show into a fresh project file (selecting the entire project and pasting into a new project) can drastically reduce the project file size. It's one indication that something strange is going on.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]