FORUMS: list search recent posts

Need quick answer...

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Tony Fields
Need quick answer...
on Feb 19, 2013 at 7:43:38 pm

Scenario: Compressor began to stall. Checked out a few forums and came across DigitalRebellion's FCS Remover. Used it to attempt to uninstall Compressor and QMaster. After re-install, kept getting a "Compressor unexpectedly quit" error when trying to launch. After the second attempt, I got the same error message when I tried to open FCP (I had NOT checked that box in DR's FCS remover). I then attempted to remove Compressor, QMaster AND FCP to do a fresh install. When I tried to run the installer, I got this message: "You can’t open the application “FinalCutStudio.mpkg” because PowerPC applications are no longer supported." I checked a few forums and discovered that b/c I'm operating on Mountain Lion, I FCS 2 doesn't work. If it was already on the system, how come I can't reinstall? Here are my numbers:

Processor: 3.33 GHz 6-core Xeon
Memory: 16GB 1333MHz DDR3

Any help? As this is a work computer, upgrading to FCS 3 isn't an option.


Return to posts index

John Pale
Re: Need quick answer...
on Feb 19, 2013 at 7:52:39 pm

The installer for FCS 2 was written for the Power PC processor (Power Mac G4 and G5). It will not work without Rosetta on a Mac with Intel Processors. Mountain Lion does not support Rosetta. I think Rosetta will only work up to Snow Leopard (10.6x)

Ironically, the applications themselves are Universal Binary. They will run just fine in PPC or Intel. It's only the installer that won't run without Rosetta.


There is no easy solution for you.

Perhaps find a copy of Snow Leopard and install it on a second drive. Then boot from that drive to do the install.


Return to posts index

Shane Ross
Re: Need quick answer...
on Feb 19, 2013 at 7:56:02 pm

Someone on the Apple forums had this possible solution:

https://discussions.apple.com/message/21115902#21115902

Shane
Little Frog Post
Read my blog, Little Frog in High Def


Return to posts index


Jon Chappell
Re: Need quick answer...
on Feb 19, 2013 at 9:16:24 pm

If you only uninstalled selected components, you must run Software Update after reinstalling. Otherwise you end up with a newer version of FCP trying to communicate with an older version of Compressor.

My software:
Pro Maintenance Tools - Tools to keep Final Cut Studio, Final Cut Pro X, Avid Media Composer and Adobe Premiere Pro running smoothly and fix problems when they arise
Pro Media Tools - Edit QuickTime chapters and metdata, detect gamma shifts, edit markers, watch renders and more
More tools...


Return to posts index

Tony Fields
Re: Need quick answer...
on Feb 19, 2013 at 10:28:40 pm

thanks. i checked into it, just can't figure out what i'm doing wrong. Here's what i'm getting after i put the script in:

installer: invalid option -target/
Usage: installer [-help] [-dominfo] [-volinfo] [-pkginfo] [-allowUntrusted] [-dumplog]
[-verbose | -verboseR] [-vers] [-config] [-plist]
[-file ] [-lang ] [-listiso]
[-showChoicesXML] [-applyChoiceChangesXML ]
[-showChoicesAfterApplyingChangesXML ]
-pkg
-target <[DomainKey|MountPoint|DiskIdentifier|DeviceNode|UUID]>

any suggestions?


Return to posts index

Tony Fields
Re: Need quick answer...
on Feb 19, 2013 at 10:50:37 pm

Here's my question:
When I got my new tower, FCP6 was running on it already. Why then won't it allow an install?


Return to posts index


Shane Ross
Re: Need quick answer...
on Feb 19, 2013 at 10:53:12 pm

Did you buy your tower USED? And it came pre-installed with FCP? If so, then you don't have a legitimate copy of the application. FCP didn't come pre-installed on any computers.

What OS was the tower running? Most likely FCP was installed under an older OS, and the new OS was installed on top of the old, running system.

Shane
Little Frog Post
Read my blog, Little Frog in High Def


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]