FORUMS: list search recent posts

Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Dale Long
Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Feb 16, 2013 at 3:48:52 pm

So I have been using a Canon 7D for a few years with FCP 7 and loved log and transfer, mainly because of the simple feature where it appended the frame rate to the filename when it created the pro res files to make it easy to sort my 60 fps footage for batch conforming to 29.97 in cinema tools.

I recently bought a Canon Rebel t4i, but now log and transfer doesn't recognize the files.

I tried a trick I found online to modify the .plist file of the eos plugin to include the t4i but it didn't work.

I have searched for hours, but if you've tried to solve this you already know that it appears that someone gamed google on this issue and the first 100 pages of answers are spam for something called the 'Pavtube HD Video Converter', which appears to be garbage, and also $30.

So it seems everyone is using mpeg streamclip, which sucks for me because I have to sort my clips by framerate manually. Whatthat means is if I have 100 files shot in 24 and 60, I ave to load the original camera files in to FCP, sort by framerate, then manually go and put all the 60fps files in their own folder. It takes forever

Has ANYONE gotten log and transfer in FCP 7 to recognize files from the t4i? I really want to maintain my old workflow with my clips labelled by framerate.

Thanks in advance.


Return to posts index

Tony Brittan
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Feb 16, 2013 at 4:02:08 pm

T4i is a great cam but I haven't logged and tranfered as I use Magic Bullet Grinder to process all of my DSLR clips. It's really awesome. 64bit and muti-core aware so it's fast too. It's around $50 but well worth it. You can do custom file naming, batches, and it'll even do proxy versions at them same time for you. Resize and all of that is optional as well. Highly recommend it.

Tony Brittan
Island Shore Productions
Posted from iPad, please excuse typos!

Tony Brittan
Island Shore Productions
Kill Devil Hills, NC


Return to posts index

Dale Long
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Feb 17, 2013 at 3:48:44 pm

Hey.

I took a look at this, it should do the trick, although I don't see framerate as a renaming option.

I assume the workflow would be to sort by framerate, remove the 24fps clips, then do a custom name for that part of the batch?

What's your grinder workflow?


Return to posts index


Neil Patience
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Feb 16, 2013 at 5:11:58 pm

Which version of the Canon tool are you using ? My reason for asking is that I have a 550D (T3i) and the original release worked fine with the plist modification.
Then Canon updated it and indeed it would not work any more with the T3i however the latest version, which I got from the 5DMKIII software page now works again with the same plist mod as before. It seems likely the T4i would be the same ?

So download the latest version, mod the file, I believe you heave to use 650D not t4i in the file and hopefully, like me, yours will work again.

best wishes
Neil
http://www.patience.tv

8 Core MacPro, Kona 3, Tangent Wave, Mackie Universal Symphony 6.5 FCP7
i7 2.7 Gig MBP (non retina) 16Gigs Ram Blackmagic Monitor Mini Symphony 6.5 FCP7


Return to posts index

Dale Long
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Feb 17, 2013 at 12:21:50 am

Hey Neil

Thanks for getting back to me. Can you post your .plist file for me? Maybe my syntax is bad? I'm using E1 plugin version 1.4, and I'm still having no luck after I modified my plist to look like this (I added 650D and REBEL 650D):

[IMG]http://i.imgur.com/bAyFwqp.png[/IMG]


Return to posts index

Neil Patience
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Feb 18, 2013 at 9:52:19 pm

Hi Dale

sorry it has taken me a while to reply, real work getting in way of Cow posting - whatever next!

I dont know if having 2 x 650D's with the rebel is adding to its confusion.

my plist file is below: In theory just change my 550D to 650 D and hopefully it will work. Hope that helps.

Edit: just noticed because I cut and paste the file it has filtered out a bunch of lines in the file.
So added a screen grab as well.




<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">


6D

Canon EOS 6D

1D C

Canon EOS-1D C

60D

Canon EOS 60D

1D

Canon EOS-1D Mark IV

5D

Canon EOS 5D Mark II

7D

Canon EOS 7D

1D X

Canon EOS-1D X

5DMarkIII

Canon EOS 5D Mark III

550D

Canon EOS 550D

best wishes
Neil
http://www.patience.tv

8 Core MacPro, Kona 3, Tangent Wave, Mackie Universal Symphony 6.5 FCP7
i7 2.7 Gig MBP (non retina) 16Gigs Ram Blackmagic Monitor Mini Symphony 6.5 FCP7


Return to posts index


Dale Long
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Feb 23, 2013 at 2:09:22 pm

Well, modifying the plist to add t4i or 650 D doesn't seem to work. It just doesn't see the files. I guess I'll use grinder until Canon addresses this.

Thanks for your help.


Return to posts index

John Sheatsley
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Mar 13, 2013 at 3:51:18 pm

Hey guys,

I finally got it to work! First, you have to download the latest version of the E-1 plugin from Canon here:
http://www.usa.canon.com/cusa/support/professional/professional_cameras/eos...

Choose your operating system, download and install (make sure FCP isn't open) Once you've installed the plug-in, navigate to the cameras.plist file (it's in the same location as before). Here's what my plist looks like:



Save the file, open FCP, and you should be good to go.

John


Return to posts index

Daw Frame
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on May 5, 2013 at 9:50:21 pm

Hi, I've spent hours and still can't get it to work. I am using Lion ver. 10.7.5, FCP ver. 7.03 and have a Canon T3i. I can't get an old version of the Canon E1 plug-in (thought this might help as others have been successful with earlier versions) and have been trying with the latest version, which is 1.4 and having NO success. I would like to delete the E1 plug-in that I have and start from scratch. I guess I can just delete the MIO file? would that be enough?
I believe you are working with vers. 1.4? if so, is there no way to provide a copy of the entire working plist that I could simply copy and paste? as spaces etc. are so critical.
As it is, the files appear in FCP for L&T, but when I queue them, I get an exclamation mark in a red background (essentially signifying an error) and they simply will not ingest correctly, so no viable product.
Rather desperate to get this to work.


Return to posts index


John Sheatsley
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on May 6, 2013 at 3:56:50 am

Here is my updated cameras.plist file. This file worked for me using FCP 7.03 and Mountain Lion 10.8.3.

<--Copy Below--->

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">


6D

Canon EOS 6D

1D C

Canon EOS-1D C

60D

Canon EOS 60D

1D

Canon EOS-1D Mark IV

5D

Canon EOS 5D Mark II

7D

Canon EOS 7D

1D X

Canon EOS-1D X

5DMarkIII

Canon EOS 5D Mark III

T2i

Canon EOS REBEL T2i

T3i

Canon EOS REBEL T3i

T4i

Canon EOS REBEL T4i




<--Copy Above-->


Return to posts index

Daw Frame
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on May 6, 2013 at 9:01:16 am

I don't understand. Your plist is missing all the tags ... string, key etc.


Return to posts index

John Sheatsley
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on May 6, 2013 at 3:13:10 pm

Yeah...that's weird. They were in there when I created the post, but for some reason, they get removed once it's posted. Can you send me your email address so I can just send the file to you directly?


Return to posts index


Dale Long
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on May 6, 2013 at 7:53:21 pm

Hey

I figured this out and posted my plist as a link to an image file and it got blocked, I guess they never approved it.

I KNOW the fix, and have tested it. You modify the plist file, but for some reason I noticed when I was browsing a still photo in Lightroom that my Canon t4i (North American) was listed as the "Canon EOS Kiss x6i"

I am using the E1 plugin version (I think it's 1.3.0.3) with FCP 7 on Mountain Lion.

SO

Open your cameras.plist file, copy and paste the entire 5DMark III section, and replace the first string's "5DMarkIII" with "X6i" and replace the second string that reads "Canon EOS 5D Mark III" with "Canon EOS Kiss X6i" and Log and Captuire will work.


Return to posts index

John Sheatsley
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on May 6, 2013 at 3:17:56 pm

Let's try this...you might be able to download my plist file here:

5951_cameras.plist.zip


Return to posts index

Daw Frame
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on May 6, 2013 at 6:08:57 pm

Faaaannnntaastic! It works! I didn't believe it possible. Thanks for your help.


Return to posts index


John Sheatsley
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on May 6, 2013 at 7:16:14 pm

Excellent! I'm glad it worked for you! Happy logging and transferring!


Return to posts index

liz castro-thomas
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on May 9, 2013 at 10:53:39 pm

Hi John,
Glad you got it sorted, sounds like a saga to sort out. thanks for the link I just went there and apparently with a Mountain Lion and Mac OS operating system i don't need to download a plug -in. am a novice at digital editing and wondered if this could be possible as seems to easy. Dont want to start merrily logging original footage without compressing and find a problem in a couple of months time. If you could spare 2 mins to advice me i would be very grateful. Best wishes, liz


Return to posts index

John Sheatsley
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on May 9, 2013 at 11:59:08 pm

Hey Liz,

Yes, when shooting on a DSLR, it is possible to bring your footage into FCP without logging and transferring. However, there are some things to note. FCP's native format is AppleProRes, which means that files saved to this CODEC do not require any rendering in FCP in order to play them back. DSLR's don't typically use this CODEC, so if you were to import the footage directly into FCP without using the Log & Transfer function, every clip you bring in will need to be rendered as you edit...which is a serious pain in the butt.

In addition to FCP's built in Log & Transfer function, you may also convert your DSLR files to AppleProRes using 3rd party software like MPEG Streamclip, which I believe is a free download. Personally, I prefer to use Log & Transfer for importing because I like to add the metadata to each clip. Plus L&T automatically imports the converted footage into my project, saving me an extra step of having to locate the converted footage and import it.

I hope this helps.

John


Return to posts index


Nicole Alexis
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Jul 9, 2013 at 4:57:13 pm

L&T doesnt work with canon t4i and t5i sd cards, I'm using streamclip now but looking for faster transfer method, any other suggestions?


Return to posts index

John Sheatsley
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Jul 9, 2013 at 5:24:37 pm

It absolutely works with the t4i and sd cards...in fact, I'm transferring footage as we speak. Check my previous posts with my camera.plist settings. You may need to download the latest version of the E-1 plugin first.

John


Return to posts index

Nicole Alexis
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Jul 9, 2013 at 5:54:09 pm

I'm new to this site,not sure how to find old posts but will try to find your old stuff. I didn't see a t4i/t5i plugin on canons site, I downloaded the 5d mark 3 plug in (per canons suggestion) but I read on another thread that it drops frames, did you experience that? Are you also using the 5dmark3 plug in? The mpg streamclip conversion only took about an hour for 30 mins of footage, not too bad. Id hate to use the L&t'd footage only to find dropped frames after hours of editing.


Return to posts index


Dale Long
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Jul 9, 2013 at 8:02:21 pm

L&T does in fact work with those cameras.

I outlined the details earlier in the thread, but I discovered the trick to making L&T work with my North American t4i was updating my E1 plugin and modifying the plist file like this:


Open your cameras.plist file, copy and paste the entire 5DMark III section, and replace the first string's "5DMarkIII" with "X6i" and replace the second string that reads "Canon EOS 5D Mark III" with "Canon EOS Kiss X6i" and Log and Captuire will work.


I think people have verified the other poster's method worked for them too, but for MY t4i using "t4i" didn't work, I had to call it the "X6i" as stated.

If your T3i isn't working with the other poster's method, open up the metadata on a still photo file you took with it (in lightroom or something similar) and see what your camera is called to be certain, then modify the plist file to match and it will work.

(Using mpeg streamclip is a really clunky way to do it, and even clunkier if you're conforming footage with cinema tools.)


Return to posts index

Michael Locke
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Aug 16, 2015 at 8:19:06 pm

Hey shooter/editors,

Latest E1 plugin link I found was NOT Canon USA (go figure)...


http://support-hk.canon-asia.com/contents/HK/EN/0200408402.html


Return to posts index

John Sheatsley
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Mar 13, 2013 at 3:54:45 pm

Correction to my previous post...here's the link to grab the E-1 Plugin:


Return to posts index

Bill Edwards
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Sep 6, 2013 at 8:42:55 am

I managed to get the Canon T5i to work with FCP 7. I installed the recommended EOS Movie Plugin and simply added these to the plist(formatting is ignored on here, so just swap out 5D and Canon EOS 5D Mark II, for example :

key =T5i
string = Canon EOS REBEL T5i

Turns out REBEL was the word that was alluding me!

Happy editing!


Return to posts index

Mark Anderson
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Sep 12, 2013 at 3:30:37 pm

I have the same challenge with T4i footage and using Log and Transfer. Question, when I add to the plist, do I have to delete the current plist that is in my Mac -- OR do I add the plist that John Sheatsley provided below the current plist? Thanks, John! I also added the E-1 movie plug in.

When I try to log and transfer the footage, it now starts to work temporarily but nothing comes up from my SD card.

This is a great thread and I am grateful for everyone's thoughts.

-Mark


Return to posts index

Dale Long
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Sep 12, 2013 at 3:32:10 pm

Just open your existing plist in text edit, make the changes, and re save it.


Return to posts index

Mark Anderson
Re: Has anyone used log and transfer in FCP7 with a Canon t4i? How did you do it?
on Sep 12, 2013 at 3:37:21 pm

Thanks for the quick response. Do I have to simply add to the current plist or do I delete the old list and add John's plist and then re-save?


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]