FORUMS: list search recent posts

FCP7 and OS update compatability

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Stephen de Vere
FCP7 and OS update compatability
on Dec 13, 2012 at 11:46:44 am

I'm running FCP7 and OS 10.6.6 on a 2008 MacbookPro and worried about the update to 10.6.8 because I am in the middle of a 70min doco edit.

Is there somewhere I can check compatability ?



Return to posts index

Neil Patience
Re: FCP7 and OS update compatability
on Dec 13, 2012 at 12:41:31 pm

I have run FCP 7.03 without issue (OS-wise) up to OS 10.7.5, others here are running happily on Mountain Lion - obviously I have at times needed to update plug-ins and ancillary software etc but overall not had any problems. With the major OS changes like from Snow Leopard to Lion etc I have always done a clean install but not on incremental updates.

That said is there a a compelling reason to update your OS mid project ? Because the law of sod is potentially going to kick in and ruin your otherwise nice day.

Have to confess I dont remember what happens between 10.6.6 and 10.6.8 in terms of additional features though.

Might be time consuming but perhaps do a total back up of your drive so you can roll back in the event of something nasty happening.

If you dont have Time machine then Carbon Copy Cloner is very good - I have used it many times http://www.bombich.com

best wishes
Neil
http://www.patience.tv


Return to posts index

Steve Eisen
Re: FCP7 and OS update compatability
on Dec 13, 2012 at 12:48:02 pm

You should have no problems.

You should always clone or make a backup prior to upgrading. This will allow you to go back in case you run into problems.

Steve Eisen
Eisen Video Productions
Vice President
Chicago Creative Pro Users Group


Return to posts index


Stephen de Vere
Re: FCP7 and OS update compatability
on Dec 13, 2012 at 1:13:12 pm

Thanks to both.

I clone all my media drives and my system drive regularly with CCCloner but restoring the OS drive I would prefer to avoid.

I only began thinking I should stop ignoring the update to 10.6.8 when I checked for the Flashback virus today. I think 10.6.8 is a lot to do with security. I know I shouldn't strictly use an edit machine for email and web too but I'm not editing for a client, just myself, so if I run into trouble it's not catastrophic for my business.

Also, increasingly coming across apps and plugins (in particular Java in web browsers) that require 10.6.8 or even 10.7 as a minimum.

Sounds like I should give it a go.


Return to posts index

Neil Patience
Re: FCP7 and OS update compatability
on Dec 13, 2012 at 1:40:17 pm

Yes as long as you have back-ups you should be fine.

best wishes
Neil
http://www.patience.tv


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]