FORUMS: list search recent posts

FCP broadcast safe not working.

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Colin Tse
FCP broadcast safe not working.
on Nov 15, 2012 at 7:56:58 am

First I have a ProRes 422 (HQ) mov in FCP7. I tried to apply color limit and broadcast safe filters to clip out illegal color for broadcast, however the super black on RGB parade cannot be clipped.

Next I change the sequence setting to DNxHD, apply the same filters and this time the illegal luma are nicely eliminated as seen in the scope. But once I render the sequence, or export as DNxHD mov, the visual turned back to original like without filter, and even the luma changed so obvious that I can see the difference by eyes.

I tried a lot of different codecs and all of them are either not able to remove the underblack, or not showing the same result after render. Eventually, the only codec that can reserve most of the visual quality and can clip out the underblack after export is "Animation".

Can any one help to explain why? Perhaps a bug for FCP?

Thanks


Return to posts index

Rafael Amador
Re: FCP broadcast safe not working.
on Nov 15, 2012 at 8:16:29 am

Try with the "Levels" or the "RGB Limit" filters after the Broadcast Safe.
rafael

http://www.nagavideo.com


Return to posts index

Colin Tse
Re: FCP broadcast safe not working.
on Nov 15, 2012 at 8:32:03 am

Thank you Rafael, however it makes no difference by swapping the order of filters.

I tend not to use levels since it legalizes by washing out the video.


Return to posts index


Michael Gissing
Re: FCP broadcast safe not working.
on Nov 15, 2012 at 8:42:10 am

Broadcast safe has never been reliable post render in any codec. By far the best broadcast safe filter is to export a QuickTime movie using current settings. Drop that into a new sequence- send to Color and click broadcast safe on in setup>preferences. Render and send back to FCP. Voila.


Return to posts index

Colin Tse
Re: FCP broadcast safe not working.
on Nov 15, 2012 at 8:49:28 am

Thanks Michael. The trickiest thing is that I did the same send to color with broadcast safe on, but the underblack still persist (scopes both inside FCP and external tektronix).

Could this have anything to do with my AJA Kona 3 card?


Return to posts index

Michael Gissing
Re: FCP broadcast safe not working.
on Nov 15, 2012 at 12:01:16 pm

Were their sub blacks in the luma waveform or just the parades? You can changes the broadcast safe parameters in Color and setup the black level.


Return to posts index


Rafael Amador
Re: FCP broadcast safe not working.
on Nov 15, 2012 at 1:25:52 pm

For me sounds strange.
The default value for Color Broadcast safe is 0 IRE.
In Color is easy to check the sub-blacks clipping checking ON and OFF the Broadcast Safe window.
rafael

http://www.nagavideo.com


Return to posts index

Andrew Rendell
Re: FCP broadcast safe not working.
on Nov 15, 2012 at 2:04:01 pm

Not something I particularly worry about since I always correct my levels and only ever use the broadcast safe filter to catch any odd peaks that I might have missed, but I've just looked at the broadcast safe here and it does indeed allow sub-blacks in the RBG. The composite waveform is properly clipped though, so I guess the filter only legalises luminance and not gamut...


Return to posts index

Rafael Amador
Re: FCP broadcast safe not working.
on Nov 15, 2012 at 4:57:43 pm

[Andrew Rendell] "The composite waveform is properly clipped though, so I guess the filter only legalises luminance and not gamut..."
Yes legalize Luma, BUT..one of the problems with this filter is that do not really control the Chroma amplitude.
When it says "Custom Saturation Limiting", what is really limiting is the full composite signal: Luma + Chroma. This is why the last slider is call Reduce Luma/Chroma. You can pull one or the other to keep the Composite signal below the limit.
The RGB Limiting only works in the highlight, do not clip under-blacks.
This is filter comes from the time of the SD NTSC and PAL, so was not intended to legalize things that were not a problem at that time (under-blacks and RGB gamut.

HOWEVERy, the stand alone "RGB Limit" filter (Color Correction filters folder, no the one inside the Broadcast Safe filter) WORKS PROPERLY controlling the RGB levels, clipping RGB at the needed levels.
rafael

http://www.nagavideo.com


Return to posts index


Colin Tse
Re: FCP broadcast safe not working.
on Nov 16, 2012 at 2:39:48 am

So mysterious that I tried all methods and couldn't simply clip out the underblack even with the use of Color, RGB Limit (the standalone filter). The only way I can do is to set the codec as "Animation", or push up the black level in Color, however also crash out the black detail making the black as "greyish".

Also curious about the incorrect luma/chroma of render for DNxHD. Is it because of the difference in color space for DNxHD and others say ProRes?


Return to posts index

Colin Tse
Re: FCP broadcast safe not working.
on Nov 16, 2012 at 2:40:57 am



Return to posts index

Colin Tse
Re: FCP broadcast safe not working.
on Nov 16, 2012 at 4:53:11 am

The super black only on parade, not on luma waveform.


Return to posts index


Michael Gissing
Re: FCP broadcast safe not working.
on Nov 16, 2012 at 6:17:58 am

Then you shouldn't get pinged by a broadcast tech check. I think the parade display is before broadcast limiting of blacks. I have seen sub black in parade before but not on final luma output.


Return to posts index

Colin Tse
Re: FCP broadcast safe not working.
on Nov 16, 2012 at 6:43:25 am

The sub black also on output when checking on an external tektronix WFM.


Return to posts index

Colin Tse
Re: FCP broadcast safe not working.
on Nov 16, 2012 at 6:56:39 am

Very much appreciate all the good thoughts and input.

I couldn't find a good way to eliminate the sub black so guess just stick into "Animation" codec by now. Will do more experiment and research to see if better achievement can be made.

Thanks


Return to posts index


Rafael Amador
Re: FCP broadcast safe not working.
on Nov 16, 2012 at 1:43:52 pm

The Animation codec will do it because is 8bRGB and will clip below bit 16 and over b239, but may cause few color issues.

For me this sounds to some kind of FC misfunction.
I would trash the "Constant Frame" folder and the "Waveform cache" files, and refresh FC Preferences and repair Permissions.
As I mentioned on my system the "RGB Limit" works perfectly.
rafael

http://www.nagavideo.com


Return to posts index

Colin Tse
Re: FCP broadcast safe not working.
on Nov 19, 2012 at 1:42:45 am

Thanks Rafael and I'll try your suggestion and see if it gives any better result.

However I've tried three FCP stations with same configuration and hardware spec, all have the same result. Could this possibly be any config or hardware related issue?


Return to posts index

Colin Tse
Re: FCP broadcast safe not working.
on Nov 19, 2012 at 9:14:48 am

I did the trial and it looks the same. However I discovered that the color is perfectly legal in RGB space, however bleach out in YUV space. May be this is the reason why RGB limit not works since it clips all illegal color only according to RGB color space.

The trouble is I need to make the video also legal within YUV space for broadcast.


Return to posts index


Rafael Amador
Re: FCP broadcast safe not working.
on Nov 19, 2012 at 3:26:43 pm

[Colin Tse] " I discovered that the color is perfectly legal in RGB space, however bleach out in YUV space."
I think your picture may have some very shiny and saturated areas.
I don't know the picture you are working with, but for what you say, I think you need to make a proper Color Correction before trying to legalize it.
Broadcast safe is OK to get rid of some peaks that pass the levels after CC, but if your picture is very out of range and you just clip things, the picture can look very bad.
You need to correct first Luma and Saturation and you may need to make some secondary CC, otherwise if you just drop an RGB Limit filter, color may just disappear from bright saturated areas.
rafael

http://www.nagavideo.com


Return to posts index

Colin Tse
Re: FCP broadcast safe not working.
on Nov 20, 2012 at 8:26:51 am

Very much appreciate for your help Rafael. I starts to suspect if the video itself has some strange color coding.

The picture originally looking like this:


and the RGB parade like this (1):


When I switch the seq codec to animation, the RGB parade looks like this (2):


The strange thing is, if I have the seq codec as ProRes422 (HQ), the parade looks like (1). However if change any parameter in the scope display (e.g. from parade to waveform back to parade, or change the current frame to previous then back to current, or scope display to "All Lines" or other), the parade looks just as good as (2)! But once I move to another frame, the parade back to the bad one (1).

Any change in scope display makes the parade look good and any move on timeline makes it look bad.

I guess I may have to go back to original animator for primary color grading as suggested, but curious why I couldn't eliminate the underblack by all means within FCP. The best I can do is to raise up the black level, making everything greyish.

Thanks very much for your kind assistance.


Return to posts index

Rafael Amador
Re: FCP broadcast safe not working.
on Nov 20, 2012 at 1:31:55 pm

I don't see nothing wrong on your original picture. Nothing too bright or too saturated.
BUT for the two gray bands that I see in the Parade snapshots (up and down), I can see that you have set "Render always in 8b RGB" in your Sequence settings.
Set "Render in high Precision YUV" in your Prores sequence. Don't use the Animation codec.

What I can see as well is that the original picture has a 1 pixel wide frame all around the image. Is almost black but has different tonalities (it can be just because the Aperture). This might be causing the super-blacks. You can see that with the Digital Color meter (utilities).
Another thing is that the blacks are too high, so blacks are no real blacks (like the guy head). But this can be a designer decision.

So try what I told you with Prores HQ and "Render in high Precision YUV". Then drop the RGB Limit filter on top to clip the super-blacks. I don't think you have any super-white.
rafael

http://www.nagavideo.com


Return to posts index

Colin Tse
Re: FCP broadcast safe not working.
on Nov 21, 2012 at 3:16:11 am

Thank you Rafael and frankly I learn so much from you.

I have my sequence set as ProRes422 HQ, render in high precision YUV, have cropped 1% of all edges, dropped in "RGB Limit" and "Broadcast Safe", and under black still persist.

With curiosity I tried to crop further on the image and found that the under black have gone away when all black portion are cropped.

Further study I tried scaling up the picture and discovered that the underblack gradually raise up back to legal when I scale it heavily up say 300%. Sorry for my dumb would this because I blow the video signal up thus reducing the noise in the black?

I try to upload a sample of 1 sec and hope this can help the analysis.


Return to posts index

Colin Tse
Re: FCP broadcast safe not working.
on Nov 21, 2012 at 3:18:41 am

Sorry miss-press the button before I say thank you. By all means I don't just look for a solution but also want to unveil the mysterious cause to enrich myself.

Much appreciated.

http://reels.creativecow.net/film/sample-for-underblack-video


Return to posts index

Rafael Amador
Re: FCP broadcast safe not working.
on Nov 21, 2012 at 12:46:07 pm

Sorry, but I can't do nothing with the clip you uploaded. I can't download it. and even if I could, the clip will be Broadcast Safe if has been converted to h264 with QT. All the illegal values are clipped on compression.

[Colin Tse] " Eventually, the only codec that can reserve most of the visual quality and can clip out the underblack after export is "Animation"."
Answering to this: This is normal. When you set Animation as the sequence codec, FC forces render in 8b RGB. There there blacks are mapped to 0% (bit 0) and whites to 100% (bit 256). No room for under-blacks or super-whites. Under-blacks and supper-whites happens in YUV.


Questions:
- Which application is the cartoon coming from?
- Are they coming from AfterEffects?
If so, there is no way that there are under-blacks. AE clips everything under 0% and over100%.
- Which is the original codec of the animation?


[Colin Tse] "With curiosity I tried to crop further on the image and found that the under black have gone away when all black portion are cropped."
As I mentioned, the issue may come from the "Aperture": the way that QT present or open movies.
Another thing that could be causing troubles, is if the clip has been exported with an Alpha channel.

Can you send me "1 frame' of the original footage?
Do like that:
- Open a clip in QT Player and put the play head wherever you want.
- Hit "I", then hit "O".
- Copy (Cmd-C).
- Open a new window (Cmd-N) and paste (Cmd-V).
You will have movie with just one frame. Then "Save as..".
Save the new clip as self contained.
You can zip it and send it to me to nagavision at nagavideo dot com.
rafael

http://www.nagavideo.com


Return to posts index

Colin Tse
Re: FCP broadcast safe not working.
on Nov 22, 2012 at 1:42:54 am

Thanks Rafael I learn so much from you!

The original footage was created from Flash by an animation house , so difficult to go back and change the color. (Not sure what gadget they used by don't think its AE). Then converted to "Animation" mov wrapped for FCP edit.

1 frame sample file has been created as instructed and sent to you through email.

Very much appreciate for your help!!

Colin


Return to posts index

Rafael Amador
Re: FCP broadcast safe not working.
on Nov 22, 2012 at 5:26:06 pm

Hi Colin,
The first I have to tell you is that I know almost nothing about cartoons.
I see two issues with the picture:
- First the blacks and whites. That's easy to appreciate as soon as you have a look to the scope. Blacks are too high (3%)and Whites are too low (90%). I don't know if this is intentioned, but I don't think so.
This can be due to the conversion RGB to YUV. If've saw different applications behaving in many different ways depending of the codecs they were dealing with.

- Second is that there is something wrong with most of the black line that conform the profile (outline) of the characters. The thin almost black line that separate them from the background, and most of all in the areas where the line is almost vertical, there are some pixels where the BLUE channel is screwed. There is no Blue information at all. Even rising the Saturation with the 3W-CC, the Blue channel value keeps = 0. and I'm almost sure that's the origin of the noise we see as underblacks.

Is not difficult to detect it: Open the picture in the canvas at 100%, and with the Digital Color Meter (Utilities) set with "1 pixel aperture", pass it very slowly by those borders. You will notice that before the picker reaching the inner Black area (R=G=B= 3.1), many times the Blue value is = 0.
And if you upscale the picture and you look at the FCs Parade you can easily tell that most illegal Blue values (underblues) are concentrated on those "borders" lines.
No idea about the reason of those pixels.

How to fix it?
If you just want to get rid of the under-blacks, running the movie through compressor with the "Broadcast Safe" ON, will do it. also, just running the clip through AE, should get rid of any illegal RGB value.
If you want to fix the movie, you have to fix two things:
- Levels: Rise the whites and crunch the Blacks.
- Fix the noise; There is noise on the Chroma channels on the lows. You will get rid of a lot of that by crunching the Blacks, and will help you also the "Desaturate Lows" filter (Set it; "Apply Below 5 or even below 10. Those color shouldn't really have chroma. Softness: 5 to 10). This will clean all that spill on the underblacks.
I've also tried with the best denoiser available for FC (Neat-video) which is able to clean the noise on the Chroma channels, and also makes disappear all the spill on the underblacks.

I can see some times a single point on the under-blues. This shows up whenever I tweak some filters, but always disappear when I open a new Scope window. At this point, I'm not sure if that can be just a problem with the very scope.
I've done all the tests on a ProresHQ sequence and as you know, with just a single frame.
My opinion is that the reason of those issues may be the inconsistent conversion of the footage (color spaces, codecs, platform (?)), with no color managing.
rafael

http://www.nagavideo.com


Return to posts index

Colin Tse
Re: FCP broadcast safe not working.
on Nov 23, 2012 at 4:31:55 am

Thank you Rafael, you've done so much that I really appreciate and also real sorry to keep troubling you.

I've done the same and yes I can find the thin edge that may be the trouble source. The underwhite and overblack are the poor color correction from the offline editor which can be easily fixed. Our concentration is how to eliminate the illegal black (underblack).

I tried to replicate the same as you suggested but have some troubles:

1. I cannot find an option in Compressor to check broadcast safe on.

2. Applied all filters as suggested (even to a higher extend) can eliminate some underblack, but majority of them still persist. (As snapshot)


I don't know if there is any wrong setting incorporated in my FCP machine that has different outcome from your test. Will go back and check again.

Also I will try to ask how the animation house create the file so to determine how these troublesome black thin lines are generated.

Thanks

Colin


Return to posts index

Rafael Amador
Re: FCP broadcast safe not working.
on Nov 23, 2012 at 5:51:45 am

[Colin Tse] "1. I cannot find an option in Compressor to check broadcast safe on."
Sorry,
I meant Color, no Compressor.

I've rendered the file in Color with the "Broadcast Safe" filter ON and also in AE.
Imported back to FC, both files keep showing that spills on the underblacks.
In years I've never heard a single complain about legalizing with Color.
In the other hand, getting off-levels in AE is technically impossible, so the only conclusion I can reach is that FCs scope is faulty.
Rafael

http://www.nagavideo.com


Return to posts index

Colin Tse
Re: FCP broadcast safe not working.
on Nov 23, 2012 at 7:15:24 am

Very lovely. Thanks Rafael.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]