FORUMS: list search recent posts

HD Sequence forcing interlacing - an error in my workflow somewhere

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Terry Hahin
HD Sequence forcing interlacing - an error in my workflow somewhere
on Sep 24, 2012 at 5:41:01 pm

This is a topic killed to death here. So my apologies. But I have been looking up my exact issue and cannot find an appropriate solution from the countless iterations of interlacing issues here on the cow.

I want a progress 1080p sequence. I go to the sequences settings, hit "custom" in the aspect ratio. I do this because the only preset in there is the "HDTV 1080i." So I choose in the end:

Frame Size: 1920x1080
Aspect Ration: custom
Field Dominance: none
Editing Timebase: 25
Compressor: Animation

I choose the compressor because I have a mix of Ex3 XDcam footage and After Effects Animation Footage. I find when I do a final master export of a sequence with Animation codec after effects material, in a more lossy codec such as Pro res, the graphics end up very chunky. So I export everything at the end in a Animation sequence.


This works fin except that things that Final Cut is rendering like transitions, overlay, etc, add interlacing into them. Not all the material. Everything is clean EXCEPT THE MATERIAL THAT FCP IS RE_RENDERING.

Very Baffling.

My only clue is that when I look back at my sequence settings, I see that FCP has changed my aspect ratio back to HDTV 1080i, even though I have set everything up to be a progressive sequence. I rechange it to "custom," so it's not 1080i, but it just changes it back again....

Does FCP just refuse a progressive 10809 sequence.

Am I going insane?

Terry Hahin

Designer and Editor
terryhahin.com


Return to posts index

Shane Ross
Re: HD Sequence forcing interlacing - an error in my workflow somewhere
on Sep 24, 2012 at 6:17:13 pm

1080 is an interlaced format. That's the nature of 1080. You can have PROGRESSIVE settings, but the format is known as 1080i. 720p is progressive format, and will always be known as 720p.

You will have to render pretty much everything if you use the Animation codec as a sequence setting. It is not RT in any way. But the question I have is, what is the intended final output of this going to be? Displayed how? Will you export an Animation Codec final to be played somewhere? If so...what will play the Animation Codec without stalling and sputtering?

How are you monitoring your project? Using the computer display? Looking at the CANVAS and the VIEWER and judging quality? That's not the place to do it. They aren't designed to show you full quality, or what things will actually look like. IO devices like those by AJA, Blackmagic Design, Matrox...connected to an HDTV or broadcast monitor will show you a more realistic example. Except they won't play out if you use Animation sequence settings.

Shane
Little Frog Post
Read my blog, Little Frog in High Def


Return to posts index

Terry Hahin
Re: HD Sequence forcing interlacing - an error in my workflow somewhere
on Sep 25, 2012 at 12:33:24 pm

Shane,
thanks for quick response.

Workflow is usually this. Shoot material in various formats. Transcode to Pro Res. Cut in that Pro Res Compression sequence setting for RT.

I find I can't output in that compression setting though, because my Animation material from After Effects gets extremely crunched up in the codec. So in the final Output I switch to animation to output. So the Render issue you talk about is not an issue.

This is the only solution I have found that does not crunch up the graphics in my outputs.

These outputs are for web, not broadcast. I am viewing the final output on the desktop in quicktime. Not judging the interlacing issues here in the Canvas or Viewer.

Everything works fine, except that Final Cut adds interlacing to material that it is rendering. An example of these moments are:

transitions
time warps
motion warps

it's a problem because has an inconsistent amount of interlacing.

Thoughts?

Thanks in advance,
terry

Terry Hahin

Designer and Editor
terryhahin.com


Return to posts index


Rafael Amador
Re: HD Sequence forcing interlacing - an error in my workflow somewhere
on Sep 25, 2012 at 2:24:48 am

[Terry Hahin] "I want a progress 1080p sequence. I go to the sequences settings, hit "custom" in the aspect ratio. I do this because the only preset in there is the "HDTV 1080i."
That is ASPECT RATIO, it doesn't means the resulting stuff wil be Interlaced.
As Shane poits, 1080, even being progressive is streamed as interlaced (psf).

So, conform your sequence to the EX-1 footage, change the sequence setting to Prores, and forget about Animation.
Set as well "Render in High Precision".


[Terry Hahin] "I find when I do a final master export of a sequence with Animation codec after effects material, in a more lossy codec such as Pro res, the graphics end up very chunky. So I export everything at the end in a Animation sequence."
Animation is by now a legacy codec. Use Prores444 instead.
rafael

http://www.nagavideo.com


Return to posts index

Joseph Owens
Re: HD Sequence forcing interlacing - an error in my workflow somewhere
on Sep 25, 2012 at 4:10:56 pm

[Rafael Amador] "Animation is by now a legacy codec. Use Prores444 instead."

If you need to keep things in RGB with alpha. ProRes4444 can get quite big, but the problems that Animation codec present to the Y'CbCr FCP preview are bigger.

Try using Compressor to render out the finals, rather than from the Timeline or FCP Conversion options. The rules change once you leave Final Cut, and I have found transitions to come out much cleaner.

I'd also be interested if "Square" was chosen rather than custom AR. You might have to change the aspect ratio on most of the footage, but that is something I work through all the time when flowing anamorphic (1440x1080) media through color correction.

jPo

"I always pass on free advice -- its never of any use to me" Oscar Wilde.


Return to posts index

Mike Newton
Re: HD Sequence forcing interlacing - an error in my workflow somewhere
on Nov 20, 2012 at 5:24:39 pm

Hello Terry,

I have had this EXACT issue multiple times. The issue is not that the footage is 1080, as you can edit progressive just as easy as 720. The compressor is also fine. The trouble is with poor FCP coding...

I found a workaround which will hopefully work for you.

1. Make a new sequence.

2. Drop a piece of 1080 progressive footage into that sequence, and when FCP prompts "do you want the sequence to match clip settings yotta yotta yotta" you say yes.

3. Open the sequences that is giving you problems, cmd+a (select all), then cmd+v [copy].

4. Open your new sequences. cmd+v [paste].

In some instances I have had to do this multiple times after opening/closing FCP. Its a quick workaround though as compared to waiting for the render, and ending up with interlaced footage.

-Hope this helps!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]