FORUMS: list search recent posts

Canon MXF Plugin for FCP Won't Install

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Jordan Hart
Canon MXF Plugin for FCP Won't Install
on Jun 11, 2012 at 7:14:42 pm

Hey Guys,

I am the tech director for a tech camp, and we have hundreds of cloned Macs all with the same issue. We can't install Canon's plugin (Canon XF Plugin for Final Cut Pro 1.3) which is downloaded here:
https://www.usa.canon.com/cusa/consumer/products/camcorders/professional_ca...

It's a .app installer that just refs another .app installer, which just ref another. When it gets to what I believe is the second in the chain it throws the error in the attached screenshot:
"You don't have enough priviledge to install. Log in as an administrator and try again."

We are running Bootcamp with Lion and Windows 7, of course this is the Lion side where we are working with Final Cut. Final Cut Studio 3 is installed, as is FCPX, I've tried the plugins and utilities for both and they all fail the same way. Some machines are 2008 Macbook Pros, most are 2010 Macbook Pros, and many are iMacs. All have the same issue.

Things I've tried already:
1. Logging in as Root
2. Changing permissions (Library folders and the App folders)
3. Repairing disk permissions
4. Creating a new admin user
5. Rebooting
6. Reinstalling Final Cut
7. Using terminal with sudo

I've been beating my head against it and getting absolutely no where. Nothing has had the slightest impact on the error. Any help or ideas would be greatly appreciated, I'll be dealing with hundreds of Macs all summer with the same issue.

Thx,
Jordan


Return to posts index

Phillip D'Annibale
Re: Canon MXF Plugin for FCP Won't Install
on Jun 28, 2012 at 8:51:00 pm

Well I don't have a solution for you other than to say that I think it might be a problem on Canon's end.

First of all I can't even download ver 1.3 from their US a site, I had to get it from Canada and Asia. Tried to install both of those files and got a generic "An error has occurred. Error = 1" from both installers (Logged in as an admin, os x 10.6 fcp 7.0.3).

Seeing how it was just released June 6, I don't think many people have hit it to discover that maybe Canon botched the installer and I can only hope that since I cant get it from the US site, Canon is aware and fixing it. I sent an email to them via their website, so we'll see...

-----
Phill


Return to posts index

Jordan Hart
Re: Canon MXF Plugin for FCP Won't Install
on Jun 29, 2012 at 12:04:23 am

Hey Guys,

Here's the solution I ended up coming up with. The installer works fine on some computers, not sure why it doesn't work on others. If you can find a computer it does install in correctly, then you can grab the files it places from that machine and just manually move them over.

There are 2 folders you need to pull, a Canon folder from Macintosh HD / Library / Application Support, and the MIO folder from Macintosh HD / Library / Application Support / Pro Apps

While not a real fix, it's gotten us by for both FCPX and FCP7. Hope it helps.

Jordan


Return to posts index


Joseph Finneran
Re: Canon MXF Plugin for FCP Won't Install
on Oct 30, 2012 at 10:52:51 pm

Hi Jordan,

It's now almost November and I'm having exactly the same problem mentioned above, and Canon pro support's only suggestion was that I repair permissions via a root user (as mentioned above). I'm staring at a high-priority C300 project that we wrap shooting on tomorrow and would love to avoid transcoding all the footage by using Log & Transfer.

This may seem like a wildly outrageous request, but is there a chance that you'd be willing to post those two folders (and their contents) for us unlucky suckers who don't have other machines to try and get lucky on?

Any other suggestions from anyone with this plugin problem other than "get lucky?!" I'm calling Canon back but would love more ideas (or help from Jordan!)

Thanks,
Joseph


Return to posts index

Nick Grechler
Re: Canon MXF Plugin for FCP Won't Install
on Oct 31, 2012 at 8:34:03 pm

Joseph - I feel your pain with this issue - I had a Mac Pro that I simply could NOT get the XF Utility installed on. Therefore I have uploaded the files you asked for - it worked for me.

4895_canonxfutilityinstalledfolders.zip

Canon folder should go in Library/Application Support/
MIO folder should go in Library/Application Support/ProApps/

Good luck.

-Nick


Return to posts index

Thaddeus Setla
Re: Canon MXF Plugin for FCP Won't Install
on Jan 30, 2013 at 4:47:37 am

After reading all these posts and trying everything that was mentioned I am still not getting this to work. I am working on a MacPro Dual Quad Core 2.66 with Mountain Lion. I have added the folders to the directory and repaired all permissions as well. Since I have a project due in 2 days with this footage I am hoping for a quick fix here!

Thanks for any help you can provide from here.

Thaddeus Setla
http://www.setlafilms.com

Thaddeus Setla - DP/ Editor
http://www.setlafilms.com


Return to posts index


Chris Novy
Re: Canon MXF Plugin for FCP Won't Install
on Mar 10, 2013 at 12:43:37 am

Nick:

Your solution worked for me with FCP 7.0.3 and Mountain Lion. I created a Creative Cow account just to post this thank you message.

..Chris..


Return to posts index

Josh Miller
Re: Canon MXF Plugin for FCP Won't Install
on Jan 11, 2014 at 5:11:08 pm

Nick-

From the set of a commercial in LA I send you some serious thanks and kudos. 10.9 Mavericks destroyed my C300 workflow through FCP and I was hastily looking for solutions and abandoning hope when I stumbled upon this thread. Sincere thanks


Return to posts index

Guilain Depardieu
Re: Canon MXF Plugin for FCP Won't Install
on Jan 18, 2014 at 6:14:07 pm

works just fine, thank u !


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]