FORUMS: list search recent posts

Error Message about unavailable memory block when exporting video.

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Ben Rich
Error Message about unavailable memory block when exporting video.
on May 28, 2012 at 7:19:30 pm

When compressing a small 3 min HD project to ProRes in Compressor I receive this error message in FCP 7. The plus in it's referring to is the the "Neat Video noise reduction" plugin for FCP ( which i use on my footage. I am not sure what this error means and how to fix it. I have 46 gigs free on my local HD. below are my system specs. The compression starts and acquires some progress before this message appears and stops everything. I then have to force quit FCP and restart my computer. Any help would be welcome.

Hardware Overview:

Model Name: iMac
Model Identifier: iMac8,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.8 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 6 MB
Memory: 4 GB
Bus Speed: 1.07 GHz
Boot ROM Version: IM81.00C1.B00
SMC Version (system): 1.30f1
Serial Number (system): YD9200GGZE4
Hardware UUID: 51149474-E9A3-5751-9DC8-CC8976F0BA42

Ben Rich
Videographer | Technologist

Return to posts index

Ben Rich
Re: Error Message about unavailable memory block when exporting video.
on May 28, 2012 at 7:58:27 pm

I received a reply from Neat Video's technical support on this issue. Quite informative. Will try their recommendations now:

It is a systemic issue related to the overall 32-bit software
system including FCP, its filters including Neat Video, codecs, etc.

FCP 7 is a 32-bit application (not 64-bit one) and so it (together
with all used plug-ins and codecs) can use up to about 2.5-3 GB
only, irrespective of the available physical RAM. This is a
limitation of any 32-bit application on Mac.

Apparently, the project - and that includes all the components
involved - FCP itself, filters you use (including Neat Video),
input codecs that read input clips, output codecs that encode
the output clip, and the like, - is hitting the limits of the
memory space available to FCP (2.5-3GB) and at some point Neat
Video (as one of the components residing in that limited memory
space) is not getting the requested memory block required for
regular processing and in that situation it cannot do anything
but report that problem using that error message that you have
shown. It cannot continue processing without the memory block.

There are several measures that could be used to reduce the
memory load and prevent such a condition from occuring:

1. Reduce the amount of system memory given to FCP:

Preferences > System Settings > Memory & Cache > Application

By default, it is usually set to 100%. Please try to reduce to
something like 50-60%
If more memory within those 2.5-3 GB remains free then OSX
may be able to provide it to Neat Video when it is needed
for processing.

Remember to restart FCP after changing the above settings.

Only if the above doesn't help, try the following options:

2. When you apply Neat Video, try to use a generally
simpler project, with fewer clips and fewer filters applied.
If possible, render them one at a time.

Use smaller frame size if possible. Do not use large still
images directly in the timeline, instead resize them down
before including into the project.

Restart FCP whenever possible. This makes memory resources recover.

3. When exporting, use a simpler output compression scheme, like 1-pass
instead of 2-pass. Or use a different output compression codec.
Different schemes and different codecs use different amount
of memory. Simpler ones usually are more economical in terms of memory use.

4. Reduce the number of CPU cores used by Neat Video for
processing. Click the Options button to open the main window
of Neat Video. Then go to menu Tools > Preferences > Performance
and in that tab make sure the settings are set to use only CPU
and for example only one CPU core. This will reduce the
speed, but may also somewhat reduce the memory load.

Please try these options above. Please let me know if the stability improves.

The best solution would be to switch to a 64-bit version of FCP.

Another possibility would be to pre-denoise each individual clip
before importing them into your main project. That would require
some additional manual work of course..

I hope some of these ideas will help. Please let me know your
observations and findings. Perhaps we will then also come up with
some new ideas.

Ben Rich
Videographer | Technologist

Return to posts index

David Eaks
Re: Error Message about unavailable memory block when exporting video.
on May 28, 2012 at 10:51:35 pm

Can you tell us more about your workflow on this project? What was the original source of video, editing codec, did you export "self-contained" or "send to compressor", what is the final delivery format etc. etc?

Return to posts index

Michael Gissing
Re: Error Message about unavailable memory block when exporting video.
on May 29, 2012 at 12:19:54 am

With your system spec you shouldn't be sending to Compressor from the FCP timeline. In FCP make sure all is rendered and then export a self contained QT Movie using current settings.

Close FCP and then open that file in COmpressor.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 All Rights Reserved