FORUMS: list search recent posts

ProRes keeps making me render audio?

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
john whiteway
ProRes keeps making me render audio?
on May 17, 2012 at 9:43:41 pm

Hello,

The other day I used Compressor to change some MP4 video files from a Blackberry Playbook tablet to ProRes so that I could edit them in Final Cut. I opened Final cut and without altering my existing Audio/Video settings imported the files. When I did I got a message asking me if I wanted the settings in my new sequence to conform to those of my media source. I clicked yes. After that all works fine up to a point. I can watch and listen to the clips in the Viewer but once I make a selection and place it in the Timeline I get the little red line that says I have to render the audio. I do that and all's fine again. But this is a nuisance, and somehow I feel this shouldn't be the case. I've opened a new Project and Sequence and changed all the settings to the ones you see below, then imported the same files. But no change.

Does anyone understand what's happening and how I might correct things?

John

Here are my A/V Settings as they are now:

Sequence Preset: Apple ProRes (HQ) 1280 X 720 30p 48 kHz
Capture Preset" HDV- Apple ProRes (HQ).... (I didn't think the Playbook was HDV but there is only one ProRes (HQ) setting to choose from. Also this shouldn't matter as the files were converted in Compressor and directly imported.)
Device Control: Firewire NTSC
Video Playback: [missing] Apple Firewire NTSC (720X 480)
Audio Playback: default


Return to posts index

Shane Ross
Re: ProRes keeps making me render audio?
on May 17, 2012 at 10:26:50 pm

You no doubt had AUDIO PASSTHROUGH selected when you did the conversion. It's on by default. You need to uncheck that and manually make the audio Linear PCM 16bit stereo 48kHz. Otherwise FCP will want to render.

Shane
Little Frog Post
Read my blog, Little Frog in High Def


Return to posts index

john whiteway
Re: ProRes keeps making me render audio?
on May 18, 2012 at 3:22:49 pm

Thank you very much for the reply. This is the first time I've used Compressor so am still sorting my way through the program. I've gone back to look at the settings I've used and see that, as you say, AUDIO PASSTHROUGH is the default setting with the ProRes 422 (HQ) codec. I'm wondering though where I'd go to change that to Linear PCM 16bit stereo 48kHz as you suggest. In the Inspector pane I can click on an icon that would seem to offer me the chance to change audio settings but these options are all greyed out, as if with the choice of ProRes you are stuck with the entire package. Is there some other place in the program where I can make this manual change? Or do I have to be using something other than ProRes (HQ) to begin with? (Also while I'm at it, I'm assuming that correcting my problem means changing these settings then converting my Playbook MP4 files all over again.)

Again, thanks very much for taking the time to give me your help.

John


Return to posts index


jerry wise
Re: ProRes keeps making me render audio?
on May 17, 2012 at 10:40:37 pm

i also would get the red line and i found out that my sequence was set to 48khz but my source was 44.1khz. i ran it thru soundtrack pro and upped it to 48 and all was good.


Return to posts index

john whiteway
Re: ProRes keeps making me render audio?
on May 18, 2012 at 4:04:15 pm

Thanks very much for the reply.

Right now I'm going to try the solution suggested by Shane Ross. I think it will work, but I'm kind of restricted to doing that anyway. Seems this challenge of converting MP4 files has thrown me into a study of FC Studio I've been able to avoid till now. In short, I've never had reason to tackle Compressor or Soundtrack Pro before, and so far it's just been Compressor I've been doing battle with. Soundtrack Pro is next on my plate, so as it is right now I wouldn't know how to make the conversions you outline above.

I did, out of curiosity, go back over some of the notes I've accumulated in the last few days. I went onto Blackberry chat rooms, and there one fellow replied giving me the full specs on the MP4 files the Playbook produces. He says it's audio is "MPEG-4 AAC at 128Kbps, stereo (2 channels) 48 kHz sampling" If that is the case do you think the solution you suggest would work in my case? (If I strike out on Shane's idea I will be tackling Soundtrack Pro and your suggestion next.)

Thanks again for all your help.

John


Return to posts index

Bret Williams
Re: ProRes keeps making me render audio?
on May 18, 2012 at 4:58:26 pm

You sure don't need prores HQ! Use 422 or LT.


Return to posts index


john whiteway
Re: ProRes keeps making me render audio?
on May 18, 2012 at 5:44:38 pm

Thanks for the reply.

I'm wondering if either 422 or LT would help.

At the moment I'm trying to figure out how I can apply Shane's suggested solution of removing "audio passthrough" and manually setting the audio. Trouble I'm facing is that all the QuickTime codex, including the two you've just mentioned, include "audio passthrough". And if one goes to Inspector is seems that none of these codex allow a change in audio setting. (As the manual says, I've just found out, "If a setting has "pass-through" selected the Filter pane audio filters are not available...")

Bottom line I'm wondering if any QuickTime codex can solve my problem.

John


Return to posts index

Dave LaRonde
Re: ProRes keeps making me render audio?
on May 18, 2012 at 6:30:59 pm

Make your own custom preset in Compressor. You can highlight the one you used previously, then hit a but to create custom preset. You can now change the settings on the custom.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

john whiteway
Re: ProRes keeps making me render audio?
on May 18, 2012 at 7:11:59 pm

Thanks for the reply.

I've just been searching Compressor to see if I can figure out how to do what you suggest. I can highlite the ProRes codex I used in the settings window but when I do that I can't figure out where this button is that will allow me to create a custom preset. It's likely in front of my nose, but could you tell me exactly where it is?

Thanks.

John


Return to posts index


Shane Ross
Re: ProRes keeps making me render audio?
on May 18, 2012 at 7:14:24 pm

IN the INSPECTOR...the ENCODER tab, second from the left. VIDEO will say ENABLED, and AUDIO will have the "settings" greyed out and say PASS-THROUGH. CLick on PASS-THRU and choose ENABLED. Then click on SETTINGS.

Shane
Little Frog Post
Read my blog, Little Frog in High Def


Return to posts index

john whiteway
Re: ProRes keeps making me render audio?
on May 18, 2012 at 7:44:41 pm

Hi.

Wish I could attach a screen-shot of the information I'm seeing on Inspector/Encoder.

As you say, to the right of "Video" is a button saying "Settings". To the right of that is another button saying "Enabled". Directly below the word "Video" is the word "Audio" and next to it buttons that say "Settings" and "Pass-through".

The problem is the entire Inspector/Encoder window is greyed out and will not allow me to make any of the changes you suggest.

John


Return to posts index

Dave LaRonde
Re: ProRes keeps making me render audio?
on May 18, 2012 at 8:07:42 pm

That's why you have to create a custom preset: no more grayed-out boxes.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index


john whiteway
Re: ProRes keeps making me render audio?
on May 18, 2012 at 8:16:19 pm

Hi,

Sorry for being so slow with all of this.

My problem seems to be two-fold. 1) When ProRes 422 (HQ) is highlighted I can not see the button you suggest I hit to create a custom preset. 2)When ProRes 422 (HQ) is highlighted the Inspector/Encoder window allows no changes.

I'm at a loss.

John


Return to posts index

Dave LaRonde
Re: ProRes keeps making me render audio?
on May 18, 2012 at 8:28:26 pm

Hover over the buttons at the top (bottom?) of the panel where the presets are. See what they say. You'll find it.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

john whiteway
Re: ProRes keeps making me render audio?
on May 18, 2012 at 10:44:00 pm

Hello again Dave.

Sorry but what you've suggest doesn't seem to work for me. With ProRes 422 (HQ) highlighted (its info displayed in Inspector) I see three buttons at the top of the Settings panel/window: "Create a New Setting Group", "Save Selection as Droplet", "Duplicate Selected Setting" and "Create a New Setting" (where a list of 13 possibilities appear). Hovering above or below the Settings panel/window, or right-clicking while I do, in my version of Compressor, I'm afraid, yields nothing.

John


Return to posts index


john whiteway
Re: ProRes keeps making me render audio?
on May 19, 2012 at 12:28:10 am

Always a way I guess.

How to create a custom setting. How to determine what to put in it. How to "re-create" ProRes 422 (HQ) but with audio that doesn't need rendering.

Using all the messages and suggestions I've been receiving these last two days I think I've finally been able to figure it out.

First, I realized I CAN'T change the settings of the ProRes 422 (HQ) that already exists in Settings. In the manual and elsewhere I've seen several messages that say precisely this. For example, when trying anything I thought I'd see what would happen if I dragged the ProRes 422 (HQ) setting to the Custom folder. When I did I got the message: "ProRes 422 (HQ) could not be moved because it can not be modified".

So the change has to come elsewhere. Turns out the answer lies in the "Add" button at the top right of the Settings window. When you click on it a list of 13 formats appear. I checked the ProRes files I'd created that had problematic audio and saw that they were all QuickTime Movie files. That was a clue. With the Custom folder highlighted I clicked "Add+" and then chose QuickTime Movie.

Now I finally had the beginnings of a Custom Preset. What now? How do I get the settings in it that Shane had suggested? Now both Video and Audio said "enabled", but what next? Trick turned out to be clicking the "Settings" button next to each. Clicking the "Settings" button next to "Video" and there was the list that allowed me to select "ProRes 422 (HQ)". Clicking the "Settings" button next to "Audio" and I was able to select the "Linear PCM 48kHz" that Shane recommends.

Now I seem to have it. I've converted some of my Playbook MP4 files with this Custom Preset and voila, the audio no longer needs rendering!

An interesting past two days. Thanks to everyone who's helped me.

(Though all this said I still can't help but ask: Does anybody see a flaw in my solution?)

John


Return to posts index

Bret Williams
Re: ProRes keeps making me render audio?
on May 21, 2012 at 9:00:18 pm

You didn't try the option you mentioned labeled "duplicate selected setting?"

This is a pretty standard thing in FCP and other software that has presets of any sort. You can't adjust a factory preset. Duplicate it first, call it what you will and change away.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]