FORUMS: list search recent posts

FCP 7 App corrupt? Can I restore from Time Machine or do I need to reinstall?

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Mike Raff
FCP 7 App corrupt? Can I restore from Time Machine or do I need to reinstall?
on Mar 22, 2012 at 5:38:46 pm

My assistant's copy of FCP seems to have become corrupted. It was working fine yesterday before he went to lunch, but when he came back it would crash whenever he tried to launch it.

Tried all the usual tricks: trashed prefs, repaired permissions, deleted recent render files. No luck.

I had cloned his boot drive to an external drive about a month ago, so I attached the external, changed his startup disk and re-booted. Final Cut launches just fine from the cloned drive. So I conclude that something about the copy of FCP on his Mac Pro boot drive has gotten corrupted.

Does that sound reasonable?

My next line of attack is Time Machine. I've not used it before, but I backed up his boot drive, including Apps, to Time Machine a couple of weeks ago. TIme Machine is supposed to revert your computer to a previous working state, right? So this ought to solve our problems, no?

Here's what happened. I went to his Time Machine backup, selected Final Cut Pro in Applications and was offered the choice of replacing the application or keeping both the old install and the newly restored one.

So I opted for Replace. The process appeared to start, showed that it was estimating how long it would take to copy the file, then stopped. Tried this twice to no avail. So on the third attempt, I opted for Keep Both. This time, it started copying. I was watching the App folder on the MacPro and, sure enough, the old Final Cut Pro application icon had "(original)" appended to it while a new Final Cut Pro icon appeared greyed out as the copying continued.

But when the copying from Time Machine finished, it turned out not to be a new FCP application icon, but a folder called Final Cut Pro with a volume of just over 500 GB. And inside the folder, I could not find a new FCP app icon. Instead, I found a folder marked Contents which included the following:

_CodeSignature (folder)
CodeResources (alias)
Frameworks (folder)
Info.plist (file)
MacOS (folder)
PkgInfo (file)
Plug-ins (folder)
Plugins (folder)
Resources (folder)
version.plist (file)

Not sure what this means, but it's not the outcome I was hoping for. Did I do something wrong? Or was my expectation of Time Machine incorrect? I was hoping for a new FCP app icon. (Or was my existing backup somehow flawed in the first place, and therefore not capable do of doing what I'd like it to do?)

Unless I can find a simple Time Machine solution, I think I'm looking at a uninstall/reinstall of FCS 3 at the least. And if that doesn't do it, a clean install of the OS and all the apps.

Any advice or insight would be welcome.

TIA,

Mike Raff
Richmond, VA


Return to posts index

Bret Williams
Re: FCP 7 App corrupt? Can I restore from Time Machine or do I need to reinstall?
on Mar 22, 2012 at 5:57:37 pm

Just drag the app from your backup to the App folder. If that doesn't work just reinstall FCP (not the whole studio) from your install discs.

But really I'd try booting from your backup drive, and repairing the main system drive with disk utility.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]