FORUMS: list search recent posts

field dominance problem

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Esben Hardt
field dominance problem
on Jan 8, 2012 at 12:29:56 am

Help! I have a rejected master from a TV distributor who says my master has interlace errors "all over it".

I cannot see anything wrong on my 3 monitors but the TV distributor's tech department and also a friends studio reports that the movie plays back in a "stuttery" way on their monitors. I am using the BlackMagic Decklink HD Extreme video card on a TV-Logic broadcast monitor via HD-SDI, a JVC Analog Component SD monitor via Component, and a Sony HDTV via HDMI. None of these show the error. But if I play back the master file using the spacebar command in Finder (Snow Leopard) there are bad jagged/combing edges on all motion in the pictures. If I compress it for Quicktime, DVD and BluRay I get a "stuttery" playout on my HDTV, and jagged/combing edges on the computer monitors.

My master film has been pieced together in FCP with clips exported out of Avid, DaVinci Resolve, and ProRes converted material originally shot on XDCAM EX and DSLR's. Some of these clips (Avid or Resolve) must have had the fields swapped to the wrong order as my ProRes 422 HQ master file is in the correct Upper field dominance format.

I have used the following sequence settings for the timeline:
Frame Size: 1920x1080, HDTV 1080i (16:9)
Pixel Aspect Ratio: Square, NOT CHECKED, Anamorphic 16:9
Field Dominance Upper (Odd)
Editing Timebase: 25
Compressor: Apple ProRes 422 (HQ)
Quality: 100%
Compression Type: Apple ProRes 422 (HQ)
Frames per second: 25
Camma Correction: Automatic
CHECKED, Interlaced, Top field first
NOT CHECKED, Enable chroma filtering for 4:4:4 sources

I have analyzed the clips in the timeline for field dominance using the Item Properties command and 75-85% turns out to have field dominance set to None, while the rest has it set to Upper.
Is this a problem for FCP?
How can I force the clips on the timeline to have field dominance set to Upper so that they all match up to the master timeline's settings for field dominance?
Let's say f.ex that the clips from DaVinci Resolve has the wrong field order within them, how can I force just these clips to swap around before adding them to my timeline?

If I changed the sequence settings in the timeline to LOWER, then exported the film. Then used compressor to re-compress it using a field dominance of UPPER would that just bring me back to scratch?
What if I took the (many) clips in the timeline that have a field dominance of NONE and ran them through compressor using a setting with the field dominance set to UPPER, then re-linked to these clips in my UPPER timeline. Would that be a fix?

Mac Pro 2 x 2.4 GHz Quad-core Intel Xeon
OSX 10.6.8
FCP 7.0.3
Avid MC 5.5.3
DaVinci Resolve 8.1.1
ATI Radeon HD 5770
SeriTek2ME4 e-SATA controller
4x CalDigit VR
BlackMagic Decklink HD Extreme

Return to posts index

Chris Tompkins
Re: field dominance problem
on Jan 8, 2012 at 2:58:01 pm

1st off, viewing the clip (final master movie file) played back on the computer screen, will not look correct, esp. if Interlaced.

If 3/4 of your material is Progressive, why didn't you edit this in a Progressive Sequence?

You have quality i/o card an monitor in place, this should show any issues.

Chris Tompkins
Video Atlanta LLC

Return to posts index

Esben Hardt
Re: field dominance problem
on Jan 9, 2012 at 7:20:53 pm

Thanks for helping. And maybe I am chasing a ghost here..? I have been to an online studio today and followed the copying of SD Digibeta tapes from my HD masterfiles, and as far as I could see there was nothing wrong with them! Tomorrow I am going to the other studio who told me that there is a problem with the HD master file. I want to see it for myself. I want to know what they can see on their monitors that I can't here...
I will let you know the verdict! For now we will assume that there are no error, but I did experience this (see photo) on my studio monitors when I scaled one of the clips in the timeline to 104%. Which is why I am worried there is some kind of interlacing error "baked into" some of the clips?!

Regarding monitoring.
I have also been thinking that interlaced will always show the jagged lines on a computer monitor. But I have never seen it as bad as I see it on this film. Or maybe I have just never noticed... Maybe if I could show a picture of it then maybe it would make more sense. Maybe in the next post!

I get very bad jagged lines around anything that moves. When I play the film back in full scale resolution on a computerscreen I don't see anything. But if I scale the player window down I get bad jagged edges. Not so bad when I'm using Quicktime Player, but very bad when I'm using the spacebar shortcut in Finder.
Is this normal?
So how should it look when the field order is played back wrong? And how should it look when it's right?
My image looks very similar to the picture in this post (when viewed at 10-24%) and they are talking about an error in the field order or bad resizing,

Regarding the timeline
So why was the timeline not progressive? Well this film has been on a long road before it ended in my FCP timeline. A great deal has been out of my hands and control, which is why I wasn't reluctant to believe that there WAS an interlace problem. I have merely collected the pieces in FCP.
I'll try and explain... 90% of the original footage IS in fact interlaced, and around 10% are from DSLR's which are progressive. All the material have been transcoded to ProRes 422 using MPEG Streamclip, and after going through this software all the clips are flagged as Upper field order (I've checked using Item/Properties/Format in FCP)). But the clips were first edited in Avid using AMA linking. Then they've been transcoded to mxf files (DNxHD) and moved to DaVinci Resolve where they've been graded. Then transcoded to ProRes 422 in a TARGET MOVIE file (please don't ask..), plus a few individual graded clips have been rendered out of Resolve as ProRes 422. Most of these files are now flagged as NONE in field order (?) which I believed was causing the interlacing error. On top of this a few files have been rendered out of Avid in ProRes, some are flagged NONE, some are flagged UPPER, but they all were collected in a timeline in FCP.

Maybe there is nothing wrong with mixing all these files together in FCP despite the wrong flagging in the field order for some of them, but why does two studios reject my film then?
What I am looking for is a 100% method to tell if the fields are actually all in the right order? And a fix for it if they aren't? I would like a STONE SURE WAY of knowing that a field error has NOT been "baked into" a progressive timeline along the way and exported along with this error within it?

I have tried adding the Shift Field filter to the clips in the timeline, but THEN it starts stuttering horribly when I view it on my monitors.
I have tried right-clicking all the clips in the timeline and manually choosing Upper field using Item/Properties/Format. But there are no visible difference so I don't know if this makes any difference.

Return to posts index

Jeff Meyer
Re: field dominance problem
on Jan 10, 2012 at 3:42:03 am

You will not see any field dominance issues on a computer display. The 100% confident way to see these issues is to use an I/O and a monitor, and to quality control your output off of a deck prior to delivering. Computer displays are very different from TVs. Don't trust what you see on a computer - particularly when scaling footage. This could be why you see some issues using Quick Look in Finder..footage is often scaled when previewed. It's difficult to build a shelf without essential tools, like a hammer. It's also difficult to produce a TV program without a TV. You're blind without monitoring.

Shift fields is useful if you have content with the wrong dominance (lower when you need upper) but it isn't useful for content with no dominance. Normal dominance for SD is lower and for HD it is upper. SD footage needs a shift fields filter if it hasn't had one. If the SD footage had a shift fields baked in upstream and you add a shift fields the dominance will be incorrect.

When going through Streamclip you need to pick the Options after picking ProRes422, pick two fields, and pick even or odd. Often with ProRes getting interlacing is takes two steps, you have to tell the program to export fields and tell the ProRes encoder to be interlaced. If you didn't look into interlacing when taking the content through Streamclip you easily could have introduced a field dominance issue. I find Compressor to be more intuitive to use, and Adobe Media Encoder is my preferred tool for transcoding footage. Streamclip feels rather unintuitive every time I open it up. In Compressor pick the ProRes preset, then on the Encoder portion go to the Settings for video and you should be able to pick Interlaced. Make sure every video is interlaced before submitting a job.

Working with interlaced footage requires due diligence at every step of the workflow, otherwise you end up scratching your head at the end. If the studio is having a slow day perhaps you'll be able to tie up a deck for an hour or two and make notes of what does/doesn't look correct and go from there, but I wouldn't bet on you being able to do that.

Return to posts index

Esben Hardt
Re: field dominance problem
on Jan 10, 2012 at 5:14:10 pm

Ok, just to make it clear. The picture above looks like this on BOTH my 3 studio monitors (see specs at top) AND the computer screens. The picture looked like this on the footage coming from Resolve or Avid. I have a sneaky suspicion that the clip has been scaled slightly in one of these applications, in other words it has zoomed in on an interlacing error. Maybe interlaced footage has been added to a progressive workflow somewhere along the line, I don't know..?

The fix? I went back to Avid, and asked for an export of this clip again in 100% scale, then zoomed into the picture in FCP, bypassing Resolve. Problem gone!

Return to posts index

Esben Hardt
Re: field dominance problem
on Jan 10, 2012 at 5:21:55 pm

PS. The master file was cleared today in a third studo looking at a top-of-the-line Sony grading monitor. now I awaiting the final judgement from the TV distributor....

Return to posts index

Fabrizio D'Agnano
Re: field dominance problem
on Feb 15, 2012 at 9:28:22 pm

I am having the same problem with footage coming from a Canon HF-S100. FCP interpretates it wrong, labeling it with "none" as a field order. I am using the following walk around: in the browser, I set the clips to the correct "upper" before I drag them on the sequence. Just to make sure I did not forget anything, before delivering I select all the video in the sequence (no audio), check item properties (from the timeline, not the browser) and correct files that may be wrong. Then I export a video clip with the proves settings, and place it into a sequence with the master tape settings (HDV or DV). I am now sure everything is fine. Conforming to sequence will cause a zoom in is the clip is HD and the timeline is SD, so I find it best not to copy and paste the sequence's clips in the new timeline, but the file I exported. Hope this helps.
Fabrizio D'Agnano
Rome, Italy

Fabrizio D'Agnano
Rome, Italy

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 All Rights Reserved