FORUMS: list search recent posts

Canon EOS Plugin/Lion/"contains unsupported media"

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
elise london
Canon EOS Plugin/Lion/"contains unsupported media"
on Jan 4, 2012 at 3:12:40 am

Hi -- I have used the Canon EOS plugin trillions of times to transcode video from my Canon 7D. I know full well to keep the folder hierarchy intact and am always sure to do so and I never had any issues on my previous laptop running Snow Leopard.

Now I'm on my newish laptop running Lion. All of a sudden, EOS Plugin is not recognizing SOME my folders, EVEN THOUGH THE HIERARCHY IS INTACT. On some folders it recognizes it just fine, then in others it refuses!

FOLDER "contains unsupported media or has an invalid directory structure. Please choose a folder whose directory structure matches supported media."

What's going on?? Please help!!! :)


Return to posts index

Colin McQuillan
Re: Canon EOS Plugin/Lion/"contains unsupported media"
on Jan 4, 2012 at 4:13:09 am

There could be corrupt media in the folder or your hard drive may be on the way out.

The only time I have had this issue was trying to import footage from a hard-drive that was failing.

Colin McQuillan
Vancouver, B.C.



Return to posts index

elise london
Re: Canon EOS Plugin/Lion/"contains unsupported media"
on Jan 4, 2012 at 4:31:47 am

Thanks for the response but I do not think this is the issue.
First of all, it is happening with media on multiple drives, not just one.
Also, the plugin is not even reading test footage that I shot, directly off the card!

Any other ideas anyone?


Return to posts index


Jeremy Garchow
Re: Canon EOS Plugin/Lion/"contains unsupported media"
on Jan 4, 2012 at 4:44:36 am

Do the encompassing folders have illegal characters, like "#"?

Jeremy


Return to posts index

elise london
Re: Canon EOS Plugin/Lion/"contains unsupported media"
on Jan 4, 2012 at 5:07:31 am

Nope, not at all. I always create simple folders ie "01" "02" etc. Then the original "DCIM" and "MISC" folders are intact inside. I cannot figure out why it would not recognize them.


Return to posts index

Jeremy Garchow
Re: Canon EOS Plugin/Lion/"contains unsupported media"
on Jan 4, 2012 at 5:12:24 am

Are there also photos along with the video in there? Try moving the photos out of the main EOS folder.

Jeremy


Return to posts index


elise london
Re: Canon EOS Plugin/Lion/"contains unsupported media"
on Jan 4, 2012 at 5:35:42 am

Jeremy -- good idea but I just tried it and no dice. :(
Phil -- Thanks but some of the media that is failing is media that has NEVER been imported before. Also I am having trouble trashing my prefs manually. Now in Lion I cannot find the folder called "Final Cut Pro User Data" and neither can I find "com.apple.finalcutpro.plist" file. I was only able to trash my prefs by using a program called "Preference Manager" which said that it deleted them.

Any other ideas anyone??


Return to posts index

Jeremy Garchow
Re: Canon EOS Plugin/Lion/"contains unsupported media"
on Jan 4, 2012 at 6:13:50 am

[elise london] "Now in Lion I cannot find the folder called "Final Cut Pro User Data" and neither can I find "com.apple.finalcutpro.plist" file."

The library folder is hidden in lion. See here:

http://reviews.cnet.com/8301-13727_7-20082044-263/os-x-lion-where-did-my-li...

Do you have v1.2 of the E1 plugin installed? I haven't tried it with lion, so maybe it doesnt work? Don't know, but I think it should.

Can you post your file structure? What does the "EOS" file say in the DCIM folder?


Return to posts index

Phil Balsdon
Re: Canon EOS Plugin/Lion/"contains unsupported media"
on Jan 4, 2012 at 5:13:32 am

I've had similar problem which rectified after doing a "Trash Preferences"

Also I seem to remember reading somewhere that updated versions (I think it's now in it's second or third version) of the EOS plugin were not compatible with re-importing media previously imported with an earlier version.

Cinematographer, Steadicam Operator, Final Cut Pro Post Production.
http://philming.com.au
http://www.steadi-onfilms.com.au/


Return to posts index


elise london
Re: Canon EOS Plugin/Lion/"contains unsupported media"
on Jan 4, 2012 at 6:09:43 am

OKAY I FIGURED IT OUT by doing deeper into this forum. Apparently the particular footage I was working with was from the T2i (I have both cameras so I was mistaken when I said 7D.) I had to hack the plugin to make it read the T2i footage and now it works.

You have to hack the plugin.

Found this a while back somewhere

1. Install the new Canon EOS MOVIE Plugin-E1 for Final Cut Pro (http://www.usa.canon.com/consumer/co...nloadDetailAct)

2. Go to Library/Application Support/ProApps/MIO/RAD/Plugins/CanonE1.RADPLug/Contents/Resources/

2. Open up cameras.plist (this didn't work when I opened up the file in TextEdit or a word processor, I had to use TextWrangler or BBedit) I would also back up the file before opening it.

3. After the 7D info add the following lines of code (keeping to the coding structure):

T2i

Canon EOS REBEL T2i


4. Save the text file. Close it. Everything should work now.



Return to posts index

Jeremy Garchow
Re: Canon EOS Plugin/Lion/"contains unsupported media"
on Jan 4, 2012 at 6:17:11 am

Ah. Yep, that'll do it.

Good sleuthing.


Return to posts index

elise london
Re: Canon EOS Plugin/Lion/"contains unsupported media"
on Jan 4, 2012 at 6:34:59 am

Strange that I didn't need to hack the plugin last time for use with the t2i, but hey, it works, that's all that matters!


Return to posts index


Jeremy Garchow
Re: Canon EOS Plugin/Lion/"contains unsupported media"
on Jan 4, 2012 at 6:49:28 am

[elise london] "Strange that I didn't need to hack the plugin last time for use with the t2i, but hey, it works, that's all that matters!
"


Maybe it was prehacked!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]