FORUMS: list search recent posts

Keying out graphic from single-layered, red background JPG

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Mick Parker
Keying out graphic from single-layered, red background JPG
on Dec 22, 2011 at 9:03:40 pm

Hi there- new to this forum. Saw a ton of CC threads come up when searching for similar solutions. I searched through the past threads here on the FCP forum but still couldn't find anything that relates. Hopefully someone here can shed some light for me.

I have a client who has given me a jpg with a monochrome graphic which has many shades of grey, from black to white. The background on this single layer is a pure red and I cannot, for the life of me, get this to key over their video.

I've tried using the Chroma Keyer and eye-dropping the background, adjusting the Saturation and Luminance sliders to bring in the lighter shades of the graphic (it has a drop-shadow), but it still looks choppy and there's a smaller part that it omitted completely.

The closest I've been able to get is by using the Channel Mixer, converting to Monochrome, and playing around with the Alpha Output and Red Output sliders, but I'm wondering (hoping?) there's a more efficient way.

If anyone has a sec to chime in, I'd be curious to see what the more experienced folks say. Is my playing with the Channel Mixer the best that can be done since the original image is a single layer, and not set up with an alpha channel?

Thanks,
Mick

MBP w/4GB RAM
FCP7
CS4


Return to posts index

jerry wise
Re: Keying out graphic from single-layered, red background JPG
on Dec 22, 2011 at 9:44:14 pm

i would politely ask the client to provide you with a graphic with an alpha channel.


Return to posts index

Mark Suszko
Re: Keying out graphic from single-layered, red background JPG
on Dec 22, 2011 at 9:59:15 pm

Assuming the clisnt has no idea what an alpha channel is or etc. I would take this into photoshop and use the selection tools there; worst case you could use it to trace out each part and give it it's own layer there. This would be way faster than messing with the keyer, and higher rez too.


Return to posts index


jerry wise
Re: Keying out graphic from single-layered, red background JPG
on Dec 22, 2011 at 10:32:40 pm

attach the offending graphic so we can take a look at it.


Return to posts index

Stephen Smith
Re: Keying out graphic from single-layered, red background JPG
on Dec 23, 2011 at 3:33:28 pm

If we are just talking about one jpeg that you need to cut the background out of you should use Photoshop if you have it. Check out this tutorial that showcases its amazing ability to cut stuff out...it doesn't always work that easy but this gives you an idea.







Stephen Smith
Utah Video Productions

Check out my Motion Training DVD

Check out my Vimeo page


Return to posts index

Mick Parker
Re: Keying out graphic from single-layered, red background JPG
on Dec 23, 2011 at 5:19:59 pm

Thanks for all the replies, gents-

Unfortunately, I:

-Cannot ask for an alpha-channeled version of the graphic, or share the images with you due to its confidentiality.
-Cannot use the selection tools to cut it out, since there's drop shadow on it and the gradient falls off from dark grey to red, and I need to retain that drop shadow in the final product.
-Cannot utilize the magical new features of CS5, as I'm still on CS4.

I'm fairly pleased with what I have now, by using the channel mixer and if this is the best I can get, then I guess that'll have to do for now.

Thanks again for the replies.
-M


Return to posts index


Stephen Smith
Re: Keying out graphic from single-layered, red background JPG
on Dec 23, 2011 at 5:42:04 pm

CS4 has amazing tools to cut items out as well. If you want I can dig up a tutorial.

Stephen Smith
Utah Video Productions

Check out my Motion Training DVD

Check out my Vimeo page


Return to posts index

Gary Milligan
Re: Keying out graphic from single-layered, red background JPG
on Dec 23, 2011 at 6:06:37 pm

[Mick Parker] "I'm fairly pleased with what I have now, by using the channel mixer and if this is the best I can get, then I guess that'll have to do for now."

If you're pleased with what you have, that's a good thing... you're good to go. Here is what I would do: use the magic wand in Photoshop to get rid of the red background, then work with the selection tools to cut off the reddish drop shadow to end up with just the monochrome graphic, and finally, add a drop shadow back onto it.

HTH

Gary

This is me - this is what I do - http://web.mac.com/garymmw


Return to posts index

Stephan Walfridsson
Re: Keying out graphic from single-layered, red background JPG
on Dec 25, 2011 at 12:03:08 am

If the red is truly pure and there isn't to much jpeg compression artifacts then here is how I would do it in Final Cut:

1. Duplicate the logo as a new master clip (in the browser). (Let's call this copy "Matte")

2. Add a Channel swap filter to the Original master clip and set Red from -> Green. This will remove the red and leave a monochrome logo on black. (Let's call this clip "Logo on black")

3. Add a Compound arithmetic filter on the "Matte" clip and drag the "Logo on black" into the image well. Set operator to Subtract and Channel to RGB.

4. Add a Channel swap filter to the "Matte" clip and set Alpha from -> Inverse Red. Now we have a nice matte for the logo and dropshadow.

5. Place the "Matte" clip on one track and the Logo (on black) clip above. Change the Composite Mode of the logo clip to Travel Matte - Alpha.

(6. Nest the logo and matte clip if you need to reposition them.)


Alternatively (and preferably) you could prepare the logo in Photoshop:

0. Load the logo image and unlock the background by converting it to a normal layer.

1. Select menu Image -> Calculations. Set Source 1 channel to Green and Source 2 channel to Red. Set blending to "Subtract" and Result to New Channel.

2. A new alpha channel will be created. Select this channel and invert it. This is the matte for the logo and dropshadow.

3. Swap the green channel into the red by selecting menu Image -> Adjustments -> Channel Mixer and set output channel to Red, Source channel Red to 0% and Green to 100%.

4. Save as a tif image with alpha channel.


Stephan


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]