FORUMS: list search recent posts

Rendered progressive but recognized by FCP as upper field first

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Esky Ching
Rendered progressive but recognized by FCP as upper field first
on Dec 14, 2011 at 4:48:05 am

Hi Everyone,

I have some motion graphics to overlay on top of the footage in FCP.

I rendered the motion graphic part from After Effects with codecs:

ProRes4444 RGBA straight/premultiplied
Animation RGBA

Neither of them are properly interpreted in FCP as progressive.
In FCP file browser, the footage is properly label "Field Dominance = None"
And of course my FCP sequence is progressive

Sometimes by reconnecting the footage (AE render files, even same file) will solve the problem, but most of the time it does not.

I have really no idea. Any clues?
Thanks.

----
After Effects CS5
FCP Pro 7.0.3
OS X Lion 10.7.2 on latest gen Mac Pro 8 core


Return to posts index

Bret Williams
Re: Rendered progressive but recognized by FCP as upper field first
on Dec 14, 2011 at 5:42:22 am

So what's the problem? None=progressive.


Return to posts index

Esky Ching
Re: Rendered progressive but recognized by FCP as upper field first
on Dec 14, 2011 at 6:06:37 am

Sorry. Maybe I did not make myself clear.
FCP detects and interprets the footage as progressive, but it renders as upper field first. (i.e. with jagged edge). It should be perfectly smooth for the curve/edge.

Should look like:


FCP gives:


Return to posts index


Bill Russell
Re: Rendered progressive but recognized by FCP as upper field first
on Dec 14, 2011 at 7:52:47 am

Which FCP are you using, and what are you viewing on? Check to make sure the render indicator is fully gray and not subtly green (hard to see). Sometimes the "subtly green", what's supposed to be full real-time, gives you low-rez frames until you fully render. Change render settings in menus. Also, computer display unreliable, sometimes single-field (half frame for progressive) without telling you -- only true view is through third-party video monitoring.

"THE LOST SKELETON OF CADAVRA" -

And more...


Return to posts index

Esky Ching
Re: Rendered progressive but recognized by FCP as upper field first
on Dec 14, 2011 at 8:22:45 am

I use FCP 7.0.3, everything is fully rendered.

Re-checking the file exported from After Effects in FCP's Viewer window, it looks fine!!!

The jagged edge only appears when I put the AE rendered file in FCP sequence.

The video footage below does not show any sign of interlacing, therefore I am pretty sure it does not relate to video monitoring or something.

My sequence setting:



Very interestingly, if I change the Sequence, Settingsā€¦, Field Dominance from "None" to "Upper (Odd)", it shows perfect smoothness.

Strange...


Return to posts index

Esky Ching
Re: Rendered progressive but recognized by FCP as upper field first
on Dec 14, 2011 at 8:58:30 am

Just to update...
When I drag the AE rendered file to the timeline it shows jagged edge.
When I open the AE rendered file in Viewer, drag it from Viewer to Canvas it does not show jagged edge!!!

I think this is a bug of FCP...

Problem solved. Thanks.


Return to posts index


Bill Russell
Re: Rendered progressive but recognized by FCP as upper field first
on Dec 14, 2011 at 9:52:36 am

I wager if you export a short piece of the "jagged edge version" then open the Quicktime movie you'll find that it's really not jagged, but merely FCP's knack for capricious display on desktop (which does display as jaggies on the horizontal but is actually something other than interlacing per se; as opposed to the actual video signal it generates, only viewable on external hardware) -- so yes random and buggish I think and harmless. Anyway, you've got an easy work-around -- cheers!

BTW this "FULL" unchecked in rendering is what to watch out for: http://imgur.com/2r1i0 - note subtle green line on right clip.

"THE LOST SKELETON OF CADAVRA" -

And more...


Return to posts index

Esky Ching
Re: Rendered progressive but recognized by FCP as upper field first
on Dec 14, 2011 at 10:06:47 am

I did export that part and it was jagged. ;)
Not so sure why...

Anyhow it works now.
:)


Return to posts index

Rafael Amador
Re: Rendered progressive but recognized by FCP as upper field first
on Dec 14, 2011 at 2:50:31 pm

Set "Render all YUV in High Precision", "Render Motion Effects BEST", and make sure that your canvas window is set to 100%.

[Esky Ching] "ProRes4444 RGBA straight/premultiplied"
Strait or Premultiplied?
Both at the same time is not possible.
To avoid problems with FC, better Strait.

rafael

http://www.nagavideo.com


Return to posts index


Dave LaRonde
Re: Rendered progressive but recognized by FCP as upper field first
on Dec 14, 2011 at 6:04:32 pm

Check the footage in the FCP Browser. You may find that FCP has changed the field order from None to something else. Just change it back.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]